summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2009-02-02 17:30:20 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2009-02-02 17:30:20 +0000
commitcdac338bc9264df173e104aa785e1caacfb80c78 (patch)
treedf50d1f7553f0feb034f20d1c201cd6ae9ee5e67 /net-misc
parentversion bump: Ebuild changes include port to EAPI=2, proper dependencies for ... (diff)
downloadgentoo-2-cdac338bc9264df173e104aa785e1caacfb80c78.tar.gz
gentoo-2-cdac338bc9264df173e104aa785e1caacfb80c78.tar.bz2
gentoo-2-cdac338bc9264df173e104aa785e1caacfb80c78.zip
Version Bump
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/axel/axel-2.3.ebuild17
1 files changed, 13 insertions, 4 deletions
diff --git a/net-misc/axel/axel-2.3.ebuild b/net-misc/axel/axel-2.3.ebuild
index 3cf18408971b..33b1b7cda34c 100644
--- a/net-misc/axel/axel-2.3.ebuild
+++ b/net-misc/axel/axel-2.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/axel/axel-2.3.ebuild,v 1.1 2009/02/02 17:17:48 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/axel/axel-2.3.ebuild,v 1.2 2009/02/02 17:30:20 drizzt Exp $
-inherit toolchain-funcs
+inherit eutils toolchain-funcs
DESCRIPTION="light Unix download accelerator"
HOMEPAGE="http://axel.alioth.debian.org/"
@@ -10,12 +10,14 @@ SRC_URI="http://alioth.debian.org/frs/download.php/2287/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="debug nls"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="debug kde nls"
RDEPEND="nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
+RDEPEND="${RDEPEND}
+ kde? ( kde-misc/kaptain )"
S="${WORKDIR}/${PN}-1.1"
@@ -42,6 +44,13 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
+
+ if use kde; then
+ dobin gui/kapt/axel-kapt || die
+ doman gui/kapt/axel-kapt.1 || die
+ domenu gui/kapt/axel-kapt.desktop || die
+ fi
+
dodoc API CHANGES CREDITS README axelrc.example
}