summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2013-08-09 17:08:49 +0000
committerDoug Goldstein <cardoe@gentoo.org>2013-08-09 17:08:49 +0000
commitcdc424dbe980e07bc989d50b99aa6c341c61e13b (patch)
tree3a8ba6c7bd01dd542ce15fd17e8f870a36f81a24 /net-misc
parentclean up (diff)
downloadgentoo-2-cdc424dbe980e07bc989d50b99aa6c341c61e13b.tar.gz
gentoo-2-cdc424dbe980e07bc989d50b99aa6c341c61e13b.tar.bz2
gentoo-2-cdc424dbe980e07bc989d50b99aa6c341c61e13b.zip
Fix missing symbol in SpiceClientGtk Python module. Identified by X4 <worldwide@online.de> on bug #480146. rhbz#981815
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key D7DFA8D318FA9AEF!)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/spice-gtk/ChangeLog10
-rw-r--r--net-misc/spice-gtk/files/spice-gtk-0.20-add-spice-channel-string-to-type.patch84
-rw-r--r--net-misc/spice-gtk/spice-gtk-0.20-r1.ebuild172
3 files changed, 265 insertions, 1 deletions
diff --git a/net-misc/spice-gtk/ChangeLog b/net-misc/spice-gtk/ChangeLog
index 842121d8cd5e..13c2a6c4bb26 100644
--- a/net-misc/spice-gtk/ChangeLog
+++ b/net-misc/spice-gtk/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/spice-gtk
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/spice-gtk/ChangeLog,v 1.63 2013/08/08 09:41:42 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/spice-gtk/ChangeLog,v 1.64 2013/08/09 17:08:49 cardoe Exp $
+
+*spice-gtk-0.20-r1 (09 Aug 2013)
+
+ 09 Aug 2013; Doug Goldstein <cardoe@gentoo.org>
+ +files/spice-gtk-0.20-add-spice-channel-string-to-type.patch,
+ +spice-gtk-0.20-r1.ebuild:
+ Fix missing symbol in SpiceClientGtk Python module. Identified by X4
+ <worldwide@online.de> on bug #480146. rhbz#981815
08 Aug 2013; Agostino Sarubbo <ago@gentoo.org> spice-gtk-0.20.ebuild:
Stable for amd64, wrt bug #480146
diff --git a/net-misc/spice-gtk/files/spice-gtk-0.20-add-spice-channel-string-to-type.patch b/net-misc/spice-gtk/files/spice-gtk-0.20-add-spice-channel-string-to-type.patch
new file mode 100644
index 000000000000..3375d801ab2d
--- /dev/null
+++ b/net-misc/spice-gtk/files/spice-gtk-0.20-add-spice-channel-string-to-type.patch
@@ -0,0 +1,84 @@
+From b85ca792af72d5f1e10aa6af9515eb96a044fc5c Mon Sep 17 00:00:00 2001
+From: Hans de Goede <hdegoede@redhat.com>
+Date: Wed, 26 Jun 2013 15:39:39 +0000
+Subject: Add spice_channel_string_to_type to map files
+
+And document both spice_channel_string_to_type and
+spice_channel_type_to_string.
+
+Signed-off-by: Hans de Goede <hdegoede@redhat.com>
+---
+diff --git a/doc/reference/spice-gtk-sections.txt b/doc/reference/spice-gtk-sections.txt
+index e1e2833..8d61aa9 100644
+--- a/doc/reference/spice-gtk-sections.txt
++++ b/doc/reference/spice-gtk-sections.txt
+@@ -98,6 +98,7 @@ spice_channel_disconnect
+ spice_channel_test_capability
+ spice_channel_test_common_capability
+ spice_channel_type_to_string
++spice_channel_string_to_type
+ spice_channel_set_capability
+ spice_channel_flush_async
+ spice_channel_flush_finish
+diff --git a/gtk/map-file b/gtk/map-file
+index a0b7330..a69eb40 100644
+--- a/gtk/map-file
++++ b/gtk/map-file
+@@ -11,6 +11,7 @@ spice_channel_get_type;
+ spice_channel_new;
+ spice_channel_open_fd;
+ spice_channel_set_capability;
++spice_channel_string_to_type;
+ spice_channel_test_capability;
+ spice_channel_test_common_capability;
+ spice_channel_type_to_string;
+diff --git a/gtk/spice-channel.c b/gtk/spice-channel.c
+index 0a32d6c..093b292 100644
+--- a/gtk/spice-channel.c
++++ b/gtk/spice-channel.c
+@@ -1884,6 +1884,15 @@ static const char *to_string[] = {
+ [ SPICE_CHANNEL_PORT ] = "port",
+ };
+
++/**
++ * spice_channel_type_to_string:
++ * @type: a channel-type property value
++ *
++ * Convert a channel-type property value to a string.
++ *
++ * Returns: string representation of @type.
++ * Since: 0.20
++ **/
+ const gchar* spice_channel_type_to_string(gint type)
+ {
+ const char *str = NULL;
+@@ -1895,6 +1904,15 @@ const gchar* spice_channel_type_to_string(gint type)
+ return str ? str : "unknown channel type";
+ }
+
++/**
++ * spice_channel_string_to_type:
++ * @str: a string representation of the channel-type property
++ *
++ * Convert a channel-type property value to a string.
++ *
++ * Returns: the channel-type property value for a @str channel
++ * Since: 0.21
++ **/
+ gint spice_channel_string_to_type(const gchar *str)
+ {
+ int i;
+diff --git a/gtk/spice-glib-sym-file b/gtk/spice-glib-sym-file
+index 2b172d0..8540307 100644
+--- a/gtk/spice-glib-sym-file
++++ b/gtk/spice-glib-sym-file
+@@ -14,6 +14,7 @@ spice_channel_set_capability
+ spice_channel_test_capability
+ spice_channel_test_common_capability
+ spice_channel_type_to_string
++spice_channel_string_to_type
+ spice_client_error_quark
+ spice_cursor_channel_get_type
+ spice_display_channel_get_type
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/net-misc/spice-gtk/spice-gtk-0.20-r1.ebuild b/net-misc/spice-gtk/spice-gtk-0.20-r1.ebuild
new file mode 100644
index 000000000000..9ac27635acf1
--- /dev/null
+++ b/net-misc/spice-gtk/spice-gtk-0.20-r1.ebuild
@@ -0,0 +1,172 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/spice-gtk/spice-gtk-0.20-r1.ebuild,v 1.1 2013/08/09 17:08:49 cardoe Exp $
+
+EAPI=5
+GCONF_DEBUG="no"
+WANT_AUTOMAKE="1.12"
+VALA_MIN_API_VERSION="0.14"
+VALA_USE_DEPEND="vapigen"
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit eutils python-single-r1 vala
+
+PYTHON_DEPEND="2"
+
+DESCRIPTION="Set of GObject and Gtk objects for connecting to Spice servers and a client GUI."
+HOMEPAGE="http://spice-space.org http://gitorious.org/spice-gtk"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+SRC_URI="http://spice-space.org/download/gtk/${P}.tar.bz2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="dbus doc gstreamer gtk3 +introspection policykit pulseaudio
+python sasl smartcard static-libs usbredir vala"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ ?? ( pulseaudio gstreamer )"
+
+# TODO:
+# * check if sys-freebsd/freebsd-lib (from virtual/acl) provides acl/libacl.h
+# * use external pnp.ids as soon as that means not pulling in gnome-desktop
+RDEPEND="${PYTHON_DEPS}
+ pulseaudio? ( media-sound/pulseaudio[glib] )
+ gstreamer? (
+ media-libs/gstreamer:0.10
+ media-libs/gst-plugins-base:0.10 )
+ >=x11-libs/pixman-0.17.7
+ >=media-libs/celt-0.5.1.1:0.5.1
+ dev-libs/openssl
+ gtk3? ( x11-libs/gtk+:3[introspection?] )
+ x11-libs/gtk+:2[introspection?]
+ >=dev-libs/glib-2.26:2
+ >=x11-libs/cairo-1.2
+ virtual/jpeg
+ sys-libs/zlib
+ dbus? ( dev-libs/dbus-glib )
+ introspection? ( dev-libs/gobject-introspection )
+ python? ( dev-python/pygtk:2 )
+ sasl? ( dev-libs/cyrus-sasl )
+ smartcard? ( app-emulation/libcacard )
+ usbredir? (
+ sys-apps/hwids
+ >=sys-apps/usbredir-0.4.2
+ virtual/libusb:1
+ virtual/udev[gudev]
+ policykit? (
+ sys-apps/acl
+ >=sys-auth/polkit-0.101 )
+ )"
+DEPEND="${RDEPEND}
+ dev-lang/python
+ virtual/pyparsing
+ dev-perl/Text-CSV
+ >=dev-util/intltool-0.40.0
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )"
+
+# Hard-deps while building from git:
+# dev-lang/vala:0.14
+# dev-lang/perl
+
+GTK2_BUILDDIR="${WORKDIR}/${P}_gtk2"
+GTK3_BUILDDIR="${WORKDIR}/${P}_gtk3"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ mkdir ${GTK2_BUILDDIR} ${GTK3_BUILDDIR} || die
+
+ epatch "${FILESDIR}"/${P}-add-spice-channel-string-to-type.patch
+}
+
+src_configure() {
+ local myconf
+ local audio="no"
+
+ use gstreamer && audio="gstreamer"
+ use pulseaudio && audio="pulse"
+
+ if use vala ; then
+ # force vala regen for MinGW, etc
+ rm -fv gtk/controller/controller.{c,vala.stamp} gtk/controller/menu.c
+ fi
+
+ myconf="
+ $(use_enable static-libs static) \
+ $(use_enable introspection) \
+ --with-audio=${audio} \
+ $(use_with python) \
+ $(use_with sasl) \
+ $(use_enable smartcard) \
+ $(use_enable usbredir) \
+ $(use_with usbredir usb-ids-path /usr/share/misc/usb.ids) \
+ $(use_with usbredir usb-acl-helper-dir /usr/libexec) \
+ $(use_enable policykit polkit) \
+ $(use_enable vala) \
+ $(use_enable dbus) \
+ $(use_enable doc gtk-doc) \
+ --disable-werror \
+ --enable-pie"
+
+ cd ${GTK2_BUILDDIR}
+ echo "Running configure in ${GTK2_BUILDDIR}"
+ ECONF_SOURCE="${S}" econf --disable-maintainer-mode \
+ --with-gtk=2.0 \
+ ${myconf}
+
+ if use gtk3; then
+ cd ${GTK3_BUILDDIR}
+ echo "Running configure in ${GTK3_BUILDDIR}"
+ ECONF_SOURCE="${S}" econf --disable-maintainer-mode \
+ --with-gtk=3.0 \
+ ${myconf}
+ fi
+}
+
+src_compile() {
+ cd ${GTK2_BUILDDIR}
+ einfo "Running make in ${GTK2_BUILDDIR}"
+ default
+
+ if use gtk3; then
+ cd ${GTK3_BUILDDIR}
+ einfo "Running make in ${GTK3_BUILDDIR}"
+ default
+ fi
+}
+
+src_test() {
+ cd ${GTK2_BUILDDIR}
+ einfo "Running make check in ${GTK2_BUILDDIR}"
+ default
+
+ if use gtk3; then
+ cd ${GTK3_BUILDDIR}
+ einfo "Running make check in ${GTK3_BUILDDIR}"
+ default
+ fi
+}
+
+src_install() {
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+
+ cd ${GTK2_BUILDDIR}
+ einfo "Running make check in ${GTK2_BUILDDIR}"
+ default
+
+ if use gtk3; then
+ cd ${GTK3_BUILDDIR}
+ einfo "Running make install in ${GTK3_BUILDDIR}"
+ default
+ fi
+
+ # Remove .la files if they're not needed
+ use static-libs || prune_libtool_files
+
+ use python && rm -rf "${ED}"/usr/lib*/python*/site-packages/*.la
+
+ make_desktop_entry spicy Spicy "utilities-terminal" "Network;RemoteAccess;"
+}