summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-05-18 11:11:44 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-05-18 11:11:44 +0000
commitd56e7a40b007cfa064b997efac58ae76f69f6f59 (patch)
tree4cdd6e2249cbf4c35f102e96897c5ea1495aedfc /net-misc
parentkeyword amd64-linux and x86-linux; handle data dir via envd; fix clhep linking (diff)
downloadgentoo-2-d56e7a40b007cfa064b997efac58ae76f69f6f59.tar.gz
gentoo-2-d56e7a40b007cfa064b997efac58ae76f69f6f59.tar.bz2
gentoo-2-d56e7a40b007cfa064b997efac58ae76f69f6f59.zip
Version bump
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/vidalia/ChangeLog7
-rw-r--r--net-misc/vidalia/vidalia-0.2.18.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/net-misc/vidalia/ChangeLog b/net-misc/vidalia/ChangeLog
index 2becc3187347..d144ab4a8f4b 100644
--- a/net-misc/vidalia/ChangeLog
+++ b/net-misc/vidalia/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/vidalia
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vidalia/ChangeLog,v 1.31 2012/03/27 15:28:42 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vidalia/ChangeLog,v 1.32 2012/05/18 11:11:44 blueness Exp $
+
+*vidalia-0.2.18 (18 May 2012)
+
+ 18 May 2012; Anthony G. Basile <blueness@gentoo.org> +vidalia-0.2.18.ebuild:
+ Version bump
*vidalia-0.3.1 (27 Mar 2012)
diff --git a/net-misc/vidalia/vidalia-0.2.18.ebuild b/net-misc/vidalia/vidalia-0.2.18.ebuild
new file mode 100644
index 000000000000..b6fa157f9c5e
--- /dev/null
+++ b/net-misc/vidalia/vidalia-0.2.18.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vidalia/vidalia-0.2.18.ebuild,v 1.1 2012/05/18 11:11:44 blueness Exp $
+
+EAPI="4"
+
+inherit eutils qt4-r2 cmake-utils
+# cmake-utils needs to be last, so we get its src_compile()
+
+DESCRIPTION="Qt 4 front-end for Tor"
+HOMEPAGE="https://www.torproject.org/projects/vidalia.html.en"
+SRC_URI="https://www.torproject.org/dist/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-3 GPL-2 ) openssl"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug +tor"
+
+DEPEND="x11-libs/qt-gui:4[debug?]"
+RDEPEND="${DEPEND}
+ tor? ( net-misc/tor )"
+
+DOCS="CHANGELOG CREDITS README"
+
+pkg_postinst() {
+ ewarn
+ if use tor; then
+ ewarn "To have vidalia starting tor, you probably have to copy"
+ ewarn "/etc/tor/torrc.sample to the users ~/.tor/torrc and comment"
+ ewarn "the settings there and change the socks. Also, in vidalia"
+ ewarn "change the default user under which tor will run."
+ else
+ ewarn "You have disabled tor USE flag, which means you need to "
+ ewarn "configure tor on a different host."
+ fi
+ ewarn
+}