summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda XU <heroxbd@gentoo.org>2013-04-01 10:32:20 +0000
committerBenda XU <heroxbd@gentoo.org>2013-04-01 10:32:20 +0000
commitd71ae3a687d3f2524d269d0f606f1fd5e16f444b (patch)
tree7f29fffddb8152813ee7765cd445ce1697b18d69 /net-misc
parentRevision bump. Package was forcing debug on everyone, resolved by only passin... (diff)
downloadgentoo-2-d71ae3a687d3f2524d269d0f606f1fd5e16f444b.tar.gz
gentoo-2-d71ae3a687d3f2524d269d0f606f1fd5e16f444b.tar.bz2
gentoo-2-d71ae3a687d3f2524d269d0f606f1fd5e16f444b.zip
version bump for bug #445055. update to EAPI=5. keyword ~arm.
(Portage version: 2.1.11.52/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/unison/ChangeLog10
-rw-r--r--net-misc/unison/unison-2.40.102.ebuild82
-rw-r--r--net-misc/unison/unison-2.45.4.ebuild20
3 files changed, 100 insertions, 12 deletions
diff --git a/net-misc/unison/ChangeLog b/net-misc/unison/ChangeLog
index e06d2a23768a..fda6a2270ef5 100644
--- a/net-misc/unison/ChangeLog
+++ b/net-misc/unison/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/unison
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/ChangeLog,v 1.69 2012/06/18 15:55:24 heroxbd Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/ChangeLog,v 1.70 2013/04/01 10:32:20 heroxbd Exp $
+
+*unison-2.40.102 (01 Apr 2013)
+
+ 01 Apr 2013; Benda Xu <heroxbd@gentoo.org> +unison-2.40.102.ebuild,
+ unison-2.45.4.ebuild:
+ version bump for bug #445055. update to EAPI=5. keyword ~arm.
18 Jun 2012; Benda Xu <heroxbd@gentoo.org> unison-2.27.157.ebuild:
fix patch filename
diff --git a/net-misc/unison/unison-2.40.102.ebuild b/net-misc/unison/unison-2.40.102.ebuild
new file mode 100644
index 000000000000..3eed81f07260
--- /dev/null
+++ b/net-misc/unison/unison-2.40.102.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/unison-2.40.102.ebuild,v 1.1 2013/04/01 10:32:20 heroxbd Exp $
+
+EAPI="5"
+
+inherit eutils versionator
+
+IUSE="gtk doc static debug threads +ocamlopt test"
+
+DESCRIPTION="Two-way cross-platform file synchronizer"
+HOMEPAGE="http://www.cis.upenn.edu/~bcpierce/unison/"
+LICENSE="GPL-2"
+SLOT="$(get_version_component_range 1-2 ${PV})"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+
+# ocaml version so we are sure it has ocamlopt use flag
+DEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]
+ gtk? ( >=dev-ml/lablgtk-2.2 )
+ test? ( || ( dev-util/ctags virtual/emacs ) )"
+
+RDEPEND="gtk? ( >=dev-ml/lablgtk-2.2
+ || ( net-misc/x11-ssh-askpass net-misc/ssh-askpass-fullscreen ) )
+ !net-misc/unison:0
+ app-admin/eselect-unison"
+
+#PDEPEND="gtk? ( media-fonts/font-schumacher-misc )"
+
+SRC_URI="http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}.tar.gz
+ doc? ( http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}-manual.pdf
+ http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}-manual.html )"
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ myconf="$myconf THREADS=true"
+ fi
+
+ if use static; then
+ myconf="$myconf STATIC=true"
+ fi
+
+ if use debug; then
+ myconf="$myconf DEBUGGING=true"
+ fi
+
+ if use gtk; then
+ myconf="$myconf UISTYLE=gtk2"
+ else
+ myconf="$myconf UISTYLE=text"
+ fi
+
+ use ocamlopt || myconf="$myconf NATIVE=false"
+
+ # Discard cflags as it will try to pass them to ocamlc...
+ emake $myconf CFLAGS="" buildexecutable
+}
+
+src_test() {
+ emake selftest
+}
+
+src_install () {
+ # install manually, since it's just too much
+ # work to force the Makefile to do the right thing.
+ newbin unison unison-${SLOT}
+ dodoc BUGS.txt CONTRIB INSTALL NEWS \
+ README ROADMAP.txt TODO.txt
+
+ if use doc; then
+ dohtml "${DISTDIR}/${P}-manual.html"
+ dodoc "${DISTDIR}/${P}-manual.pdf"
+ fi
+ use ocamlopt || export STRIP_MASK="*/bin/*"
+}
+
+pkg_postinst() {
+ elog "Unison now uses SLOTs, so you can specify servercmd=/usr/bin/unison-${SLOT}"
+ elog "in your profile files to access exactly this version over ssh."
+ elog "Or you can use 'eselect unison' to set the version."
+}
diff --git a/net-misc/unison/unison-2.45.4.ebuild b/net-misc/unison/unison-2.45.4.ebuild
index 0f684f0cbecc..c98893bb51db 100644
--- a/net-misc/unison/unison-2.45.4.ebuild
+++ b/net-misc/unison/unison-2.45.4.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/unison-2.45.4.ebuild,v 1.1 2012/06/11 12:28:47 heroxbd Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/unison-2.45.4.ebuild,v 1.2 2013/04/01 10:32:20 heroxbd Exp $
-EAPI="2"
+EAPI="5"
inherit eutils versionator
@@ -12,7 +12,7 @@ DESCRIPTION="Two-way cross-platform file synchronizer"
HOMEPAGE="http://www.cis.upenn.edu/~bcpierce/unison/"
LICENSE="GPL-2"
SLOT="$(get_version_component_range 1-2 ${PV})"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
# ocaml version so we are sure it has ocamlopt use flag
DEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]
@@ -54,23 +54,23 @@ src_compile() {
use ocamlopt || myconf="$myconf NATIVE=false"
# Discard cflags as it will try to pass them to ocamlc...
- emake $myconf CFLAGS="" buildexecutable || die "error making unsion"
+ emake $myconf CFLAGS="" buildexecutable
}
src_test() {
- emake selftest || die "selftest failed"
+ emake selftest
}
src_install () {
# install manually, since it's just too much
# work to force the Makefile to do the right thing.
- newbin unison unison-${SLOT} || die
+ newbin unison unison-${SLOT}
dodoc BUGS.txt CONTRIB INSTALL NEWS \
- README ROADMAP.txt TODO.txt || die
+ README ROADMAP.txt TODO.txt
if use doc; then
- dohtml "${DISTDIR}/${P}-manual.html" || die
- dodoc "${DISTDIR}/${P}-manual.pdf" || die
+ dohtml "${DISTDIR}/${P}-manual.html"
+ dodoc "${DISTDIR}/${P}-manual.pdf"
fi
use ocamlopt || export STRIP_MASK="*/bin/*"
}