summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-05-05 21:29:22 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-05-05 21:29:22 +0000
commitde7368d0b33f3438abb7d8746aa6c8e0c26e32a5 (patch)
treee4f1d76088652625f3c82d3f0a0ba879eec76f07 /net-misc
parentilbc use flag for new linphone (diff)
downloadgentoo-2-de7368d0b33f3438abb7d8746aa6c8e0c26e32a5.tar.gz
gentoo-2-de7368d0b33f3438abb7d8746aa6c8e0c26e32a5.tar.bz2
gentoo-2-de7368d0b33f3438abb7d8746aa6c8e0c26e32a5.zip
Version bump, fixes bugs 108187,113199,116685 and 129194
(Portage version: 2.1_pre10-r2)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/linphone/ChangeLog10
-rw-r--r--net-misc/linphone/files/digest-linphone-1.3.56
-rw-r--r--net-misc/linphone/files/ilbc-1.2.0-makefile.diff13
-rw-r--r--net-misc/linphone/linphone-1.3.5.ebuild97
4 files changed, 124 insertions, 2 deletions
diff --git a/net-misc/linphone/ChangeLog b/net-misc/linphone/ChangeLog
index 0f9c1c70b75e..c20a479444e8 100644
--- a/net-misc/linphone/ChangeLog
+++ b/net-misc/linphone/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/linphone
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/linphone/ChangeLog,v 1.9 2005/09/30 16:23:36 stkn Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/linphone/ChangeLog,v 1.10 2006/05/05 21:29:22 genstef Exp $
+
+*linphone-1.3.5 (05 May 2006)
+
+ 05 May 2006; Stefan Schweizer <genstef@gentoo.org>
+ +files/ilbc-1.2.0-makefile.diff, +linphone-1.3.5.ebuild:
+ Version bump, fixes bugs 108187,113199,116685 and 129194
30 Sep 2005; Stefan Knoblich <stkn@gentoo.org> linphone-1.1.0.ebuild:
Dropping unnecessary gnome-panel dependency, thanks to
diff --git a/net-misc/linphone/files/digest-linphone-1.3.5 b/net-misc/linphone/files/digest-linphone-1.3.5
new file mode 100644
index 000000000000..9fea9935fe17
--- /dev/null
+++ b/net-misc/linphone/files/digest-linphone-1.3.5
@@ -0,0 +1,6 @@
+MD5 522b08a22c5e1de281676cddd3f2bcf6 linphone-1.3.5.tar.gz 7411961
+RMD160 51376621dd9f0b9e8ea1a30aa175680c7b94989d linphone-1.3.5.tar.gz 7411961
+SHA256 b1036fde820c928b877a7065a8e396a7aaf262df125da96c6f6b56f02097a1f3 linphone-1.3.5.tar.gz 7411961
+MD5 26089f758bc7786aa2bad2783c472c7e linphone-plugin-ilbc-1.2.0.tar.gz 334855
+RMD160 0bf4ac7552544cf33126e80ac37e6cfd996ddc3e linphone-plugin-ilbc-1.2.0.tar.gz 334855
+SHA256 33240cce2cb2cd5e46bb6efa332a8687c1ab998432d9c07deeba0866966e22b1 linphone-plugin-ilbc-1.2.0.tar.gz 334855
diff --git a/net-misc/linphone/files/ilbc-1.2.0-makefile.diff b/net-misc/linphone/files/ilbc-1.2.0-makefile.diff
new file mode 100644
index 000000000000..6c24a52596b4
--- /dev/null
+++ b/net-misc/linphone/files/ilbc-1.2.0-makefile.diff
@@ -0,0 +1,13 @@
+--- linphone-plugin-ilbc-1.2.0/Makefile.orig 2006-01-15 21:37:09.000000000 +0100
++++ linphone-plugin-ilbc-1.2.0/Makefile 2006-01-15 21:37:34.000000000 +0100
+@@ -19,8 +19,8 @@
+ MKINSTALLDIRS=$(LINPHONE_SOURCE)/mkinstalldirs
+
+ GLIB_CFLAGS=`pkg-config --cflags glib-2.0`
+-CFLAGS=-g -O2 -pthread -I$(LINPHONE_SOURCE) -I$(LINPHONE_SOURCE)/mediastreamer \
+- -DHAVE_CONFIG_H $(GLIB_CFLAGS) -I$(ILBC_INST_PREFIX)/include/ilbc
++CFLAGS+= -fPIC -pthread -I$(LINPHONE_SOURCE) -I$(LINPHONE_SOURCE)/mediastreamer \
++ -DHAVE_CONFIG_H $(GLIB_CFLAGS) -I$(ILBC_INST_PREFIX)/include/ilbc
+ LDFLAGS=-shared -pthread -L$(ILBC_INST_PREFIX)/lib -lilbc
+
+ .c.o :
diff --git a/net-misc/linphone/linphone-1.3.5.ebuild b/net-misc/linphone/linphone-1.3.5.ebuild
new file mode 100644
index 000000000000..0c4e07918bed
--- /dev/null
+++ b/net-misc/linphone/linphone-1.3.5.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/linphone/linphone-1.3.5.ebuild,v 1.1 2006/05/05 21:29:22 genstef Exp $
+
+inherit eutils
+
+MY_DPV="${PV%.*}.x"
+
+DESCRIPTION="Linphone is a SIP phone with a GNOME interface."
+HOMEPAGE="http://www.linphone.org/?lang=us"
+SRC_URI="http://simon.morlat.free.fr/download/${MY_DPV}/source/${P}.tar.gz
+ ilbc? ( http://simon.morlat.free.fr/download/${MY_DPV}/source/plugins/${PN}-plugin-ilbc-1.2.0.tar.gz )"
+SLOT=1
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="alsa gnome ilbc ipv6 xv"
+# truespeech does not build
+
+RDEPEND="dev-libs/glib
+ dev-perl/XML-Parser
+ net-dns/bind-tools
+ >=net-libs/libosip-2.2.0
+ >=media-libs/speex-1.1.6
+ x86? ( xv? ( dev-lang/nasm ) )
+ gnome? ( >=gnome-base/gnome-panel-2
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=x11-libs/gtk+-2 )
+ alsa? ( media-libs/alsa-lib )
+ ilbc? ( dev-libs/ilbc-rfc3951 )"
+
+DEPEND="${RDEPEND}"
+
+S_ILBC="${WORKDIR}/${PN}-plugin-ilbc-1.2.0"
+
+src_unpack() {
+ unpack ${A}
+ grep " \-Werror" * -Rl | xargs sed -i "s: -Werror::"
+
+ cd ${S}
+ # fix #99083
+ epatch ${FILESDIR}/${PN}-1.0.1-ipv6-include.diff
+
+ cd ${S_ILBC}
+ # add -fPIC and custom cflags to ilbc makefile
+ epatch ${FILESDIR}/ilbc-1.2.0-makefile.diff
+}
+
+src_compile() {
+ local withgnome myconf=""
+
+ if use gnome; then
+ einfo "Building with GNOME interface."
+ withgnome="yes"
+ else
+ withgnome="no"
+ fi
+
+# use x86 && use truespeech && \
+# myconf="--enable-truespeech"
+
+ econf \
+ --enable-glib \
+ --with-speex=/usr \
+ --libdir=/usr/$(get_libdir)/linphone \
+ --enable-gnome_ui=${withgnome} \
+ `use_enable ipv6` \
+ `use_enable alsa` \
+ ${myconf} || die "Unable to configure"
+
+ grep " \-Werror" * -Rl | xargs sed -i "s: -Werror::"
+ emake || die "Unable to make"
+
+ use ilbc && \
+ emake LINPHONE_SOURCE=${S} \
+ PLUGINS_INSTALL_PATH=/usr/$(get_libdir)/linphone/plugins/mediastreamer \
+ -C ${S_ILBC} || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die "Failed to install"
+
+ use ilbc && \
+ make LINPHONE_SOURCE=${S} \
+ PLUGINS_INSTALL_PATH=/usr/$(get_libdir)/linphone/plugins/mediastreamer \
+ DESTDIR=${D} -C ${S_ILBC} install || die
+
+ dodoc ABOUT-NLS AUTHORS BUGS ChangeLog COPYING INSTALL NEWS README
+ dodoc README.arm TODO
+
+ # don't install ortp includes, docs and pkgconfig files
+ # to avoid conflicts with net-libs/ortp
+ rm -rf ${D}/usr/include/ortp
+ rm -rf ${D}/usr/share/gtk-doc/html/ortp
+ rm -rf ${D}/usr/$(get_libdir)/linphone/pkgconfig
+}