summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-12-01 02:04:41 +0000
committerMike Frysinger <vapier@gentoo.org>2011-12-01 02:04:41 +0000
commitf2f2ae7b2b090d60408cc91c598a5da87ea219cd (patch)
tree9b6be8f440185a716a368186d2ca739dfb2ab493 /net-misc
parentInitial commit (diff)
downloadgentoo-2-f2f2ae7b2b090d60408cc91c598a5da87ea219cd.tar.gz
gentoo-2-f2f2ae7b2b090d60408cc91c598a5da87ea219cd.tar.bz2
gentoo-2-f2f2ae7b2b090d60408cc91c598a5da87ea219cd.zip
Switch to pkg-config for looking up openssl #246556 by Rick Farina.
(Portage version: 2.2.0_alpha75/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/wget/ChangeLog8
-rw-r--r--net-misc/wget/files/wget-1.13.4-openssl-pkg-config.patch30
-rw-r--r--net-misc/wget/wget-1.13.4-r1.ebuild76
3 files changed, 113 insertions, 1 deletions
diff --git a/net-misc/wget/ChangeLog b/net-misc/wget/ChangeLog
index a1090407dfe2..d9ccfc1ff4c2 100644
--- a/net-misc/wget/ChangeLog
+++ b/net-misc/wget/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/wget
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/ChangeLog,v 1.147 2011/09/18 23:08:35 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/ChangeLog,v 1.148 2011/12/01 02:04:41 vapier Exp $
+
+*wget-1.13.4-r1 (01 Dec 2011)
+
+ 01 Dec 2011; Mike Frysinger <vapier@gentoo.org> +wget-1.13.4-r1.ebuild,
+ +files/wget-1.13.4-openssl-pkg-config.patch:
+ Switch to pkg-config for looking up openssl #246556 by Rick Farina.
*wget-1.13.4 (18 Sep 2011)
diff --git a/net-misc/wget/files/wget-1.13.4-openssl-pkg-config.patch b/net-misc/wget/files/wget-1.13.4-openssl-pkg-config.patch
new file mode 100644
index 000000000000..c052b4a189e3
--- /dev/null
+++ b/net-misc/wget/files/wget-1.13.4-openssl-pkg-config.patch
@@ -0,0 +1,30 @@
+detect openssl via pkg-config if it's available
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -234,7 +234,16 @@ dnl
+ dnl Checks for libraries.
+ dnl
+
++PKG_PROG_PKG_CONFIG
++
+ AS_IF([test x"$with_ssl" = xopenssl], [
++ PKG_CHECK_MODULES([OPENSSL], [openssl], [
++ AC_MSG_NOTICE([compiling in support for SSL via OpenSSL])
++ AC_LIBOBJ([openssl])
++ LIBS="$OPENSSL_LIBS $LIBS"
++ CFLAGS="$OPENSSL_CFLAGS -DHAVE_LIBSSL $CFLAGS"
++ ], [
++
+ dnl some versions of openssl use zlib compression
+ AC_CHECK_LIB(z, compress)
+
+@@ -294,6 +303,8 @@ AS_IF([test x$ssl_found != xyes],
+
+ ])
+
++])
++
+ ], [
+ # --with-ssl is not gnutls: check if it's no
+ AS_IF([test x"$with_ssl" != xno], [
diff --git a/net-misc/wget/wget-1.13.4-r1.ebuild b/net-misc/wget/wget-1.13.4-r1.ebuild
new file mode 100644
index 000000000000..2491d1a20bc4
--- /dev/null
+++ b/net-misc/wget/wget-1.13.4-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.13.4-r1.ebuild,v 1.1 2011/12/01 02:04:41 vapier Exp $
+
+EAPI="4"
+
+inherit flag-o-matic toolchain-funcs autotools
+
+DESCRIPTION="Network utility to retrieve files from the WWW"
+HOMEPAGE="http://www.gnu.org/software/wget/"
+SRC_URI="mirror://gnu/wget/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug gnutls idn ipv6 nls ntlm +ssl static"
+
+LIB_DEPEND="idn? ( net-dns/libidn[static-libs] )
+ ssl? (
+ gnutls? ( net-libs/gnutls[static-libs(+)] )
+ !gnutls? ( >=dev-libs/openssl-0.9.6b[static-libs(+)] )
+ )"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs]} )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ static? ( ${LIB_DEPEND} )
+ nls? ( sys-devel/gettext )"
+
+REQUIRED_USE="ntlm? ( !gnutls ssl ) gnutls? ( ssl )"
+
+DOCS=( AUTHORS MAILING-LIST NEWS README doc/sample.wgetrc )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-openssl-pkg-config.patch
+ eautoreconf
+}
+
+src_configure() {
+ # openssl-0.9.8 now builds with -pthread on the BSD's
+ use elibc_FreeBSD && use ssl && append-ldflags -pthread
+ # fix compilation on Solaris, we need filio.h for FIONBIO as used in
+ # the included gnutls -- force ioctl.h to include this header
+ [[ ${CHOST} == *-solaris* ]] && append-flags -DBSD_COMP=1
+
+ # the configure script contains a few hacks to workaround openssl
+ # build limitations. disable those, and use openssl's pkg-config.
+ eval export ac_cv_lib_{z_compress,dl_{dlopen,shl_load}}=no
+
+ if use static ; then
+ append-ldflags -static
+ tc-export PKG_CONFIG
+ PKG_CONFIG+=" --static"
+ fi
+ econf \
+ --disable-rpath \
+ $(use_with ssl ssl $(usex gnutls gnutls openssl)) \
+ $(use_enable ssl opie) \
+ $(use_enable ssl digest) \
+ $(use_enable idn iri) \
+ $(use_enable ipv6) \
+ $(use_enable nls) \
+ $(use_enable ntlm) \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+
+ use ipv6 && cat "${FILESDIR}"/wgetrc-ipv6 >> "${ED}"/etc/wgetrc
+
+ sed -i \
+ -e "s:/usr/local/etc:${EPREFIX}/etc:g" \
+ "${ED}"/etc/wgetrc \
+ "${ED}"/usr/share/man/man1/wget.1 \
+ "${ED}"/usr/share/info/wget.info
+}