summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-12-27 16:49:47 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-12-27 16:49:47 +0000
commitfd3806e4d63dfbd52948a74e09d698f0898063e1 (patch)
tree3032a4570c30b0742c15fed5a2b524daa2ab2605 /net-misc
parentSwitch to --disable-hardlink-deliver, this fixes bug 481784 and bug 488846 (diff)
downloadgentoo-2-fd3806e4d63dfbd52948a74e09d698f0898063e1.tar.gz
gentoo-2-fd3806e4d63dfbd52948a74e09d698f0898063e1.tar.bz2
gentoo-2-fd3806e4d63dfbd52948a74e09d698f0898063e1.zip
Add patch for bug #495170
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/curl/ChangeLog8
-rw-r--r--net-misc/curl/curl-7.34.0-r1.ebuild (renamed from net-misc/curl/curl-7.34.0.ebuild)5
-rw-r--r--net-misc/curl/files/curl-7.34.0-fix-ipv6-failover.patch27
3 files changed, 37 insertions, 3 deletions
diff --git a/net-misc/curl/ChangeLog b/net-misc/curl/ChangeLog
index 834eb22ecdb0..0201102fecd4 100644
--- a/net-misc/curl/ChangeLog
+++ b/net-misc/curl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/curl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.315 2013/12/26 23:21:57 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.316 2013/12/27 16:49:47 blueness Exp $
+
+*curl-7.34.0-r1 (27 Dec 2013)
+
+ 27 Dec 2013; Anthony G. Basile <blueness@gentoo.org> +curl-7.34.0-r1.ebuild,
+ +files/curl-7.34.0-fix-ipv6-failover.patch, -curl-7.34.0.ebuild:
+ Add patch for bug #495170
26 Dec 2013; Michał Górny <mgorny@gentoo.org> curl-7.34.0.ebuild:
Add epatch_user call to make patch testing easier.
diff --git a/net-misc/curl/curl-7.34.0.ebuild b/net-misc/curl/curl-7.34.0-r1.ebuild
index 2caf1c9183c8..1fd3d794a4db 100644
--- a/net-misc/curl/curl-7.34.0.ebuild
+++ b/net-misc/curl/curl-7.34.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.34.0.ebuild,v 1.2 2013/12/26 23:21:57 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.34.0-r1.ebuild,v 1.1 2013/12/27 16:49:47 blueness Exp $
EAPI="5"
@@ -84,7 +84,8 @@ src_prepare() {
epatch \
"${FILESDIR}"/${PN}-7.30.0-prefix.patch \
"${FILESDIR}"/${PN}-respect-cflags-3.patch \
- "${FILESDIR}"/${PN}-fix-gnutls-nettle.patch
+ "${FILESDIR}"/${PN}-fix-gnutls-nettle.patch \
+ "${FILESDIR}"/${P}-fix-ipv6-failover.patch
sed -i '/LD_LIBRARY_PATH=/d' configure.ac || die #382241
epatch_user
diff --git a/net-misc/curl/files/curl-7.34.0-fix-ipv6-failover.patch b/net-misc/curl/files/curl-7.34.0-fix-ipv6-failover.patch
new file mode 100644
index 000000000000..ce05e239b908
--- /dev/null
+++ b/net-misc/curl/files/curl-7.34.0-fix-ipv6-failover.patch
@@ -0,0 +1,27 @@
+This fixes bug #495170: hangs after hitting IPv6 address with no IPv6
+
+See upstream: https://sourceforge.net/p/curl/bugs/1315/
+
+diff --git a/lib/connect.c b/lib/connect.c
+index 4b6ee00..97a0655 100644
+--- a/lib/connect.c
++++ b/lib/connect.c
+@@ -1104,13 +1104,12 @@ CURLcode Curl_connecthost(struct connectdata *conn, /*
+ conn->tempaddr[0]->ai_next == NULL ? timeout_ms : timeout_ms / 2;
+
+ /* start connecting to first IP */
+- res = singleipconnect(conn, conn->tempaddr[0], &(conn->tempsock[0]));
+- while(res != CURLE_OK &&
+- conn->tempaddr[0] &&
+- conn->tempaddr[0]->ai_next &&
+- conn->tempsock[0] == CURL_SOCKET_BAD)
+- res = trynextip(conn, FIRSTSOCKET, 0);
+-
++ while(conn->tempaddr[0]) {
++ res = singleipconnect(conn, conn->tempaddr[0], &(conn->tempsock[0]));
++ if(res == CURLE_OK)
++ break;
++ conn->tempaddr[0] = conn->tempaddr[0]->ai_next;
++ }
+ if(conn->tempsock[0] == CURL_SOCKET_BAD)
+ return res;