summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-31 05:40:05 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-31 05:40:05 +0000
commita342a54e99667fdfc24d59a77f7fa382aff495fa (patch)
tree91af6250880e43fb3e789642e34d7d910b67251e /net-nds/ypserv
parentClosing bug25551 (Manifest recommit) (diff)
downloadgentoo-2-a342a54e99667fdfc24d59a77f7fa382aff495fa.tar.gz
gentoo-2-a342a54e99667fdfc24d59a77f7fa382aff495fa.tar.bz2
gentoo-2-a342a54e99667fdfc24d59a77f7fa382aff495fa.zip
ia64 stable for #66786
Diffstat (limited to 'net-nds/ypserv')
-rw-r--r--net-nds/ypserv/ypserv-2.13-r1.ebuild30
1 files changed, 14 insertions, 16 deletions
diff --git a/net-nds/ypserv/ypserv-2.13-r1.ebuild b/net-nds/ypserv/ypserv-2.13-r1.ebuild
index dbf66c4bea95..691c6d1e94e8 100644
--- a/net-nds/ypserv/ypserv-2.13-r1.ebuild
+++ b/net-nds/ypserv/ypserv-2.13-r1.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/ypserv/ypserv-2.13-r1.ebuild,v 1.8 2004/10/08 18:02:53 hansmi Exp $
-
-IUSE="slp"
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypserv/ypserv-2.13-r1.ebuild,v 1.9 2004/10/31 05:40:05 vapier Exp $
DESCRIPTION="Network Information Service server"
HOMEPAGE="http://www.linux-nis.org/nis/"
@@ -10,35 +8,35 @@ SRC_URI="mirror://kernel/linux/utils/net/NIS/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc sparc ~ppc64 amd64"
+KEYWORDS="amd64 ia64 ppc ~ppc64 sparc x86"
+IUSE="slp"
-DEPEND=">=sys-libs/gdbm-1.8.0
+RDEPEND=">=sys-libs/gdbm-1.8.0
slp? ( net-libs/openslp )"
+DEPEND="${RDEPEND}
+ >=sys-apps/portage-2.0.51"
src_compile() {
- econf `use_enable slp` || die
+ econf $(use_enable slp) || die
emake || die
}
src_install() {
- make DESTDIR=${D} install
+ make DESTDIR=${D} install || die
dodoc AUTHORS ChangeLog INSTALL NEWS README THANKS TODO
insinto /etc
doins etc/ypserv.conf etc/netgroup etc/netmasks
-
insinto /var/yp
newins etc/securenets securenets.default
- insinto /etc/conf.d
- newins ${FILESDIR}/ypserv.confd ypserv
- newins ${FILESDIR}/rpc.yppasswdd.confd rpc.yppasswdd
- newins ${FILESDIR}/rpc.ypxfrd.confd rpc.ypxfrd
+ newconfd ${FILESDIR}/ypserv.confd ypserv
+ newconfd ${FILESDIR}/rpc.yppasswdd.confd rpc.yppasswdd
+ newconfd ${FILESDIR}/rpc.ypxfrd.confd rpc.ypxfrd
- exeinto /etc/init.d
- newexe ${FILESDIR}/ypserv ypserv
- newexe ${FILESDIR}/rpc.yppasswdd-r1 rpc.yppasswdd
- newexe ${FILESDIR}/rpc.ypxfrd rpc.ypxfrd
+ newinitd ${FILESDIR}/ypserv ypserv
+ newinitd ${FILESDIR}/rpc.yppasswdd-r1 rpc.yppasswdd
+ newinitd ${FILESDIR}/rpc.ypxfrd rpc.ypxfrd
# Save the old config into the new package as CONFIG_PROTECT
# doesn't work for this package.