summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-09-02 20:08:25 +0000
committerMike Frysinger <vapier@gentoo.org>2011-09-02 20:08:25 +0000
commite9094cda4dcaa782123d1cc12c38b2a6e7ac94c0 (patch)
tree7cea5650a92c863ce9340285c3291b90172fb9a2 /net-nds
parentMigrate to EAPI=2 for fun. (diff)
downloadgentoo-2-e9094cda4dcaa782123d1cc12c38b2a6e7ac94c0.tar.gz
gentoo-2-e9094cda4dcaa782123d1cc12c38b2a6e7ac94c0.tar.bz2
gentoo-2-e9094cda4dcaa782123d1cc12c38b2a6e7ac94c0.zip
Add pkg-config patch from upstream.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/rpcbind/ChangeLog6
-rw-r--r--net-nds/rpcbind/files/rpcbind-0.2.0-pkgconfig.patch65
-rw-r--r--net-nds/rpcbind/rpcbind-0.2.0.ebuild12
-rw-r--r--net-nds/rpcbind/rpcbind-9999.ebuild7
4 files changed, 81 insertions, 9 deletions
diff --git a/net-nds/rpcbind/ChangeLog b/net-nds/rpcbind/ChangeLog
index a881d601f597..1899079186bd 100644
--- a/net-nds/rpcbind/ChangeLog
+++ b/net-nds/rpcbind/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-nds/rpcbind
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/ChangeLog,v 1.13 2011/09/02 20:02:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/ChangeLog,v 1.14 2011/09/02 20:08:25 vapier Exp $
+
+ 02 Sep 2011; Mike Frysinger <vapier@gentoo.org> rpcbind-0.2.0.ebuild,
+ +files/rpcbind-0.2.0-pkgconfig.patch, rpcbind-9999.ebuild:
+ Add pkg-config patch from upstream.
02 Sep 2011; Mike Frysinger <vapier@gentoo.org> rpcbind-0.2.0.ebuild,
rpcbind-9999.ebuild:
diff --git a/net-nds/rpcbind/files/rpcbind-0.2.0-pkgconfig.patch b/net-nds/rpcbind/files/rpcbind-0.2.0-pkgconfig.patch
new file mode 100644
index 000000000000..e0339af92b7e
--- /dev/null
+++ b/net-nds/rpcbind/files/rpcbind-0.2.0-pkgconfig.patch
@@ -0,0 +1,65 @@
+From afd71b8fc0df036a884b3af14ddb875674a49a85 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Diego=20Elio=20Petten=F2?= <flameeyes@gmail.com>
+Date: Mon, 29 Nov 2010 16:28:38 -0500
+Subject: [PATCH] Use pkg-config to find libtirpc
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+This allows to properly cross-compile rpcbind, as /usr/include/tirpc is
+no longer a valid path in that case.
+
+Signed-off-by: Diego Elio Pettenò <flameeyes@gmail.com>
+Signed-off-by: Steve Dickson <steved@redhat.com>
+---
+ configure.in | 4 +++-
+ src/Makefile.am | 13 +++++++------
+ 2 files changed, 10 insertions(+), 7 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index de1c730..7d43fd4 100644
+--- a/configure.in
++++ b/configure.in
+@@ -51,7 +51,9 @@ AC_CHECK_HEADERS([arpa/inet.h fcntl.h netdb.h \
+ unistd.h nss.h])
+
+ AC_CHECK_LIB([pthread], [pthread_create])
+-AC_CHECK_LIB([tirpc], [clnt_create])
++
++PKG_CHECK_MODULES([TIRPC], [libtirpc])
++
+ AC_ARG_ENABLE(libwrap,[ --enable-libwrap Enables host name checking],
+ [case "${enableval}" in
+ yes) libwarp=true
+diff --git a/src/Makefile.am b/src/Makefile.am
+index cc0a85b..a2f3e34 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -1,4 +1,4 @@
+-INCLUDES = -I$(srcdir)/tirpc -DPORTMAP -DINET6 -DVERSION="\"$(VERSION)\"" \
++INCLUDES = $(TIRPC_CFLAGS) -DPORTMAP -DINET6 -DVERSION="\"$(VERSION)\"" \
+ -D_GNU_SOURCE -Wall -pipe
+ if DEBUG
+ INCLUDES += -DRPCBIND_DEBUG -DSVC_RUN_DEBUG -DDEBUG_RMTCALL
+@@ -23,12 +23,13 @@ rpcbind_SOURCES = check_bound.c rpcbind.c \
+ rpcbind.h
+
+ rpcinfo_SOURCES = rpcinfo.c
+-rpcinfo_LDFLAGS = -lpthread -ltirpc
+-rpcinfo_LDADD = $(LIB_TIRPC)
++rpcinfo_LDFLAGS = -lpthread
++rpcinfo_LDADD = $(TIRPC_LIBS)
+
+
+-rpcbind_LDFLAGS = -lpthread -ltirpc
+-rpcbind_LDADD = $(LIB_TIRPC)
+-AM_CPPFLAGS = -I/usr/include/tirpc -DCHECK_LOCAL -DPORTMAP \
++rpcbind_LDFLAGS = -lpthread
++rpcbind_CFLAGS = $(TIRPC_CFLAGS)
++rpcbind_LDADD = $(TIRPC_LIBS)
++AM_CPPFLAGS = -DCHECK_LOCAL -DPORTMAP \
+ -DFACILITY=LOG_MAIL -DSEVERITY=LOG_INFO
+
+--
+1.7.6
+
diff --git a/net-nds/rpcbind/rpcbind-0.2.0.ebuild b/net-nds/rpcbind/rpcbind-0.2.0.ebuild
index 89796d9418cb..db2a7217da03 100644
--- a/net-nds/rpcbind/rpcbind-0.2.0.ebuild
+++ b/net-nds/rpcbind/rpcbind-0.2.0.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/rpcbind-0.2.0.ebuild,v 1.9 2011/09/02 20:02:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/rpcbind-0.2.0.ebuild,v 1.10 2011/09/02 20:08:25 vapier Exp $
EAPI="2"
+inherit autotools
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://git.infradead.org/~steved/rpcbind.git"
inherit autotools git
@@ -21,15 +22,16 @@ LICENSE="BSD"
SLOT="0"
IUSE=""
-DEPEND="net-libs/libtirpc"
-RDEPEND=${DEPEND}
+RDEPEND="net-libs/libtirpc"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
src_prepare() {
if [[ ${PV} == "9999" ]] ; then
eautoreconf
else
- # fix busted timestamps
- find . -type f -print0 | xargs -0 touch -r .
+ epatch "${FILESDIR}"/${P}-pkgconfig.patch
+ eautoreconf
fi
}
diff --git a/net-nds/rpcbind/rpcbind-9999.ebuild b/net-nds/rpcbind/rpcbind-9999.ebuild
index 32e566e51b84..991de85ba0bd 100644
--- a/net-nds/rpcbind/rpcbind-9999.ebuild
+++ b/net-nds/rpcbind/rpcbind-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/rpcbind-9999.ebuild,v 1.4 2011/09/02 20:02:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/rpcbind-9999.ebuild,v 1.5 2011/09/02 20:08:25 vapier Exp $
EAPI="2"
@@ -21,8 +21,9 @@ LICENSE="BSD"
SLOT="0"
IUSE=""
-DEPEND="net-libs/libtirpc"
-RDEPEND=${DEPEND}
+RDEPEND="net-libs/libtirpc"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
src_prepare() {
if [[ ${PV} == "9999" ]] ; then