summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2011-03-01 06:48:16 +0000
committerTiziano Müller <dev-zero@gentoo.org>2011-03-01 06:48:16 +0000
commitf5d0384c750665d0bd545da9b619f7ca1abe97e5 (patch)
treed9b31ed70c442d762e1e9f055569bd58e3933cce /net-nds
parentBump to EAPI 1 and add a slot dependency on gtk+:2. (diff)
downloadgentoo-2-f5d0384c750665d0bd545da9b619f7ca1abe97e5.tar.gz
gentoo-2-f5d0384c750665d0bd545da9b619f7ca1abe97e5.tar.bz2
gentoo-2-f5d0384c750665d0bd545da9b619f7ca1abe97e5.zip
Version bump (bug #356827).
(Portage version: 2.1.9.41/cvs/Linux x86_64)
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/gosa-plugin-systems/ChangeLog10
-rw-r--r--net-nds/gosa-plugin-systems/gosa-plugin-systems-2.6.12.ebuild45
2 files changed, 53 insertions, 2 deletions
diff --git a/net-nds/gosa-plugin-systems/ChangeLog b/net-nds/gosa-plugin-systems/ChangeLog
index 7ed878d20a4c..41607b41bcc1 100644
--- a/net-nds/gosa-plugin-systems/ChangeLog
+++ b/net-nds/gosa-plugin-systems/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-nds/gosa-plugin-systems
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/gosa-plugin-systems/ChangeLog,v 1.2 2010/08/23 08:57:32 dev-zero Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/gosa-plugin-systems/ChangeLog,v 1.3 2011/03/01 06:48:16 dev-zero Exp $
+
+*gosa-plugin-systems-2.6.12 (01 Mar 2011)
+
+ 01 Mar 2011; Tiziano Müller <dev-zero@gentoo.org>
+ +gosa-plugin-systems-2.6.12.ebuild:
+ Version bump (bug #356827).
*gosa-plugin-systems-2.6.11 (23 Aug 2010)
diff --git a/net-nds/gosa-plugin-systems/gosa-plugin-systems-2.6.12.ebuild b/net-nds/gosa-plugin-systems/gosa-plugin-systems-2.6.12.ebuild
new file mode 100644
index 000000000000..e9d2303fd096
--- /dev/null
+++ b/net-nds/gosa-plugin-systems/gosa-plugin-systems-2.6.12.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/gosa-plugin-systems/gosa-plugin-systems-2.6.12.ebuild,v 1.1 2011/03/01 06:48:16 dev-zero Exp $
+
+EAPI=4
+
+MY_P="${P/plugin/plugins}"
+
+DESCRIPTION="GOsa plugin for common systems integration"
+HOMEPAGE="https://oss.gonicus.de/labs/gosa/wiki/WikiStart."
+SRC_URI="ftp://oss.gonicus.de/pub/gosa/${MY_P}.tar.bz2
+ http://oss.gonicus.de/pub/gosa/${MY_P}.tar.bz2
+ ftp://oss.gonicus.de/pub/gosa/archive/${MY_P}.tar.bz2
+ http://oss.gonicus.de/pub/gosa/archive/${MY_P}.tar.bz2 "
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="~net-nds/gosa-core-${PV}"
+
+S="${WORKDIR}/${MY_P}"
+GOSA_COMPONENT="${PN/gosa-plugins-}"
+
+src_install() {
+ insinto /usr/share/gosa/html/plugins/${GOSA_COMPONENT}/
+ doins -r html/*
+
+ insinto /usr/share/gosa/locale/plugins/${GOSA_COMPONENT}/
+ doins -r locale/*
+
+ insinto /usr/share/gosa/plugins
+ doins -r admin
+
+ insinto /usr/share/gosa/doc/plugins/${GOSA_COMPONENT}/
+ doins -r help/*
+}
+
+pkg_postinst() {
+ ebegin "Updating class cache and locales"
+ "${EROOT}"usr/sbin/update-gosa
+ eend $?
+}