summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Buchholz <rbu@gentoo.org>2008-01-08 02:40:47 +0000
committerRobert Buchholz <rbu@gentoo.org>2008-01-08 02:40:47 +0000
commit849f40c2cf4cb3667a5d04f11d41fb7079ecf89b (patch)
tree5ed299432826e7635aa9d0b6cb8bd9db40d8a6a9 /net-news/blam/blam-1.8.4.ebuild
parent Remove superfluous test use flag. (diff)
downloadgentoo-2-849f40c2cf4cb3667a5d04f11d41fb7079ecf89b.tar.gz
gentoo-2-849f40c2cf4cb3667a5d04f11d41fb7079ecf89b.tar.bz2
gentoo-2-849f40c2cf4cb3667a5d04f11d41fb7079ecf89b.zip
Version bump by security for untrusted search path vulnerability (CVE-2005-4790, bug #199841). Cleaning up old patches.
(Portage version: 2.1.4_rc10)
Diffstat (limited to 'net-news/blam/blam-1.8.4.ebuild')
-rw-r--r--net-news/blam/blam-1.8.4.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-news/blam/blam-1.8.4.ebuild b/net-news/blam/blam-1.8.4.ebuild
new file mode 100644
index 000000000000..4ac90eee3e29
--- /dev/null
+++ b/net-news/blam/blam-1.8.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-news/blam/blam-1.8.4.ebuild,v 1.1 2008/01/08 02:40:46 rbu Exp $
+
+inherit mono eutils autotools
+
+DESCRIPTION="A RSS aggregator written in C#"
+HOMEPAGE="http://www.cmartin.tk/blam.html"
+SRC_URI="http://www.cmartin.tk/blam/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/mono-1.1.17
+ >=dev-dotnet/gtk-sharp-2.8.2
+ >=dev-dotnet/gconf-sharp-2.8.2
+ >=dev-dotnet/glade-sharp-2.8.2
+ >=dev-dotnet/gecko-sharp-0.11-r1
+ >=gnome-base/libgnomeui-2.2
+ >=gnome-base/gconf-2.4"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.19
+ >=dev-util/intltool-0.25"
+
+# Disable parallel builds
+MAKEOPTS="$MAKEOPTS -j1"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if [[ "$(get_libdir)" != "lib" ]] ; then
+ sed -i -e 's:$(prefix)/lib/blam:$(libdir)/blam:' \
+ -e "s:@prefix@/lib:@prefix@/$(get_libdir):" \
+ "${S}"/{,lib,libblam,src}/Makefile.{in,am} "${S}"/blam.in || die
+ fi
+
+ eautomake
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+}