summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2008-03-04 00:22:29 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2008-03-04 00:22:29 +0000
commita1e9b84403f66a2c635a508bb00b7eddc7de2a69 (patch)
tree113dd7e4374473defd9a958806e2e319df4efbbc /net-news/liferea
parentold (diff)
downloadgentoo-2-a1e9b84403f66a2c635a508bb00b7eddc7de2a69.tar.gz
gentoo-2-a1e9b84403f66a2c635a508bb00b7eddc7de2a69.tar.bz2
gentoo-2-a1e9b84403f66a2c635a508bb00b7eddc7de2a69.zip
Bump to 1.4.13
* WebKitGtk interface updates for SVN r28711. (patches by Lars Strojny and George Sherwood) * Fixes SF #1886797: crash on format string (patch by Giandomenico De Tullio) * Fixes SF #1884048: crashes on empty comment feed URI (reported by djotaku4) * Workaround for Debian #454184: crash on startup when Gecko widget not visible. (patch from Luis Rodrigo Gallardo Cruz) * Added support for OPML blogrolls with "xmlURL" (instead of "xmlUrl") feed attributes as created by LiveJournal blogroll exports. * Fix for missing statusbar signal. (patch by Gustavo Chain) * Fixes SF #1879861: browser skimming hotkey doesn't work correctly when used in search folders. (reported by darthanubis) * Removes versioned notification plugin soname. (patch by Marcin Banasiak) (Portage version: 2.1.4.4)
Diffstat (limited to 'net-news/liferea')
-rw-r--r--net-news/liferea/ChangeLog26
-rw-r--r--net-news/liferea/liferea-1.4.13.ebuild87
2 files changed, 112 insertions, 1 deletions
diff --git a/net-news/liferea/ChangeLog b/net-news/liferea/ChangeLog
index b1f62bdf11fa..45d313c11234 100644
--- a/net-news/liferea/ChangeLog
+++ b/net-news/liferea/ChangeLog
@@ -1,6 +1,30 @@
# ChangeLog for net-news/liferea
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-news/liferea/ChangeLog,v 1.137 2008/01/22 03:17:22 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-news/liferea/ChangeLog,v 1.138 2008/03/04 00:22:29 dang Exp $
+
+*liferea-1.4.13 (04 Mar 2008)
+
+ 04 Mar 2008; Daniel Gryniewicz <dang@gentoo.org> +liferea-1.4.13.ebuild:
+ Bump to 1.4.13
+ * WebKitGtk interface updates for SVN r28711.
+ (patches by Lars Strojny and George Sherwood)
+ * Fixes SF #1886797: crash on format string
+ (patch by Giandomenico De Tullio)
+ * Fixes SF #1884048: crashes on empty comment feed URI
+ (reported by djotaku4)
+ * Workaround for Debian #454184: crash on startup
+ when Gecko widget not visible.
+ (patch from Luis Rodrigo Gallardo Cruz)
+ * Added support for OPML blogrolls with "xmlURL"
+ (instead of "xmlUrl") feed attributes as created
+ by LiveJournal blogroll exports.
+ * Fix for missing statusbar signal.
+ (patch by Gustavo Chain)
+ * Fixes SF #1879861: browser skimming hotkey doesn't
+ work correctly when used in search folders.
+ (reported by darthanubis)
+ * Removes versioned notification plugin soname.
+ (patch by Marcin Banasiak)
*liferea-1.4.11 (22 Jan 2008)
diff --git a/net-news/liferea/liferea-1.4.13.ebuild b/net-news/liferea/liferea-1.4.13.ebuild
new file mode 100644
index 000000000000..cce472a00925
--- /dev/null
+++ b/net-news/liferea/liferea-1.4.13.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-news/liferea/liferea-1.4.13.ebuild,v 1.1 2008/03/04 00:22:29 dang Exp $
+
+WANT_AUTOMAKE=1.7
+WANT_AUTOCONF=latest
+inherit gnome2
+
+DESCRIPTION="News Aggregator for RDF/RSS/CDF/Atom/Echo/etc feeds"
+HOMEPAGE="http://liferea.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+
+EAPI="1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="dbus firefox gtkhtml gnutls libnotify lua networkmanager seamonkey xulrunner"
+
+RDEPEND="
+ libnotify? ( >=x11-libs/libnotify-0.3.2 )
+ lua? ( >=dev-lang/lua-5.1 )
+ xulrunner? ( net-libs/xulrunner )
+ !xulrunner? ( firefox? ( www-client/mozilla-firefox ) )
+ !xulrunner? ( !firefox? ( seamonkey? ( www-client/seamonkey ) ) )
+ !amd64? ( !xulrunner? ( !firefox? ( !seamonkey? ( gnome-extra/gtkhtml:2 ) ) ) )
+ !amd64? ( gtkhtml? ( gnome-extra/gtkhtml:2 ) )
+ >=x11-libs/gtk+-2.8
+ x11-libs/pango
+ >=gnome-base/gconf-2
+ >=dev-libs/libxml2-2.6.27
+ >=dev-libs/libxslt-1.1.19
+ >=dev-db/sqlite-3.3
+ >=dev-libs/glib-2
+ >=gnome-base/libglade-2
+ dbus? ( >=dev-libs/dbus-glib-0.71 )
+ networkmanager? ( net-misc/networkmanager )
+ gnutls? ( net-libs/gnutls )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.35"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ # On amd64, gtkhtml isn't supported. You need one of the gecko use flags
+ if use amd64 && ! use firefox && ! use seamonkey && ! use xulrunner; then
+ elog "gtkhtml is no longer supported on amd64; you will need to select"
+ elog "one of the gecko backends to use liferea"
+ die "You must enable on of the gecko backends on amd64"
+ fi
+
+ # if you don't choose a gecko to use, we will automatically
+ # use gtkhtml2 as the backend except on amd64 (where we failed above)
+ if ! use seamonkey && ! use firefox && ! use xulrunner && ! use amd64 ; then
+ G2CONF="${G2CONF} --enable-gtkhtml2"
+ elif ! use amd64 && use gtkhtml ; then
+ G2CONF="${G2CONF} --enable-gtkhtml2"
+ else
+ G2CONF="${G2CONF} --disable-gtkhtml2"
+ fi
+
+ # we prefer xulrunner over firefox over seamonkey
+ if use xulrunner ; then
+ G2CONF="${G2CONF} --enable-xulrunner"
+ elif use firefox ; then
+ G2CONF="${G2CONF} --enable-gecko=firefox"
+ elif use seamonkey ; then
+ G2CONF="${G2CONF} --enable-gecko=seamonkey"
+ else
+ G2CONF="${G2CONF} --disable-gecko"
+ fi
+
+ G2CONF="${G2CONF} \
+ --disable-webkit \
+ $(use_enable dbus) \
+ $(use_enable gnutls) \
+ $(use_enable libnotify) \
+ $(use_enable lua) \
+ $(use_enable networkmanager nm)"
+}
+
+src_install() {
+ gnome2_src_install
+ rm -f "${D}/usr/bin/${PN}"
+ mv "${D}/usr/bin/${PN}-bin" "${D}/usr/bin/${PN}"
+}