summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-10-11 08:47:01 +0000
committerIan Delaney <idella4@gentoo.org>2014-10-11 08:47:01 +0000
commita9b647885aa8b604689f27c08e6822c41d3466ec (patch)
tree76c81569a6aaa9d7faf56906170f4830636167c7 /net-news/rawdog
parentRestructure to accomodate new multilib scheme (diff)
downloadgentoo-2-a9b647885aa8b604689f27c08e6822c41d3466ec.tar.gz
gentoo-2-a9b647885aa8b604689f27c08e6822c41d3466ec.tar.bz2
gentoo-2-a9b647885aa8b604689f27c08e6822c41d3466ec.zip
bump; add test phase to run prepared shell script to run tests
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'net-news/rawdog')
-rw-r--r--net-news/rawdog/ChangeLog8
-rw-r--r--net-news/rawdog/rawdog-2.19.ebuild9
-rw-r--r--net-news/rawdog/rawdog-2.20.ebuild (renamed from net-news/rawdog/rawdog-2.18-r1.ebuild)22
3 files changed, 27 insertions, 12 deletions
diff --git a/net-news/rawdog/ChangeLog b/net-news/rawdog/ChangeLog
index cfdea025f035..1526c97c5b3f 100644
--- a/net-news/rawdog/ChangeLog
+++ b/net-news/rawdog/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-news/rawdog
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-news/rawdog/ChangeLog,v 1.54 2014/04/24 03:36:19 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-news/rawdog/ChangeLog,v 1.55 2014/10/11 08:47:01 idella4 Exp $
+
+*rawdog-2.20 (11 Oct 2014)
+
+ 11 Oct 2014; Ian Delaney <idella4@gentoo.org> +rawdog-2.20.ebuild,
+ -rawdog-2.18-r1.ebuild, rawdog-2.19.ebuild:
+ bump; add test phase to run prepared shell script to run tests
* rawdog-2.18-r1.ebuild (24 Apr 2014)
diff --git a/net-news/rawdog/rawdog-2.19.ebuild b/net-news/rawdog/rawdog-2.19.ebuild
index fc867d8c80b7..f3a4f3799c22 100644
--- a/net-news/rawdog/rawdog-2.19.ebuild
+++ b/net-news/rawdog/rawdog-2.19.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-news/rawdog/rawdog-2.19.ebuild,v 1.2 2014/04/24 03:02:16 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-news/rawdog/rawdog-2.19.ebuild,v 1.3 2014/10/11 08:47:01 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 pypy )
@@ -18,3 +18,10 @@ IUSE=""
DEPEND="dev-python/feedparser[${PYTHON_USEDEP}]"
RDEPEND=""
+# Test run fails under multi threading
+DISTUTILS_NO_PARALLEL_BUILD=1
+
+python_test() {
+ # pypy fails half way through; meh
+ ./test-rawdog || die "Test run aborted"
+}
diff --git a/net-news/rawdog/rawdog-2.18-r1.ebuild b/net-news/rawdog/rawdog-2.20.ebuild
index acb5e4ad55bd..935b7fb7d354 100644
--- a/net-news/rawdog/rawdog-2.18-r1.ebuild
+++ b/net-news/rawdog/rawdog-2.20.ebuild
@@ -1,13 +1,11 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-news/rawdog/rawdog-2.18-r1.ebuild,v 1.1 2014/04/24 03:02:17 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-news/rawdog/rawdog-2.20.ebuild,v 1.1 2014/10/11 08:47:01 idella4 Exp $
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
-inherit distutils
+inherit distutils-r1
DESCRIPTION="Rawdog - RSS Aggregator Without Delusions Of Grandeur"
HOMEPAGE="http://offog.org/code/rawdog.html http://pypi.python.org/pypi/rawdog"
@@ -18,8 +16,12 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~s390 ~sparc ~x86"
IUSE=""
-RDEPEND="dev-python/feedparser"
-DEPEND=""
+DEPEND="dev-python/feedparser[${PYTHON_USEDEP}]"
+RDEPEND=""
+# Test run fails under multi threading
+DISTUTILS_NO_PARALLEL_BUILD=1
-DOCS="NEWS PLUGINS config style.css"
-PYTHON_MODNAME="rawdoglib"
+python_test() {
+ # pypy fails half way through; meh
+ ./test-rawdog || die "Test run aborted"
+}