summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Conrad Tilstra <tadpol@gentoo.org>2001-08-16 03:27:24 +0000
committerMichael Conrad Tilstra <tadpol@gentoo.org>2001-08-16 03:27:24 +0000
commit453d9817587fd2101071ad2a97f37179dfd6033a (patch)
tree6f3d4fed1220f4eca21b50a782767aa086a70b35 /net-news/tin
parent*** empty log message *** (diff)
downloadgentoo-2-453d9817587fd2101071ad2a97f37179dfd6033a.tar.gz
gentoo-2-453d9817587fd2101071ad2a97f37179dfd6033a.tar.bz2
gentoo-2-453d9817587fd2101071ad2a97f37179dfd6033a.zip
- was too lazy to type startx. so instead I made an ebuild for a terminal
newsreader.
Diffstat (limited to 'net-news/tin')
-rw-r--r--net-news/tin/files/digest-tin-1.4.51
-rw-r--r--net-news/tin/tin-1.4.5.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/net-news/tin/files/digest-tin-1.4.5 b/net-news/tin/files/digest-tin-1.4.5
new file mode 100644
index 000000000000..864fb1d012e2
--- /dev/null
+++ b/net-news/tin/files/digest-tin-1.4.5
@@ -0,0 +1 @@
+MD5 fd4a8006f19020ed78c538f6c92f1027 tin-1.4.5.tar.gz
diff --git a/net-news/tin/tin-1.4.5.ebuild b/net-news/tin/tin-1.4.5.ebuild
new file mode 100644
index 000000000000..36e81dcd3f12
--- /dev/null
+++ b/net-news/tin/tin-1.4.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Michael Conrad Tilstra <tadpol@gentoo.org> <tadpol@tadpol.org>
+# $Header: /var/cvsroot/gentoo-x86/net-news/tin/tin-1.4.5.ebuild,v 1.1 2001/08/16 03:27:24 tadpol Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION=""
+SRC_URI="ftp://ftp.tin.org/pub/news/clients/tin/v1.4/${A}"
+HOMEPAGE="http://www.tin.org/"
+DEPEND="virtual/glibc
+ ncurses? ( ~sys-libs/ncurses )"
+
+src_compile() {
+ local myopts
+
+ [ "`use ncurses`" ] && myopts="--enable-curses --with-ncurses"
+ [ -f /etc/NNTP_INEWS_DOMAIN ] && myopts="$myopts --with-domain-name=/etc/NNTP_INEWS_DOMAIN"
+
+ ./configure --verbose --enable-nntp-only --enable-prototypes --disable-echo \
+ --disable-mime-strict-charset --with-coffee \
+ --enable-fascist-newsadmin $myopts || die
+ make build || die
+}
+
+src_install() {
+ dobin src/tin
+ ln -s tin ${D}/usr/bin/rtin
+ doman doc/tin.1
+ dodoc doc/*
+ insinto /etc/tin
+ doins doc/tin.defaults
+}
+