summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2003-07-24 23:03:10 +0000
committerRyan Phillips <rphillips@gentoo.org>2003-07-24 23:03:10 +0000
commit1f763af2bd8b6383685bb8ff202fb0363da66e6e (patch)
treeb82bf0ad584b9c72ec6275c8425faf42f3821938 /net-news
parentmetadata (diff)
downloadgentoo-2-1f763af2bd8b6383685bb8ff202fb0363da66e6e.tar.gz
gentoo-2-1f763af2bd8b6383685bb8ff202fb0363da66e6e.tar.bz2
gentoo-2-1f763af2bd8b6383685bb8ff202fb0363da66e6e.zip
version bump
Diffstat (limited to 'net-news')
-rw-r--r--net-news/tin/ChangeLog7
-rw-r--r--net-news/tin/Manifest2
-rw-r--r--net-news/tin/files/digest-tin-1.6.01
-rw-r--r--net-news/tin/tin-1.6.0.ebuild45
4 files changed, 54 insertions, 1 deletions
diff --git a/net-news/tin/ChangeLog b/net-news/tin/ChangeLog
index a1cf486c7f54..6214d58aa922 100644
--- a/net-news/tin/ChangeLog
+++ b/net-news/tin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-news/tin
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-news/tin/ChangeLog,v 1.2 2003/02/12 08:37:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-news/tin/ChangeLog,v 1.3 2003/07/24 23:03:10 rphillips Exp $
+
+*tin-1.6.0 (24 Jul 2003)
+
+ 24 Jul 2003; Ryan Phillips <rphillips@gentoo.org> tin-1.6.0.ebuild :
+ version bump
*tin-1.4.5 (1 Feb 2002)
diff --git a/net-news/tin/Manifest b/net-news/tin/Manifest
index 0ae13281ed16..a0402cd4753a 100644
--- a/net-news/tin/Manifest
+++ b/net-news/tin/Manifest
@@ -1,3 +1,5 @@
MD5 1e72b584542462b5d9de319dec790a86 ChangeLog 663
MD5 34534e9cd0b43175726e7d868842c2de tin-1.4.5.ebuild 1105
+MD5 d7bd7ddd1dde44793f00f34334ab227e tin-1.6.0.ebuild 1105
MD5 cba3ba7f3d628ed33c94f3ff4f1375e3 files/digest-tin-1.4.5 61
+MD5 2475288cb79f81762730eb56c53ba235 files/digest-tin-1.6.0 62
diff --git a/net-news/tin/files/digest-tin-1.6.0 b/net-news/tin/files/digest-tin-1.6.0
new file mode 100644
index 000000000000..39faf3cb4377
--- /dev/null
+++ b/net-news/tin/files/digest-tin-1.6.0
@@ -0,0 +1 @@
+MD5 febbe011ab9a025760984c3b5b324a3c tin-1.6.0.tar.gz 1541284
diff --git a/net-news/tin/tin-1.6.0.ebuild b/net-news/tin/tin-1.6.0.ebuild
new file mode 100644
index 000000000000..c42f6af483ea
--- /dev/null
+++ b/net-news/tin/tin-1.6.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Michael Conrad Tilstra <tadpol@gentoo.org> <tadpol@tadpol.org>
+# $Header: /var/cvsroot/gentoo-x86/net-news/tin/tin-1.6.0.ebuild,v 1.1 2003/07/24 23:03:10 rphillips Exp $
+
+IUSE="ncurses"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A threaded NNTP and spool based UseNet newsreader"
+SRC_URI="ftp://ftp.tin.org/pub/news/clients/tin/v1.6/${P}.tar.gz"
+HOMEPAGE="http://www.tin.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="ncurses? ( sys-libs/ncurses )"
+
+src_compile() {
+ local myconf
+
+ use ncurses && myconf="--enable-curses --with-ncurses"
+ [ -f /etc/NNTP_INEWS_DOMAIN ] \
+ && myconf="${myconf} --with-domain-name=/etc/NNTP_INEWS_DOMAIN"
+
+ ./configure \
+ --verbose \
+ --enable-nntp-only \
+ --enable-prototypes \
+ --disable-echo \
+ --disable-mime-strict-charset \
+ --with-coffee \
+ --enable-fascist-newsadmin \
+ ${myconf} || die
+ make build || die
+}
+
+src_install() {
+ dobin src/tin
+ ln -s tin ${D}/usr/bin/rtin
+ doman doc/tin.1
+ dodoc doc/*
+ insinto /etc/tin
+ doins doc/tin.defaults
+}