summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2008-05-04 01:34:26 +0000
committerDaniel Black <dragonheart@gentoo.org>2008-05-04 01:34:26 +0000
commit3d4eec27551fda8d2e32246cf13095204948680a (patch)
tree800272920d5e9f055fd7475119027d78c7a2c114 /net-nntp/nget
parentThis package was submitted by Nguyen Thai Ngoc Duy <pclouds@gentoo.org> in bu... (diff)
downloadgentoo-2-3d4eec27551fda8d2e32246cf13095204948680a.tar.gz
gentoo-2-3d4eec27551fda8d2e32246cf13095204948680a.tar.bz2
gentoo-2-3d4eec27551fda8d2e32246cf13095204948680a.zip
gcc-4.3 fix as per bug #199587 thanks to upstream for the patch, Mark for pointing me to it and Diego for reporting the bug
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'net-nntp/nget')
-rw-r--r--net-nntp/nget/ChangeLog7
-rw-r--r--net-nntp/nget/files/nget-0.27.1-gcc-4.3.patch40
-rw-r--r--net-nntp/nget/nget-0.27.1.ebuild12
3 files changed, 55 insertions, 4 deletions
diff --git a/net-nntp/nget/ChangeLog b/net-nntp/nget/ChangeLog
index 9075a632e41f..9b6d456c9530 100644
--- a/net-nntp/nget/ChangeLog
+++ b/net-nntp/nget/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-nntp/nget
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/nget/ChangeLog,v 1.11 2008/04/21 18:12:26 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/nget/ChangeLog,v 1.12 2008/05/04 01:34:25 dragonheart Exp $
+
+ 04 May 2008; Daniel Black <dragonheart@gentoo.org>
+ +files/nget-0.27.1-gcc-4.3.patch, nget-0.27.1.ebuild:
+ gcc-4.3 fix as per bug #199587 thanks to upstream for the patch, Mark for
+ pointing me to it and Diego for reporting the bug
21 Apr 2008; Christian Heim <phreak@gentoo.org> metadata.xml:
Fix up metadata.xml. If there's no maintainer for the package, the metadata
diff --git a/net-nntp/nget/files/nget-0.27.1-gcc-4.3.patch b/net-nntp/nget/files/nget-0.27.1-gcc-4.3.patch
new file mode 100644
index 000000000000..d990c6a139c5
--- /dev/null
+++ b/net-nntp/nget/files/nget-0.27.1-gcc-4.3.patch
@@ -0,0 +1,40 @@
+--- auto_map.h 2004/06/17 20:59:44 1.8
++++ auto_map.h 2008/03/03 06:41:59 1.9
+@@ -23,10 +23,10 @@
+ #include <assert.h>
+ #include <map>
+
+-template <class K, class T, template <class BK, class BT> class Base>
+-class auto_map_base : public Base<K, restricted_ptr<T> > {
++template <class K, class T, class Base>
++class auto_map_base : public Base {
+ protected:
+- typedef Base<K, restricted_ptr<T> > super;
++ typedef Base super;
+ public:
+ typedef typename super::iterator iterator;
+
+@@ -55,9 +55,9 @@
+
+
+ template <class K, class T>
+-class auto_map : public auto_map_base<K, T, std::map> {
++class auto_map : public auto_map_base<K, T, std::map<K, restricted_ptr<T> > > {
+ public:
+- typedef typename auto_map_base<K, T, std::map>::super super;
++ typedef typename auto_map_base<K, T, std::map<K, restricted_ptr<T> > >::super super;
+ typedef typename super::iterator iterator;
+ typedef typename super::value_type value_type;
+ /*super::value_type value_type(const K &k, T*p) {
+@@ -74,9 +74,9 @@
+ };
+
+ template <class K, class T>
+-class auto_multimap : public auto_map_base<K, T, std::multimap> {
++class auto_multimap : public auto_map_base<K, T, std::multimap<K, restricted_ptr<T> > > {
+ public:
+- typedef typename auto_map_base<K, T, std::multimap>::super super;
++ typedef typename auto_map_base<K, T, std::multimap<K, restricted_ptr<T> > >::super super;
+ typedef typename super::iterator iterator;
+ typedef typename super::value_type value_type;
+ iterator insert_value(const K &k, T* p) { //we can't really use the normal insert funcs, but we don't want to just name it insert since it would be easy to confuse with all the normal map insert funcs
diff --git a/net-nntp/nget/nget-0.27.1.ebuild b/net-nntp/nget/nget-0.27.1.ebuild
index 914878af7d3c..479ce7d4fe8a 100644
--- a/net-nntp/nget/nget-0.27.1.ebuild
+++ b/net-nntp/nget/nget-0.27.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/nget/nget-0.27.1.ebuild,v 1.9 2006/09/23 08:00:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/nget/nget-0.27.1.ebuild,v 1.10 2008/05/04 01:34:25 dragonheart Exp $
-inherit flag-o-matic
+inherit flag-o-matic eutils
DESCRIPTION="Network utility to retrieve files from an NNTP news server"
HOMEPAGE="http://nget.sourceforge.net/"
@@ -19,6 +19,12 @@ RDEPEND="dev-libs/popt
zlib? ( sys-libs/zlib )"
DEPEND="dev-libs/uulib"
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc-4.3.patch
+}
+
src_compile() {
use static && append-flags -static