summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-07-14 10:48:43 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-07-14 10:48:43 +0000
commite87ac181fa0f5ae69abc777fcb45479af47961f4 (patch)
tree507b6e78f8e69129a608740b9358c68f7e49252d /net-nntp/pan
parentfinally fixed init-sript for OpenRC. (diff)
downloadgentoo-2-e87ac181fa0f5ae69abc777fcb45479af47961f4.tar.gz
gentoo-2-e87ac181fa0f5ae69abc777fcb45479af47961f4.tar.bz2
gentoo-2-e87ac181fa0f5ae69abc777fcb45479af47961f4.zip
add live ebuid, courtesy of Duncan <1i5t5.duncan@cox.net>.
(Portage version: 2.2_rc1/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'net-nntp/pan')
-rw-r--r--net-nntp/pan/ChangeLog7
-rw-r--r--net-nntp/pan/pan-9999.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/net-nntp/pan/ChangeLog b/net-nntp/pan/ChangeLog
index 343bb4a2bc91..49ba51f90751 100644
--- a/net-nntp/pan/ChangeLog
+++ b/net-nntp/pan/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-nntp/pan
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/pan/ChangeLog,v 1.65 2008/06/30 16:10:57 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/pan/ChangeLog,v 1.66 2008/07/14 10:48:43 eva Exp $
+
+*pan-9999 (14 Jul 2008)
+
+ 14 Jul 2008; Gilles Dartiguelongue <eva@gentoo.org> +pan-9999.ebuild:
+ add live ebuid, courtesy of Duncan <1i5t5.duncan@cox.net>.
30 Jun 2008; Jeroen Roovers <jer@gentoo.org> pan-0.132-r3.ebuild:
Stable for HPPA (bug #227679).
diff --git a/net-nntp/pan/pan-9999.ebuild b/net-nntp/pan/pan-9999.ebuild
new file mode 100644
index 000000000000..5c43ead3ff7b
--- /dev/null
+++ b/net-nntp/pan/pan-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/pan/pan-9999.ebuild,v 1.1 2008/07/14 10:48:43 eva Exp $
+
+inherit autotools subversion
+
+DESCRIPTION="A newsreader for the Gnome2 desktop"
+HOMEPAGE="http://pan.rebelbase.com/"
+
+ESVN_REPO_URI="http://svn.gnome.org/svn/pan2/trunk"
+ESVN_STORE_DIR="${PORTAGE_ACTUAL_DISTDIR-${DISTDIR}}"
+# maximum svn update frequency, hours
+ESVN_UP_FREQ="${ESVN_UP_FREQ:-1}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="spell"
+
+RDEPEND=">=dev-libs/glib-2.4.0
+ >=x11-libs/gtk+-2.4.0
+ >=dev-libs/libpcre-5.0
+ >=dev-libs/gmime-2.1.9
+ spell? ( >=app-text/gtkspell-2.0.7 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.21
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+ # The normal version tree ebuild we are based on (for patching)
+ Pnorm="${PN}-0.132"
+
+src_unpack() {
+ subversion_src_unpack
+ cd "${S}"
+
+ # bootstrap build system
+ intltoolize --force || die "intltoolize failed"
+ eautoreconf
+}
+
+src_compile() {
+ econf $(use_with spell gtkspell) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed"
+}