summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-01-09 19:11:02 +0000
committerJeroen Roovers <jer@gentoo.org>2010-01-09 19:11:02 +0000
commit525ded187dbc16ebb78ccba5433b7aeb51c9b9c7 (patch)
tree26f2437c128ccc00846099e1fef09a8c040291b3 /net-nntp/tin
parentTransfer Prefix keywords (diff)
downloadgentoo-2-525ded187dbc16ebb78ccba5433b7aeb51c9b9c7.tar.gz
gentoo-2-525ded187dbc16ebb78ccba5433b7aeb51c9b9c7.tar.bz2
gentoo-2-525ded187dbc16ebb78ccba5433b7aeb51c9b9c7.zip
Describe cancel-locks USE flag better. Do not strip. Do not install the colliding man pages. Set unicode USE dep for ncurses. Unify if-thens in configure or replace them with [..] || [..]. Do not die() when USE="cancel-locks -evil". econf needs no die(). Run emake build (or it will compile in src_install(). emake instead of make. Sort DEPENDs alphanumerically.
(Portage version: 2.2_rc61/cvs/Linux i686)
Diffstat (limited to 'net-nntp/tin')
-rw-r--r--net-nntp/tin/ChangeLog13
-rw-r--r--net-nntp/tin/metadata.xml2
-rw-r--r--net-nntp/tin/tin-1.8.3.ebuild9
-rw-r--r--net-nntp/tin/tin-1.9.4-r1.ebuild81
-rw-r--r--net-nntp/tin/tin-1.9.4.ebuild47
5 files changed, 120 insertions, 32 deletions
diff --git a/net-nntp/tin/ChangeLog b/net-nntp/tin/ChangeLog
index 21a20ce7e851..aba78c107df3 100644
--- a/net-nntp/tin/ChangeLog
+++ b/net-nntp/tin/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for net-nntp/tin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/tin/ChangeLog,v 1.24 2010/01/08 17:44:53 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/tin/ChangeLog,v 1.25 2010/01/09 19:11:02 jer Exp $
+
+*tin-1.9.4-r1 (09 Jan 2010)
+
+ 09 Jan 2010; Jeroen Roovers <jer@gentoo.org> tin-1.8.3.ebuild,
+ tin-1.9.4.ebuild, +tin-1.9.4-r1.ebuild, metadata.xml:
+ Describe cancel-locks USE flag better. Do not strip. Do not install the
+ colliding man pages. Set unicode USE dep for ncurses. Unify if-thens in
+ configure or replace them with [..] [..]. Do not die() when
+ USE="cancel-locks -evil". econf needs no die(). Run emake build (or it
+ will compile in src_install(). emake instead of make. Sort DEPENDs
+ alphanumerically.
08 Jan 2010; Patrick Lauer <patrick@gentoo.org> tin-1.9.4.ebuild:
Fixing unneeded built_with_use for eapi2
diff --git a/net-nntp/tin/metadata.xml b/net-nntp/tin/metadata.xml
index 84f03bcd5f09..b3076b70479e 100644
--- a/net-nntp/tin/metadata.xml
+++ b/net-nntp/tin/metadata.xml
@@ -3,7 +3,7 @@
<pkgmetadata>
<herd>net-news</herd>
<use>
-<flag name='cancel-locks'>Enable CancelLock functionality</flag>
+<flag name='cancel-locks'>Enable Cancel-Lock header functionality (also enables USE=evil)</flag>
<flag name='evil'>Let tin generate a message ID</flag>
<flag name='forgery'>Cancel messages posted from a different account</flag>
<flag name='etiquette'>Enable the display off posting etiquettes</flag>
diff --git a/net-nntp/tin/tin-1.8.3.ebuild b/net-nntp/tin/tin-1.8.3.ebuild
index 0bb128f0805c..5c54216e55c9 100644
--- a/net-nntp/tin/tin-1.8.3.ebuild
+++ b/net-nntp/tin/tin-1.8.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/tin/tin-1.8.3.ebuild,v 1.7 2009/03/08 10:30:25 cla Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/tin/tin-1.8.3.ebuild,v 1.8 2010/01/09 19:11:02 jer Exp $
EAPI="2"
@@ -25,10 +25,7 @@ DEPEND="dev-libs/libpcre
RDEPEND="${DEPEND}
net-misc/urlview"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
epatch "${FILESDIR}"/1.8.2-various.patch
}
diff --git a/net-nntp/tin/tin-1.9.4-r1.ebuild b/net-nntp/tin/tin-1.9.4-r1.ebuild
new file mode 100644
index 000000000000..b75410e048b1
--- /dev/null
+++ b/net-nntp/tin/tin-1.9.4-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/tin/tin-1.9.4-r1.ebuild,v 1.1 2010/01/09 19:11:02 jer Exp $
+
+EAPI="2"
+
+inherit versionator eutils
+
+DESCRIPTION="A threaded NNTP and spool based UseNet newsreader"
+HOMEPAGE="http://www.tin.org/"
+SRC_URI="ftp://ftp.tin.org/pub/news/clients/tin/v$(get_version_component_range 1-2)/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+IUSE="cancel-locks crypt debug evil forgery idn ipv6 nls unicode socks5 +etiquette"
+
+DEPEND="
+ crypt? ( app-crypt/gnupg )
+ idn? ( net-dns/libidn )
+ nls? ( sys-devel/gettext )
+ socks5? ( net-proxy/dante )
+ unicode? ( dev-libs/icu )
+ dev-libs/libpcre
+ dev-libs/uulib
+ sys-libs/ncurses[unicode?]
+"
+
+RDEPEND="${DEPEND}
+ net-misc/urlview"
+
+src_prepare() {
+ # Do not strip
+ sed -i src/Makefile.in -e '388s|-s ||g' || die "sed src/Makefile.in failed"
+}
+
+src_compile() {
+ emake build || die "emake failed"
+}
+
+src_configure() {
+ if use evil || use cancel-locks; then
+ sed -i -e"s/# -DEVIL_INSIDE/-DEVIL_INSIDE/" src/Makefile.in
+ fi
+
+ if use forgery
+ then
+ sed -i -e"s/^CPPFLAGS.*/& -DFORGERY/" src/Makefile.in
+ fi
+
+ local screen="ncurses"
+ use unicode && screen="ncursesw"
+
+ use etiquette || myconf="${myconf} --disable-etiquette"
+
+ econf \
+ --with-pcre=/usr \
+ --enable-nntp-only \
+ --enable-prototypes \
+ --disable-echo \
+ --disable-mime-strict-charset \
+ --with-coffee \
+ --with-screen=${screen} \
+ --with-nntp-default-server="${TIN_DEFAULT_SERVER:-${NNTPSERVER:-news.gmane.org}}" \
+ $(use_enable ipv6) \
+ $(use_enable debug) \
+ $(use_enable crypt pgp-gpg) \
+ $(use_enable nls) \
+ $(use_enable cancel-locks) \
+ $(use_with socks5) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ rm -f "${D}"/usr/share/man/man5/{mbox,mmdf}.5
+
+ dodoc doc/{CHANGES{,.old},CREDITS,TODO,WHATSNEW,*.sample,*.txt} || die "dodoc failed"
+ insinto /etc/tin
+ doins doc/tin.defaults || die "doins failed"
+}
diff --git a/net-nntp/tin/tin-1.9.4.ebuild b/net-nntp/tin/tin-1.9.4.ebuild
index 319cc4d8044f..ef35a5d64741 100644
--- a/net-nntp/tin/tin-1.9.4.ebuild
+++ b/net-nntp/tin/tin-1.9.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/tin/tin-1.9.4.ebuild,v 1.3 2010/01/08 17:44:53 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/tin/tin-1.9.4.ebuild,v 1.4 2010/01/09 19:11:02 jer Exp $
EAPI="2"
@@ -15,23 +15,31 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
IUSE="cancel-locks crypt debug evil forgery idn ipv6 nls unicode socks5 +etiquette"
-DEPEND="sys-libs/ncurses
- dev-libs/libpcre
- dev-libs/uulib
+DEPEND="
+ crypt? ( app-crypt/gnupg )
idn? ( net-dns/libidn )
- unicode? ( dev-libs/icu
- sys-libs/ncurses[unicode] )
nls? ( sys-devel/gettext )
- crypt? ( app-crypt/gnupg )
- socks5? ( net-proxy/dante )"
+ socks5? ( net-proxy/dante )
+ unicode? ( dev-libs/icu )
+ dev-libs/libpcre
+ dev-libs/uulib
+ sys-libs/ncurses[unicode?]
+"
RDEPEND="${DEPEND}
net-misc/urlview"
-src_configure() {
+src_prepare() {
+ # Do not strip
+ sed -i src/Makefile.in -e '388s|-s ||g' || die "sed src/Makefile.in failed"
+}
- if use evil
- then
+src_compile() {
+ emake build || die "emake failed"
+}
+
+src_configure() {
+ if use evil || use cancel-locks; then
sed -i -e"s/# -DEVIL_INSIDE/-DEVIL_INSIDE/" src/Makefile.in
fi
@@ -43,13 +51,7 @@ src_configure() {
local screen="ncurses"
use unicode && screen="ncursesw"
- if ! use etiquette; then
- myconf="${myconf} --disable-etiquette"
- fi
-
- if ! use evil && use cancel-locks; then
- die "USE=cancel-locks requires also USE=evil to generate MIDs and the Cancel-Lock:-Header."
- fi
+ use etiquette || myconf="${myconf} --disable-etiquette"
econf \
--with-pcre=/usr \
@@ -66,15 +68,12 @@ src_configure() {
$(use_enable nls) \
$(use_enable cancel-locks) \
$(use_with socks5) \
- ${myconf} \
- || die "econf failed"
+ ${myconf}
}
src_install() {
- if has_version mail-client/mutt; then
- rm doc/mmdf.5 doc/mbox.5
- fi
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "make install failed"
+ rm -f "${D}"/usr/share/man/man5/{mbox,mmdf}.5
dodoc doc/{CHANGES{,.old},CREDITS,TODO,WHATSNEW,*.sample,*.txt} || die "dodoc failed"
insinto /etc/tin