summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-05-21 10:51:29 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-05-21 10:51:29 +0000
commit1394a9de38f72c535109422fea445fcc37db252a (patch)
treec4d37ec28be6a5f68046fd88b4072e801e9a264c /net-p2p/deluge
parentAdded local USE flag 'cupsddk' for net-print/hplip. (diff)
downloadgentoo-2-1394a9de38f72c535109422fea445fcc37db252a.tar.gz
gentoo-2-1394a9de38f72c535109422fea445fcc37db252a.tar.bz2
gentoo-2-1394a9de38f72c535109422fea445fcc37db252a.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-p2p/deluge')
-rw-r--r--net-p2p/deluge/ChangeLog7
-rw-r--r--net-p2p/deluge/deluge-0.5.9.1.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/net-p2p/deluge/ChangeLog b/net-p2p/deluge/ChangeLog
index 1e8f508e763a..6de681f20550 100644
--- a/net-p2p/deluge/ChangeLog
+++ b/net-p2p/deluge/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/deluge
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/ChangeLog,v 1.70 2008/05/09 13:29:48 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/ChangeLog,v 1.71 2008/05/21 10:51:29 armin76 Exp $
+
+*deluge-0.5.9.1 (21 May 2008)
+
+ 21 May 2008; Raúl Porcel <armin76@gentoo.org> +deluge-0.5.9.1.ebuild:
+ Version bump
09 May 2008; Raúl Porcel <armin76@gentoo.org> -deluge-0.5.8.5.ebuild,
-deluge-0.5.8.6.ebuild, -deluge-0.5.8.7.ebuild, deluge-0.5.8.9.ebuild:
diff --git a/net-p2p/deluge/deluge-0.5.9.1.ebuild b/net-p2p/deluge/deluge-0.5.9.1.ebuild
new file mode 100644
index 000000000000..e430b5012ddf
--- /dev/null
+++ b/net-p2p/deluge/deluge-0.5.9.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-0.5.9.1.ebuild,v 1.1 2008/05/21 10:51:29 armin76 Exp $
+
+inherit eutils distutils flag-o-matic
+
+DESCRIPTION="BitTorrent client in Python and PyGTK."
+HOMEPAGE="http://deluge-torrent.org/"
+SRC_URI="http://download.deluge-torrent.org/source/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="libnotify"
+
+S="${WORKDIR}"/${PN}-torrent-${PV}
+
+DEPEND=">=dev-lang/python-2.3
+ dev-libs/boost"
+RDEPEND="${DEPEND}
+ >=dev-python/pygtk-2
+ dev-python/pyxdg
+ dev-python/dbus-python
+ gnome-base/librsvg
+ libnotify? ( dev-python/notify-python )"
+
+pkg_setup() {
+ if ! built_with_use --missing true "dev-libs/boost" threads; then
+ eerror "dev-libs/boost has to be built with threads USE-flag."
+ die "Missing threads USE-flag for dev-libs/boost"
+ fi
+
+ filter-ldflags -Wl,--as-needed
+}
+
+pkg_postinst() {
+ elog
+ elog "If after upgrading it doesn't work, please remove the"
+ elog "'~/.config/deluge' directory and try again, but make a backup"
+ elog "first!"
+ elog
+ elog "Please note that Deluge is still in it's early stages"
+ elog "of development. Use it carefully and feel free to submit bugs"
+ elog "in upstream page."
+ elog
+}