summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2009-03-01 03:10:43 +0000
committerThomas Sachau <tommy@gentoo.org>2009-03-01 03:10:43 +0000
commit6b6d1a32db67e2813eba324658eaf93735da0448 (patch)
tree3b987b3127365977793dcf252b9819d0f7cfbbac /net-p2p/fms
parentSparc stable, security Bug #260514. (diff)
downloadgentoo-2-6b6d1a32db67e2813eba324658eaf93735da0448.tar.gz
gentoo-2-6b6d1a32db67e2813eba324658eaf93735da0448.tar.bz2
gentoo-2-6b6d1a32db67e2813eba324658eaf93735da0448.zip
Version bump
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p/fms')
-rw-r--r--net-p2p/fms/ChangeLog8
-rw-r--r--net-p2p/fms/fms-0.3.32.ebuild59
2 files changed, 66 insertions, 1 deletions
diff --git a/net-p2p/fms/ChangeLog b/net-p2p/fms/ChangeLog
index 095cc4ec0cd3..ef6d33ebef28 100644
--- a/net-p2p/fms/ChangeLog
+++ b/net-p2p/fms/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/fms
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/fms/ChangeLog,v 1.5 2009/02/12 18:07:16 tommy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/fms/ChangeLog,v 1.6 2009/03/01 03:10:43 tommy Exp $
+
+*fms-0.3.32 (01 Mar 2009)
+
+ 01 Mar 2009; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ +fms-0.3.32.ebuild:
+ Version bump
*fms-0.3.31-r1 (12 Feb 2009)
diff --git a/net-p2p/fms/fms-0.3.32.ebuild b/net-p2p/fms/fms-0.3.32.ebuild
new file mode 100644
index 000000000000..98007d86ea8e
--- /dev/null
+++ b/net-p2p/fms/fms-0.3.32.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/fms/fms-0.3.32.ebuild,v 1.1 2009/03/01 03:10:43 tommy Exp $
+
+inherit eutils cmake-utils
+
+DESCRIPTION="A spam-resistant message board application for Freenet"
+HOMEPAGE="http://freenetproject.org/tools.html"
+SRC_URI="mirror://gentoo/${PN}-src-${PV}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/libiconv
+ >=dev-libs/poco-1.2.9
+ || ( =dev-db/sqlite-3.6.6.2* >=dev-db/sqlite-3.6.11 )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ enewgroup freenet
+ enewuser freenet -1 -1 /var/freenet freenet
+}
+
+src_compile() {
+ local mycmakeargs="-DI_HAVE_READ_THE_README=ON \
+ -DUSE_BUNDLED_SQLITE=OFF \
+ -DDO_CHARSET_CONVERSION=ON"
+ cmake-utils_src_compile
+}
+
+src_install() {
+ insinto /var/freenet/fms
+ dobin ${PN}_build/fms || die
+ doins {forum-,}template.htm || die "doinstall failed"
+ insinto /var/freenet/fms/fonts
+ doins fonts/*.bmp || die "doinstall of fonts failed"
+ insinto /var/freenet/fms/images
+ doins images/*png || die "doinstall of images failed"
+ fperms -R o-rwx /var/freenet/fms/ /usr/bin/fms
+ fowners -R freenet:freenet /var/freenet/fms/ /usr/bin/fms
+ doinitd "${FILESDIR}/fms" || die "installing init.d file failed"
+ dodoc readme.txt || die "installing doc failed"
+}
+
+pkg_postinst() {
+ if ! has_version 'net-p2p/freenet' ; then
+ ewarn "FMS needs a freenet node to up-/download messages."
+ ewarn "Please make sure to have a node you can connect to"
+ ewarn "or install net-p2p/freenet to get FMS working."
+ fi
+ elog "By default, the FMS NNTP server will listen on port 1119,"
+ elog "and the web configuration interface will be running at"
+ elog "http://localhost:8080. For more information, read"
+ elog "${ROOT}/usr/share/doc/${PF}/readme.txt."
+}