summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-03-16 16:31:48 +0000
committerSamuli Suominen <drac@gentoo.org>2008-03-16 16:31:48 +0000
commitb1fc7fd05fa74129290ecb854daa0774e59d6b89 (patch)
tree8a3d3cf1e357117dfcd6522ef6bedcb1d811dea1 /net-p2p/hrktorrent
parentCleanup. (diff)
downloadgentoo-2-b1fc7fd05fa74129290ecb854daa0774e59d6b89.tar.gz
gentoo-2-b1fc7fd05fa74129290ecb854daa0774e59d6b89.tar.bz2
gentoo-2-b1fc7fd05fa74129290ecb854daa0774e59d6b89.zip
Version bump wrt #213515, thanks to Nico R. Wohlgemuth for reporting.
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-p2p/hrktorrent')
-rw-r--r--net-p2p/hrktorrent/ChangeLog7
-rw-r--r--net-p2p/hrktorrent/hrktorrent-0.3.1.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/net-p2p/hrktorrent/ChangeLog b/net-p2p/hrktorrent/ChangeLog
index 83bdc8376b08..c3659d21c983 100644
--- a/net-p2p/hrktorrent/ChangeLog
+++ b/net-p2p/hrktorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/hrktorrent
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/hrktorrent/ChangeLog,v 1.7 2008/02/25 14:17:51 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/hrktorrent/ChangeLog,v 1.8 2008/03/16 16:31:48 drac Exp $
+
+*hrktorrent-0.3.1 (16 Mar 2008)
+
+ 16 Mar 2008; Samuli Suominen <drac@gentoo.org> +hrktorrent-0.3.1.ebuild:
+ Version bump wrt #213515, thanks to Nico R. Wohlgemuth for reporting.
25 Feb 2008; Raúl Porcel <armin76@gentoo.org> hrktorrent-0.3.0.ebuild:
x86 stable
diff --git a/net-p2p/hrktorrent/hrktorrent-0.3.1.ebuild b/net-p2p/hrktorrent/hrktorrent-0.3.1.ebuild
new file mode 100644
index 000000000000..c713e0b34e09
--- /dev/null
+++ b/net-p2p/hrktorrent/hrktorrent-0.3.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/hrktorrent/hrktorrent-0.3.1.ebuild,v 1.1 2008/03/16 16:31:48 drac Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="A slim rb_libtorrent based console torrent application supporting DHT"
+HOMEPAGE="http://henrik.unit5.ca/hrktorrent"
+SRC_URI="http://henrik.unit5.ca/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=net-libs/rb_libtorrent-0.12"
+DEPEND="${RDEPEND}
+ dev-cpp/asio
+ dev-util/pkgconfig"
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" || die "emake failed."
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc CHANGELOG README ${PN}.rc.example
+}
+
+pkg_postinst() {
+ elog "Extract ${PN}.rc.example from /usr/share/doc/${PF} to"
+ elog "home ~/.${PN}/${PN}.rc for example config."
+}