summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-06-30 10:06:40 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-06-30 10:06:40 +0000
commit04a21d4273fac0078f2a9a6e1486638430e6e495 (patch)
tree21f91eea8dd51e164a84978328b6e5e9acf8bbd6 /net-p2p/linuxdcpp
parentCorrect date (diff)
downloadgentoo-2-04a21d4273fac0078f2a9a6e1486638430e6e495.tar.gz
gentoo-2-04a21d4273fac0078f2a9a6e1486638430e6e495.tar.bz2
gentoo-2-04a21d4273fac0078f2a9a6e1486638430e6e495.zip
Make it compile with gcc-4.3, bug #228891
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-p2p/linuxdcpp')
-rw-r--r--net-p2p/linuxdcpp/ChangeLog6
-rw-r--r--net-p2p/linuxdcpp/files/1.0.1-gcc-4.3.patch16
-rw-r--r--net-p2p/linuxdcpp/linuxdcpp-1.0.1-r2.ebuild4
3 files changed, 24 insertions, 2 deletions
diff --git a/net-p2p/linuxdcpp/ChangeLog b/net-p2p/linuxdcpp/ChangeLog
index ace089bd5545..10cabd79380f 100644
--- a/net-p2p/linuxdcpp/ChangeLog
+++ b/net-p2p/linuxdcpp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/linuxdcpp
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/linuxdcpp/ChangeLog,v 1.28 2008/06/30 07:51:57 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/linuxdcpp/ChangeLog,v 1.29 2008/06/30 10:06:39 armin76 Exp $
+
+ 30 Jun 2008; Raúl Porcel <armin76@gentoo.org> +files/1.0.1-gcc-4.3.patch,
+ linuxdcpp-1.0.1-r2.ebuild:
+ Make it compile with gcc-4.3, bug #228891
30 Jun 2008; Christian Faulhammer <opfer@gentoo.org>
linuxdcpp-1.0.1-r2.ebuild:
diff --git a/net-p2p/linuxdcpp/files/1.0.1-gcc-4.3.patch b/net-p2p/linuxdcpp/files/1.0.1-gcc-4.3.patch
new file mode 100644
index 000000000000..279663eddefb
--- /dev/null
+++ b/net-p2p/linuxdcpp/files/1.0.1-gcc-4.3.patch
@@ -0,0 +1,16 @@
+diff -NrU5 linuxdcpp-1.0.1.orig/client/ShareManager.h linuxdcpp-1.0.1/client/ShareManager.h
+--- linuxdcpp-1.0.1.orig/client/ShareManager.h 2007-07-07 22:02:08.000000000 +0200
++++ linuxdcpp-1.0.1/client/ShareManager.h 2008-06-22 14:14:30.000000000 +0200
+@@ -35,10 +35,12 @@
+ #include "Singleton.h"
+ #include "BloomFilter.h"
+ #include "FastAlloc.h"
+ #include "MerkleTree.h"
+
++#include <memory> // GCC 4.3 fix
++
+ STANDARD_EXCEPTION(ShareException);
+
+ class SimpleXML;
+ class Client;
+ class File;
diff --git a/net-p2p/linuxdcpp/linuxdcpp-1.0.1-r2.ebuild b/net-p2p/linuxdcpp/linuxdcpp-1.0.1-r2.ebuild
index 486d15e6751b..0b6a83a7a9e7 100644
--- a/net-p2p/linuxdcpp/linuxdcpp-1.0.1-r2.ebuild
+++ b/net-p2p/linuxdcpp/linuxdcpp-1.0.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/linuxdcpp/linuxdcpp-1.0.1-r2.ebuild,v 1.2 2008/06/30 07:51:57 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/linuxdcpp/linuxdcpp-1.0.1-r2.ebuild,v 1.3 2008/06/30 10:06:39 armin76 Exp $
inherit eutils
@@ -24,7 +24,9 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
cd "${S}"
+
epatch "${FILESDIR}"/${P}-fix-remote-vulnerability.patch
+ epatch "${FILESDIR}"/${PV}-gcc-4.3.patch
}
src_compile() {