summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannes Mehnert <hannes@gentoo.org>2003-03-23 18:43:19 +0000
committerHannes Mehnert <hannes@gentoo.org>2003-03-23 18:43:19 +0000
commit2de96332d73620647adb3cbb053ece425c8e78a0 (patch)
tree36bf6b87fe4895b999b25c195351d87305c4aa7f /net-p2p/mldonkey
parentremoved old versions (diff)
downloadgentoo-2-2de96332d73620647adb3cbb053ece425c8e78a0.tar.gz
gentoo-2-2de96332d73620647adb3cbb053ece425c8e78a0.tar.bz2
gentoo-2-2de96332d73620647adb3cbb053ece425c8e78a0.zip
version bump, closes #17365
Diffstat (limited to 'net-p2p/mldonkey')
-rw-r--r--net-p2p/mldonkey/ChangeLog7
-rw-r--r--net-p2p/mldonkey/files/digest-mldonkey-2.04_rc11
-rw-r--r--net-p2p/mldonkey/mldonkey-2.04_rc1.ebuild65
3 files changed, 72 insertions, 1 deletions
diff --git a/net-p2p/mldonkey/ChangeLog b/net-p2p/mldonkey/ChangeLog
index 7a29a1129d68..d2131b7e443d 100644
--- a/net-p2p/mldonkey/ChangeLog
+++ b/net-p2p/mldonkey/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/mldonkey
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/mldonkey/ChangeLog,v 1.11 2003/02/12 08:40:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/mldonkey/ChangeLog,v 1.12 2003/03/23 18:43:19 hannes Exp $
+
+*mldonkey-2.04_rc1 (23 Mar 2003)
+
+ 23 Mar 2003; Hannes Mehnert <hannes@gentoo.org> mldonkey-2.04_rc1.ebuild:
+ version bump, thanks to Vesa Kaihlavirta <vpkaihla@cc.jyu.fi> (bug #17365)
*mldonkwy-2.02-r2 (26 Jan 2003)
diff --git a/net-p2p/mldonkey/files/digest-mldonkey-2.04_rc1 b/net-p2p/mldonkey/files/digest-mldonkey-2.04_rc1
new file mode 100644
index 000000000000..adc1ac8b47a7
--- /dev/null
+++ b/net-p2p/mldonkey/files/digest-mldonkey-2.04_rc1
@@ -0,0 +1 @@
+MD5 ea7a2320fd7d89c994de5a098e0e119a mldonkey-2.04rc1.sources.tar.gz 1774707
diff --git a/net-p2p/mldonkey/mldonkey-2.04_rc1.ebuild b/net-p2p/mldonkey/mldonkey-2.04_rc1.ebuild
new file mode 100644
index 000000000000..1060e067e5c4
--- /dev/null
+++ b/net-p2p/mldonkey/mldonkey-2.04_rc1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/mldonkey/mldonkey-2.04_rc1.ebuild,v 1.1 2003/03/23 18:43:19 hannes Exp $
+
+IUSE="gtk"
+
+S="${WORKDIR}/${PN}"
+MY_PV=${PV/_/}
+
+DESCRIPTION="mldonkey is a new client to access the eDonkey network. It is written in Objective-Caml, and comes with its own GTK GUI, an HTTP interface and a telnet interface."
+HOMEPAGE="http://savannah.nongnu.org/projects/mldonkey/"
+SRC_URI="http://savannah.nongnu.org/download/${PN}/release-${MY_PV}/${PN}-${MY_PV}.sources.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="gtk? ( >=lablgtk-1.2.3 )
+ >=dev-lang/ocaml-3.06
+ dev-lang/perl"
+
+src_compile() {
+ use gtk || export GTK_CONFIG="no"
+
+ # the dirs are not (yet) used, but it doesn't hurt to specify them anyway
+ econf \
+ --sysconfdir=/etc/mldonkey \
+ --sharedstatedir=/var/mldonkey \
+ --localstatedir=/var/mldonkey \
+ --enable-ocamlver=3.06
+
+ emake || die
+}
+
+src_install() {
+ dobin mldonkey mlchat mldc mlgnut mlim mlnap mlnet mlslsk use_tags \
+ mldonkey_gui mldonkey+gui mldonkey_gui2 mldonkey_guistarter \
+ mlgnu+gui mlslsk+gui mlnap+gui mlgnut+gui mldc+gui
+
+ cd docs
+ dodoc *.txt *.pdf *tex
+ dohtml *.html
+ insinto /usr/share/doc/${PF}/images
+ doins images/*
+
+ cd ${S}/distrib
+ dodoc AUTHORS BUGS COPYING ChangeLog Developers.txt ed2k_links.txt \
+ Readme.txt TODO
+ dohtml FAQ.html
+
+ insinto /usr/share/doc/${PF}/scripts
+ doins kill_mldonkey mldonkey_command mldonkey_previewer;
+
+ insinto /usr/share/doc/${PF}/distrib
+ doins directconnect.ini;
+
+
+}
+
+pkg_postinst() {
+ einfo "To start mldonkey, copy the contents of \$doc/distrib in a"
+ einfo "writable directory, and start mldonkey from there."
+ einfo "Eg: cp everything to /home/user1/mldonkey"
+ einfo "then: cd /home/user1/mldonkey && mldonkey >> mld.log &"
+}