summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-06-26 23:35:58 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-06-26 23:35:58 +0000
commit8c02c029251fa1fcc43710ab4906c6df93ddafce (patch)
tree5e38f3d98bc84602485993d11bb32e692091861e /net-p2p/qbittorrent
parentStable on amd64 wrt bug #325643 (diff)
downloadgentoo-2-8c02c029251fa1fcc43710ab4906c6df93ddafce.tar.gz
gentoo-2-8c02c029251fa1fcc43710ab4906c6df93ddafce.tar.bz2
gentoo-2-8c02c029251fa1fcc43710ab4906c6df93ddafce.zip
Version bump to 2.2.10 and 2.3.0_beta3
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p/qbittorrent')
-rw-r--r--net-p2p/qbittorrent/ChangeLog10
-rw-r--r--net-p2p/qbittorrent/qbittorrent-2.2.10.ebuild59
-rw-r--r--net-p2p/qbittorrent/qbittorrent-2.3.0_beta3.ebuild (renamed from net-p2p/qbittorrent/qbittorrent-2.3.0_beta1.ebuild)2
3 files changed, 69 insertions, 2 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index 259cf706aaca..f05930ca24b9 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.91 2010/06/20 19:15:24 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.92 2010/06/26 23:35:58 hwoarang Exp $
+
+*qbittorrent-2.3.0_beta3 (26 Jun 2010)
+*qbittorrent-2.2.10 (26 Jun 2010)
+
+ 26 Jun 2010; Markos Chandras <hwoarang@gentoo.org>
+ +qbittorrent-2.2.10.ebuild, -qbittorrent-2.3.0_beta1.ebuild,
+ +qbittorrent-2.3.0_beta3.ebuild:
+ Version bump to 2.2.10 and 2.3.0_beta3
20 Jun 2010; Markos Chandras <hwoarang@gentoo.org>
+files/moc_bug_workaround2.patch, qbittorrent-2.2.9-r1.ebuild:
diff --git a/net-p2p/qbittorrent/qbittorrent-2.2.10.ebuild b/net-p2p/qbittorrent/qbittorrent-2.2.10.ebuild
new file mode 100644
index 000000000000..63b3ad6c6322
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-2.2.10.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.2.10.ebuild,v 1.1 2010/06/26 23:35:58 hwoarang Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+inherit python confutils qt4-r2 versionator
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="http://www.qbittorrent.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+X geoip libnotify"
+
+# boost version so that we always have thread support
+CDEPEND="net-libs/rb_libtorrent
+ x11-libs/qt-core:4
+ X? ( x11-libs/qt-gui:4
+ libnotify? ( x11-libs/qt-gui:4[glib] ) )
+ dev-libs/boost"
+DEPEND="${CDEPEND}
+ dev-util/pkgconfig"
+RDEPEND="${CDEPEND}
+ geoip? ( dev-libs/geoip )
+ libnotify? ( x11-libs/libnotify )"
+
+DOCS="AUTHORS Changelog NEWS README TODO"
+
+pkg_setup() {
+ confutils_use_depend_all libnotify X
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # Respect LDFLAGS
+ sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ local myconf
+ use X || myconf+=" --disable-gui"
+ use geoip || myconf+=" --disable-geoip-database"
+ use libnotify || myconf+=" --disable-libnotify"
+
+ # slotted boost detection, bug #309415
+ BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ myconf+=" --with-libboost-inc=/usr/include/boost-${BOOST_VER}"
+
+ # econf fails, since this uses qconf
+ ./configure --prefix=/usr --qtdir=/usr ${myconf} || die "configure failed"
+ eqmake4
+}
diff --git a/net-p2p/qbittorrent/qbittorrent-2.3.0_beta1.ebuild b/net-p2p/qbittorrent/qbittorrent-2.3.0_beta3.ebuild
index 17d77e1164a5..8b427881a7ff 100644
--- a/net-p2p/qbittorrent/qbittorrent-2.3.0_beta1.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-2.3.0_beta3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.3.0_beta1.ebuild,v 1.1 2010/06/02 14:27:35 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.3.0_beta3.ebuild,v 1.1 2010/06/26 23:35:58 hwoarang Exp $
EAPI="2"
PYTHON_DEPEND="2"