summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2007-04-04 20:02:36 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2007-04-04 20:02:36 +0000
commit1958146157274d4080a1d7ec1643324229988a49 (patch)
tree6cefd3d8284716a554552f99f8efae4c701794f8 /net-p2p/rtorrent
parentadded ~alpha keyword (diff)
downloadgentoo-2-1958146157274d4080a1d7ec1643324229988a49.tar.gz
gentoo-2-1958146157274d4080a1d7ec1643324229988a49.tar.bz2
gentoo-2-1958146157274d4080a1d7ec1643324229988a49.zip
Version bump (thx to Flameeyes for reporting on irc)
(Portage version: 2.1.2.2)
Diffstat (limited to 'net-p2p/rtorrent')
-rw-r--r--net-p2p/rtorrent/ChangeLog7
-rw-r--r--net-p2p/rtorrent/files/digest-rtorrent-0.7.43
-rw-r--r--net-p2p/rtorrent/rtorrent-0.7.4.ebuild51
3 files changed, 60 insertions, 1 deletions
diff --git a/net-p2p/rtorrent/ChangeLog b/net-p2p/rtorrent/ChangeLog
index 13cef31cad62..f25d0ea6f22c 100644
--- a/net-p2p/rtorrent/ChangeLog
+++ b/net-p2p/rtorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/rtorrent
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.88 2007/03/29 08:02:06 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.89 2007/04/04 20:02:36 drizzt Exp $
+
+*rtorrent-0.7.4 (04 Apr 2007)
+
+ 04 Apr 2007; Timothy Redaelli <drizzt@gentoo.org> +rtorrent-0.7.4.ebuild:
+ Version bump (thx to Flameeyes for reporting on irc)
29 Mar 2007; Markus Rothe <corsair@gentoo.org> rtorrent-0.7.2.ebuild:
Stable on ppc64; bug #172469
diff --git a/net-p2p/rtorrent/files/digest-rtorrent-0.7.4 b/net-p2p/rtorrent/files/digest-rtorrent-0.7.4
new file mode 100644
index 000000000000..fd35e7c22acd
--- /dev/null
+++ b/net-p2p/rtorrent/files/digest-rtorrent-0.7.4
@@ -0,0 +1,3 @@
+MD5 6a846c129c1b3d0d08478faa4c3d8339 rtorrent-0.7.4.tar.gz 451415
+RMD160 17c72af77b3184db0488147c4ae80d4019bea6f0 rtorrent-0.7.4.tar.gz 451415
+SHA256 f028656bda47ab061ca2a723aebf511a44329f40f1fd7cf995b5fefdc992b876 rtorrent-0.7.4.tar.gz 451415
diff --git a/net-p2p/rtorrent/rtorrent-0.7.4.ebuild b/net-p2p/rtorrent/rtorrent-0.7.4.ebuild
new file mode 100644
index 000000000000..251b812656cb
--- /dev/null
+++ b/net-p2p/rtorrent/rtorrent-0.7.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.7.4.ebuild,v 1.1 2007/04/04 20:02:36 drizzt Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="BitTorrent Client using libtorrent"
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug"
+
+RDEPEND=">=net-libs/libtorrent-0.11.${PV##*.}
+ >=dev-libs/libsigc++-2.0
+ >=net-misc/curl-7.15
+ sys-libs/ncurses"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ replace-flags -Os -O2
+
+ if [[ $(tc-arch) = "x86" ]]; then
+ filter-flags -fomit-frame-pointer -fforce-addr
+
+ # See bug #151221. It seems only to hit on GCC 4.1 and x86 architecture
+ # it could be safer to fallback to -O1, but with the high use of STL in
+ # rtorrent, that could make it too slow.
+ [[ $(gcc-major-version)$(gcc-minor-version) == "41" ]] && replace-flags -O2 -O3
+ fi
+
+ econf \
+ $(use_enable debug) \
+ --disable-dependency-tracking \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+pkg_postinst() {
+ elog "rtorrent now supports a configuration file."
+ elog "A sample configuration file for rtorrent is can be found"
+ elog "in ${ROOT}usr/share/doc/${PF}/rtorrent.rc.gz."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README TODO doc/rtorrent.rc
+}