summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2007-03-27 20:48:59 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2007-03-27 20:48:59 +0000
commit7e48f5d322ba302c7cc964b08ab92025ba755d0f (patch)
treed28f4c681df3257f728bfb8a613be21f3d26e3f6 /net-p2p/rtorrent
parentVersion bump (diff)
downloadgentoo-2-7e48f5d322ba302c7cc964b08ab92025ba755d0f.tar.gz
gentoo-2-7e48f5d322ba302c7cc964b08ab92025ba755d0f.tar.bz2
gentoo-2-7e48f5d322ba302c7cc964b08ab92025ba755d0f.zip
Version bump
(Portage version: 2.1.2.2)
Diffstat (limited to 'net-p2p/rtorrent')
-rw-r--r--net-p2p/rtorrent/ChangeLog7
-rw-r--r--net-p2p/rtorrent/files/digest-rtorrent-0.7.33
-rw-r--r--net-p2p/rtorrent/rtorrent-0.7.3.ebuild51
3 files changed, 60 insertions, 1 deletions
diff --git a/net-p2p/rtorrent/ChangeLog b/net-p2p/rtorrent/ChangeLog
index 917c8738e27a..596f85f81695 100644
--- a/net-p2p/rtorrent/ChangeLog
+++ b/net-p2p/rtorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/rtorrent
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.83 2007/03/19 03:23:08 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.84 2007/03/27 20:48:59 drizzt Exp $
+
+*rtorrent-0.7.3 (27 Mar 2007)
+
+ 27 Mar 2007; Timothy Redaelli <drizzt@gentoo.org> +rtorrent-0.7.3.ebuild:
+ Version bump
19 Mar 2007; Bryan Østergaard <kloeri@gentoo.org> metadata.xml:
Remove flameeyes from metadata.xml due to retirement.
diff --git a/net-p2p/rtorrent/files/digest-rtorrent-0.7.3 b/net-p2p/rtorrent/files/digest-rtorrent-0.7.3
new file mode 100644
index 000000000000..dc3ab7ee5f0b
--- /dev/null
+++ b/net-p2p/rtorrent/files/digest-rtorrent-0.7.3
@@ -0,0 +1,3 @@
+MD5 edaeef4fb596bd21baa2adff62509bb1 rtorrent-0.7.3.tar.gz 449795
+RMD160 676b9600a7dec0a85f65678a44d551104f4cbb00 rtorrent-0.7.3.tar.gz 449795
+SHA256 19b98fd5c73b097073da59651cb5a6dc367c94f6063d129b062589b330e30881 rtorrent-0.7.3.tar.gz 449795
diff --git a/net-p2p/rtorrent/rtorrent-0.7.3.ebuild b/net-p2p/rtorrent/rtorrent-0.7.3.ebuild
new file mode 100644
index 000000000000..e687af992ba9
--- /dev/null
+++ b/net-p2p/rtorrent/rtorrent-0.7.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.7.3.ebuild,v 1.1 2007/03/27 20:48:59 drizzt Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="BitTorrent Client using libtorrent"
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug"
+
+RDEPEND=">=net-libs/libtorrent-0.11.${PV##*.}
+ >=dev-libs/libsigc++-2.0
+ >=net-misc/curl-7.12
+ sys-libs/ncurses"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ replace-flags -Os -O2
+
+ if [[ $(tc-arch) = "x86" ]]; then
+ filter-flags -fomit-frame-pointer -fforce-addr
+
+ # See bug #151221. It seems only to hit on GCC 4.1 and x86 architecture
+ # it could be safer to fallback to -O1, but with the high use of STL in
+ # rtorrent, that could make it too slow.
+ [[ $(gcc-major-version)$(gcc-minor-version) == "41" ]] && replace-flags -O2 -O3
+ fi
+
+ econf \
+ $(use_enable debug) \
+ --disable-dependency-tracking \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+pkg_postinst() {
+ elog "rtorrent now supports a configuration file."
+ elog "A sample configuration file for rtorrent is can be found"
+ elog "in ${ROOT}usr/share/doc/${PF}/rtorrent.rc.gz."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README TODO doc/rtorrent.rc
+}