summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-09-14 10:50:38 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-09-14 10:50:38 +0000
commitcdc162be818658723f0a24949e4370375416a154 (patch)
treefb69cae009a4ce183f6821f5e82e917e16dd64bc /net-p2p/rtorrent
parentVersion bump. (diff)
downloadgentoo-2-cdc162be818658723f0a24949e4370375416a154.tar.gz
gentoo-2-cdc162be818658723f0a24949e4370375416a154.tar.bz2
gentoo-2-cdc162be818658723f0a24949e4370375416a154.zip
Version bump.
(Portage version: 2.1.1)
Diffstat (limited to 'net-p2p/rtorrent')
-rw-r--r--net-p2p/rtorrent/ChangeLog7
-rw-r--r--net-p2p/rtorrent/files/digest-rtorrent-0.6.23
-rw-r--r--net-p2p/rtorrent/rtorrent-0.6.2.ebuild44
3 files changed, 53 insertions, 1 deletions
diff --git a/net-p2p/rtorrent/ChangeLog b/net-p2p/rtorrent/ChangeLog
index 738ce2015fb1..2f932e576a4b 100644
--- a/net-p2p/rtorrent/ChangeLog
+++ b/net-p2p/rtorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/rtorrent
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.58 2006/09/09 12:57:37 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.59 2006/09/14 10:50:38 flameeyes Exp $
+
+*rtorrent-0.6.2 (14 Sep 2006)
+
+ 14 Sep 2006; Diego Pettenò <flameeyes@gentoo.org> +rtorrent-0.6.2.ebuild:
+ Version bump.
09 Sep 2006; Diego Pettenò <flameeyes@gentoo.org> rtorrent-0.6.0.ebuild,
rtorrent-0.6.1.ebuild:
diff --git a/net-p2p/rtorrent/files/digest-rtorrent-0.6.2 b/net-p2p/rtorrent/files/digest-rtorrent-0.6.2
new file mode 100644
index 000000000000..be450642a176
--- /dev/null
+++ b/net-p2p/rtorrent/files/digest-rtorrent-0.6.2
@@ -0,0 +1,3 @@
+MD5 b199ca24ba4a5c0f59b587cd4fa11670 rtorrent-0.6.2.tar.gz 412290
+RMD160 c1b244b42c946913c51466fa0735f14ac4c1145e rtorrent-0.6.2.tar.gz 412290
+SHA256 138cd0344dbc92c07dde928e47130e6f0c78d8a1fd10484a56007f23a6ac67d6 rtorrent-0.6.2.tar.gz 412290
diff --git a/net-p2p/rtorrent/rtorrent-0.6.2.ebuild b/net-p2p/rtorrent/rtorrent-0.6.2.ebuild
new file mode 100644
index 000000000000..cf7ece18cc8b
--- /dev/null
+++ b/net-p2p/rtorrent/rtorrent-0.6.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.6.2.ebuild,v 1.1 2006/09/14 10:50:38 flameeyes Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="BitTorrent Client using libtorrent"
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug"
+
+RDEPEND=">=net-libs/libtorrent-0.10.1
+ >=dev-libs/libsigc++-2.0
+ >=net-misc/curl-7.12
+ sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ sys-devel/bc"
+
+src_compile() {
+ [[ $(tc-arch) = "x86" ]] && filter-flags -fomit-frame-pointer
+ replace-flags -Os -O2
+
+ econf \
+ $(use_enable debug) \
+ --disable-dependency-tracking \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+pkg_postinst() {
+ einfo "rtorrent now supports a configuration file."
+ einfo "A sample configuration file for rtorrent is can be found"
+ einfo "in ${ROOT}usr/share/doc/${PF}/rtorrent.rc.gz."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README TODO doc/rtorrent.rc
+}