summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-03-04 14:39:45 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-03-04 14:39:45 +0000
commitd18496ff756c4de3036a68c7dfd4761cc9035405 (patch)
tree9ac4ef3912f731ae32bdcd01be85acfae2a941f2 /net-p2p/rtorrent
parentFix for libtool-1.5*, bug 261167. (diff)
downloadgentoo-2-d18496ff756c4de3036a68c7dfd4761cc9035405.tar.gz
gentoo-2-d18496ff756c4de3036a68c7dfd4761cc9035405.tar.bz2
gentoo-2-d18496ff756c4de3036a68c7dfd4761cc9035405.zip
Trivial gcc-4.4 fix, bug 257643. Thanks to Mike Mullen <mike@e-junky.net>.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p/rtorrent')
-rw-r--r--net-p2p/rtorrent/ChangeLog6
-rw-r--r--net-p2p/rtorrent/files/rtorrent-0.8.4-gcc44.patch105
-rw-r--r--net-p2p/rtorrent/rtorrent-0.8.4-r1.ebuild5
3 files changed, 113 insertions, 3 deletions
diff --git a/net-p2p/rtorrent/ChangeLog b/net-p2p/rtorrent/ChangeLog
index e5c34512be6c..af6f17545e43 100644
--- a/net-p2p/rtorrent/ChangeLog
+++ b/net-p2p/rtorrent/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/rtorrent
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.132 2009/03/01 19:52:19 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.133 2009/03/04 14:39:44 loki_val Exp $
+
+ 04 Mar 2009; Peter Alfredsen <loki_val@gentoo.org>
+ +files/rtorrent-0.8.4-gcc44.patch, rtorrent-0.8.4-r1.ebuild:
+ Trivial gcc-4.4 fix, bug 257643. Thanks to Mike Mullen <mike@e-junky.net>.
01 Mar 2009; Peter Alfredsen <loki_val@gentoo.org> rtorrent-0.7.9.ebuild,
rtorrent-0.8.2-r3.ebuild, rtorrent-0.8.2-r5.ebuild, rtorrent-0.8.3.ebuild,
diff --git a/net-p2p/rtorrent/files/rtorrent-0.8.4-gcc44.patch b/net-p2p/rtorrent/files/rtorrent-0.8.4-gcc44.patch
new file mode 100644
index 000000000000..fcb3ab58ecff
--- /dev/null
+++ b/net-p2p/rtorrent/files/rtorrent-0.8.4-gcc44.patch
@@ -0,0 +1,105 @@
+diff -Nurp rtorrent-0.8.4.old/src/rpc/scgi_task.cc rtorrent-0.8.4/src/rpc/scgi_task.cc
+--- rtorrent-0.8.4.old/src/rpc/scgi_task.cc 2008-05-07 07:19:10.000000000 -0500
++++ rtorrent-0.8.4/src/rpc/scgi_task.cc 2009-02-04 10:23:31.000000000 -0600
+@@ -36,6 +36,8 @@
+
+ #include "config.h"
+
++#include <cstdio>
++
+ #include <rak/error_number.h>
+ #include <sys/types.h>
+ #include <sys/socket.h>
+
+
+diff -Nurp rtorrent-0.8.4.old/src/command_peer.cc rtorrent-0.8.4/src/command_peer.cc
+--- rtorrent-0.8.4.old/src/command_peer.cc 2008-05-07 07:19:11.000000000 -0500
++++ rtorrent-0.8.4/src/command_peer.cc 2009-02-04 10:26:53.000000000 -0600
+@@ -36,6 +36,8 @@
+
+ #include "config.h"
+
++#include <cstdio>
++
+ #include <rak/error_number.h>
+ #include <rak/path.h>
+ #include <rak/socket_address.h>
+
+
+
+diff -Nurp rtorrent-0.8.4.old/src/display/utils.cc rtorrent-0.8.4/src/display/utils.cc
+--- rtorrent-0.8.4.old/src/display/utils.cc 2008-08-27 03:25:01.000000000 -0500
++++ rtorrent-0.8.4/src/display/utils.cc 2009-02-04 10:20:34.000000000 -0600
+@@ -36,6 +36,7 @@
+
+ #include "config.h"
+
++#include <cstdio>
+ #include <cstring>
+ #include <sstream>
+ #include <iomanip>
+
+
+diff -Nurp rtorrent-0.8.4.old/src/rpc/parse.cc rtorrent-0.8.4/src/rpc/parse.cc
+--- rtorrent-0.8.4.old/src/rpc/parse.cc 2008-08-26 15:14:33.000000000 -0500
++++ rtorrent-0.8.4/src/rpc/parse.cc 2009-02-04 10:23:06.000000000 -0600
+@@ -37,6 +37,7 @@
+ #include "config.h"
+
+ #include <cstring>
++#include <cstdio>
+ #include <locale>
+ #include <rak/path.h>
+ #include <torrent/exceptions.h>
+
+ diff -Nurp rtorrent-0.8.4.old/src/utils/lockfile.cc rtorrent-0.8.4/src/utils/lockfile.cc
+--- rtorrent-0.8.4.old/src/utils/lockfile.cc 2008-05-07 07:19:11.000000000 -0500
++++ rtorrent-0.8.4/src/utils/lockfile.cc 2009-02-04 10:25:10.000000000 -0600
+@@ -40,6 +40,7 @@
+ #include <cctype>
+ #include <cerrno>
+ #include <cstring>
++#include <cstdio>
+ #include <sstream>
+ #include <fcntl.h>
+ #include <signal.h>
+
+diff -Nurp rtorrent-0.8.4.old/src/command_download.cc rtorrent-0.8.4/src/command_download.cc
+--- rtorrent-0.8.4.old/src/command_download.cc 2008-11-19 11:01:20.000000000 -0600
++++ rtorrent-0.8.4/src/command_download.cc 2009-02-04 10:25:32.000000000 -0600
+@@ -36,6 +36,8 @@
+
+ #include "config.h"
+
++#include <cstdio>
++
+ #include <functional>
+ #include <unistd.h>
+ #include <rak/file_stat.h>
+
+
+diff -Nurp rtorrent-0.8.4.old/src/command_events.cc rtorrent-0.8.4/src/command_events.cc
+--- rtorrent-0.8.4.old/src/command_events.cc 2008-11-11 04:37:20.000000000 -0600
++++ rtorrent-0.8.4/src/command_events.cc 2009-02-04 10:25:58.000000000 -0600
+@@ -36,6 +36,8 @@
+
+ #include "config.h"
+
++#include <cstdio>
++
+ #include <functional>
+ #include <rak/file_stat.h>
+ #include <rak/path.h>
+
+diff -Nurp rtorrent-0.8.4.old/src/command_network.cc rtorrent-0.8.4/src/command_network.cc
+--- rtorrent-0.8.4.old/src/command_network.cc 2008-08-27 03:25:01.000000000 -0500
++++ rtorrent-0.8.4/src/command_network.cc 2009-02-04 10:26:22.000000000 -0600
+@@ -36,6 +36,8 @@
+
+ #include "config.h"
+
++#include <cstdio>
++
+ #include <functional>
+ #include <rak/address_info.h>
+ #include <rak/path.h>
diff --git a/net-p2p/rtorrent/rtorrent-0.8.4-r1.ebuild b/net-p2p/rtorrent/rtorrent-0.8.4-r1.ebuild
index f41b661ef323..25b54127afb1 100644
--- a/net-p2p/rtorrent/rtorrent-0.8.4-r1.ebuild
+++ b/net-p2p/rtorrent/rtorrent-0.8.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.8.4-r1.ebuild,v 1.5 2009/03/01 19:52:19 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.8.4-r1.ebuild,v 1.6 2009/03/04 14:39:44 loki_val Exp $
inherit base eutils toolchain-funcs flag-o-matic
@@ -23,7 +23,8 @@ RDEPEND="${COMMON_DEPEND}
DEPEND="${COMMON_DEPEND}
dev-util/pkgconfig"
-PATCHES=( "${FILESDIR}/${PN}-0.8.2-gcc34.patch" )
+PATCHES=( "${FILESDIR}/${PN}-0.8.2-gcc34.patch"
+ "${FILESDIR}/${PN}-0.8.4-gcc44.patch" )
src_compile() {
replace-flags -Os -O2