summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2011-02-08 23:37:59 +0000
committerVlastimil Babka <caster@gentoo.org>2011-02-08 23:37:59 +0000
commit9e6f996922bbe7b9377b069049aa0e3b2215183b (patch)
tree3ddbbab66b7e7cc7b2b225250d54910fe88b3970 /net-p2p/vuze
parentRun tests in a way recommended by upstream. (diff)
downloadgentoo-2-9e6f996922bbe7b9377b069049aa0e3b2215183b.tar.gz
gentoo-2-9e6f996922bbe7b9377b069049aa0e3b2215183b.tar.bz2
gentoo-2-9e6f996922bbe7b9377b069049aa0e3b2215183b.zip
Version bump.
(Portage version: 2.2.0_alpha21/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p/vuze')
-rw-r--r--net-p2p/vuze/ChangeLog9
-rw-r--r--net-p2p/vuze/vuze-4.1.0.4-r1.ebuild143
-rw-r--r--net-p2p/vuze/vuze-4.2.0.2-r1.ebuild144
-rw-r--r--net-p2p/vuze/vuze-4.4.0.6.ebuild132
-rw-r--r--net-p2p/vuze/vuze-4.6.0.2.ebuild (renamed from net-p2p/vuze/vuze-4.5.0.4.ebuild)14
5 files changed, 19 insertions, 423 deletions
diff --git a/net-p2p/vuze/ChangeLog b/net-p2p/vuze/ChangeLog
index bdb7ad502705..cc11ca46a831 100644
--- a/net-p2p/vuze/ChangeLog
+++ b/net-p2p/vuze/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-p2p/vuze
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/vuze/ChangeLog,v 1.45 2011/01/24 19:51:54 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/vuze/ChangeLog,v 1.46 2011/02/08 23:37:59 caster Exp $
+
+*vuze-4.6.0.2 (08 Feb 2011)
+
+ 08 Feb 2011; Vlastimil Babka <caster@gentoo.org> -vuze-4.1.0.4-r1.ebuild,
+ -vuze-4.2.0.2-r1.ebuild, -vuze-4.4.0.6.ebuild, -vuze-4.5.0.4.ebuild,
+ +vuze-4.6.0.2.ebuild:
+ Version bump.
24 Jan 2011; Kacper Kowalik <xarthisius@gentoo.org>
vuze-4.3.1.4-r2.ebuild:
diff --git a/net-p2p/vuze/vuze-4.1.0.4-r1.ebuild b/net-p2p/vuze/vuze-4.1.0.4-r1.ebuild
deleted file mode 100644
index e35dbc8f771a..000000000000
--- a/net-p2p/vuze/vuze-4.1.0.4-r1.ebuild
+++ /dev/null
@@ -1,143 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/vuze/vuze-4.1.0.4-r1.ebuild,v 1.1 2010/03/28 21:44:24 caster Exp $
-
-EAPI=2
-
-JAVA_PKG_IUSE="source"
-
-inherit eutils fdo-mime java-pkg-2 java-ant-2
-
-PATCHSET_VER="4.1.0.0"
-
-DESCRIPTION="BitTorrent client in Java, formerly called Azureus"
-HOMEPAGE="http://www.vuze.com/"
-SRC_URI="mirror://sourceforge/azureus/Vuze_${PV}_source.zip
- mirror://gentoo/${PN}-${PATCHSET_VER}-gentoo-patches.tar.bz2"
-LICENSE="GPL-2 BSD"
-
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 x86"
-IUSE=""
-
-# bundles parts of commons-lang, but modified
-# bundles parts of http://www.programmers-friend.org/
-RDEPEND="
- dev-java/json-simple:0
- dev-java/bcprov:1.3
- >=dev-java/commons-cli-1.0:1
- >=dev-java/log4j-1.2.8:0
- >=dev-java/swt-3.4:3.4[cairo,xulrunner]
- !net-p2p/azureus-bin
- >=virtual/jre-1.5"
-
-DEPEND="${RDEPEND}
- app-arch/unzip
- dev-util/desktop-file-utils
- >=virtual/jdk-1.5"
-
-PDEPEND="~net-p2p/vuze-coreplugins-${PV}"
-
-src_unpack() {
- mkdir "${S}" && cd "${S}" || die
- unpack ${A}
-
- # build.xml disappeared from 4.1.0.0 although it was there in 4.0.0.4
- # hopefully that's just a packaging mistake
- [[ -f build.xml ]] && die "upstream has build.xml again, don't overwrite"
- cp "${FILESDIR}/build.xml" . || die "failed to copy build.xml"
-
- EPATCH_FORCE="yes" EPATCH_SUFFIX="patch" epatch "${S}/${PN}-${PATCHSET_VER}-gentoo-patches/"
-
- ### Removes OS X files and entries.
- rm -rv "org/gudy/azureus2/platform/macosx" \
- "org/gudy/azureus2/ui/swt/osx" || die
-
- ### Removes Windows files.
- rm -v ./org/gudy/azureus2/ui/swt/win32/Win32UIEnhancer.java || die
-
- ### Removes test files.
- rm -rv "org/gudy/azureus2/ui/swt/test" \
- org/gudy/azureus2/ui/console/multiuser/TestUserManager.java || die
-
- ### Removes bouncycastle (we use our own bcprov).
- rm -rv "org/bouncycastle" || die
-
- ### Removes bundled json
- rm -rv "org/json" || die
-
- mkdir -p build/libs || die
-}
-
-JAVA_ANT_REWRITE_CLASSPATH="true"
-EANT_GENTOO_CLASSPATH="swt-3.4,bcprov-1.3,json-simple,log4j,commons-cli-1"
-
-src_compile() {
- local mem
- use amd64 && mem="256"
- use x86 && mem="192"
- use ppc && mem="192"
- use ppc64 && mem="256"
- export ANT_OPTS="-Xmx${mem}m"
- java-pkg-2_src_compile
-}
-
-src_install() {
- java-pkg_dojar dist/*.jar || die "dojar failed"
- dodoc ChangeLog.txt || die
-
- java-pkg_dolauncher "${PN}" \
- --main org.gudy.azureus2.ui.common.Main -pre "${FILESDIR}/${PN}-4.1.0.0-pre" \
- --java_args '-Dazureus.install.path=/usr/share/vuze/ ${JAVA_OPTIONS}' \
- --pkg_args '--ui=${UI}'
- dosym vuze /usr/bin/azureus
-
- # https://bugs.gentoo.org/show_bug.cgi?id=204132
- java-pkg_register-environment-variable MOZ_PLUGIN_PATH /usr/lib/nsbrowser/plugins
-
- newicon "${S}"/org/gudy/azureus2/ui/icons/a32.png vuze.png
- domenu "${FILESDIR}/${PN}.desktop"
-
- use source && java-pkg_dosrc "${S}"/{com,edu,org}
-}
-
-pkg_postinst() {
- ###
- ### @Todo We should probably deactivate auto-update it by default,
- ### or even remove the option - bug #218959
- ###
- ewarn "Running Vuze as root is not supported and may result in untracked"
- ewarn "updates to shared components and then collisions on updates via portage"
-
- elog "Vuze has been formerly called Azureus and many references to the old name remain."
- elog
- elog "Since version 4.1.0.0, plugins that are normally bundled by upstream"
- elog "(and auto-installed in each user's ~/.azureus if not bundled)"
- elog "are now installed into shared plugin directory by the vuze-coreplugins ebuild."
- elog
- elog "Vuze may warn that shared plugin dir is not writable, that's fine."
- elog "It may also attempt to update some these plugins and fail to write."
- elog "In that case look for or fill a bump bug in bugs.gentoo.org"
- elog
- elog "We plan to disable updater for shared components and plugins."
- elog "See progress in bug #218959, patches welcome."
- elog
- elog "After running Vuze for the first time, configuration"
- elog "options will be placed in '~/.azureus/gentoo.config'."
- elog "If you need to change some startup options, you should"
- elog "modify this file, rather than the startup script."
- elog "Using this config file you can start the console UI."
- elog
- elog "To switch from classic UI to Vuze use"
- elog "1: Tools > Options > Interface > Start > Display Vuze UI Chooser"
- elog "2: Toolbar (right-hand side)"
- elog
- elog "If you have problems starting Vuze, try starting it"
- elog "from the command line to look at debugging output."
-
- fdo-mime_desktop_database_update
-}
-
-pkg_postrm() {
- fdo-mime_desktop_database_update
-}
diff --git a/net-p2p/vuze/vuze-4.2.0.2-r1.ebuild b/net-p2p/vuze/vuze-4.2.0.2-r1.ebuild
deleted file mode 100644
index 4c33d2755cba..000000000000
--- a/net-p2p/vuze/vuze-4.2.0.2-r1.ebuild
+++ /dev/null
@@ -1,144 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/vuze/vuze-4.2.0.2-r1.ebuild,v 1.3 2010/03/28 21:44:24 caster Exp $
-
-EAPI=2
-
-JAVA_PKG_IUSE="source"
-
-inherit eutils fdo-mime java-pkg-2 java-ant-2
-
-PATCHSET_VER="4.2.0.0"
-
-DESCRIPTION="BitTorrent client in Java, formerly called Azureus"
-HOMEPAGE="http://www.vuze.com/"
-SRC_URI="mirror://sourceforge/azureus/Vuze_${PV}_source.zip
- mirror://gentoo/${PN}-${PATCHSET_VER}-gentoo-patches.tar.bz2"
-LICENSE="GPL-2 BSD"
-
-SLOT="0"
-KEYWORDS="amd64 ~ppc ppc64 x86"
-IUSE=""
-
-# bundles parts of commons-lang, but modified
-# bundles parts of http://www.programmers-friend.org/
-RDEPEND="
- dev-java/json-simple:0
- dev-java/bcprov:1.3
- >=dev-java/commons-cli-1.0:1
- >=dev-java/log4j-1.2.8:0
- >=dev-java/swt-3.4:3.4[cairo,xulrunner]
- !net-p2p/azureus-bin
- >=virtual/jre-1.5"
-
-DEPEND="${RDEPEND}
- app-arch/unzip
- dev-util/desktop-file-utils
- >=virtual/jdk-1.5"
-
-PDEPEND="~net-p2p/vuze-coreplugins-${PV}"
-
-src_unpack() {
- mkdir "${S}" && cd "${S}" || die
- unpack ${A}
-
- # build.xml disappeared from 4.1.0.0 although it was there in 4.0.0.4
- # hopefully that's just a packaging mistake
- [[ -f build.xml ]] && die "upstream has build.xml again, don't overwrite"
- cp "${FILESDIR}/build.xml" . || die "failed to copy build.xml"
-
- epatch "${S}/${PN}-${PATCHSET_VER}-gentoo-patches/0001-remove-osx-platform.patch"
- epatch "${S}/${PN}-${PATCHSET_VER}-gentoo-patches/0002-use-jdk-cipher-only.patch"
-
- ### Removes OS X files and entries.
- rm -rv "org/gudy/azureus2/platform/macosx" \
- "org/gudy/azureus2/ui/swt/osx" || die
-
- ### Removes Windows files.
- rm -v ./org/gudy/azureus2/ui/swt/win32/Win32UIEnhancer.java || die
-
- ### Removes test files.
- rm -rv "org/gudy/azureus2/ui/swt/test" \
- org/gudy/azureus2/ui/console/multiuser/TestUserManager.java || die
-
- ### Removes bouncycastle (we use our own bcprov).
- rm -rv "org/bouncycastle" || die
-
- ### Removes bundled json
- rm -rv "org/json" || die
-
- mkdir -p build/libs || die
-}
-
-JAVA_ANT_REWRITE_CLASSPATH="true"
-EANT_GENTOO_CLASSPATH="swt-3.4,bcprov-1.3,json-simple,log4j,commons-cli-1"
-
-src_compile() {
- local mem
- use amd64 && mem="256"
- use x86 && mem="192"
- use ppc && mem="192"
- use ppc64 && mem="256"
- export ANT_OPTS="-Xmx${mem}m"
- java-pkg-2_src_compile
-}
-
-src_install() {
- java-pkg_dojar dist/*.jar || die "dojar failed"
- dodoc ChangeLog.txt || die
-
- java-pkg_dolauncher "${PN}" \
- --main org.gudy.azureus2.ui.common.Main -pre "${FILESDIR}/${PN}-4.1.0.0-pre" \
- --java_args '-Dazureus.install.path=/usr/share/vuze/ ${JAVA_OPTIONS}' \
- --pkg_args '--ui=${UI}'
- dosym vuze /usr/bin/azureus
-
- # https://bugs.gentoo.org/show_bug.cgi?id=204132
- java-pkg_register-environment-variable MOZ_PLUGIN_PATH /usr/lib/nsbrowser/plugins
-
- newicon "${S}"/org/gudy/azureus2/ui/icons/a32.png vuze.png
- domenu "${FILESDIR}/${PN}.desktop"
-
- use source && java-pkg_dosrc "${S}"/{com,edu,org}
-}
-
-pkg_postinst() {
- ###
- ### @Todo We should probably deactivate auto-update it by default,
- ### or even remove the option - bug #218959
- ###
- ewarn "Running Vuze as root is not supported and may result in untracked"
- ewarn "updates to shared components and then collisions on updates via portage"
-
- elog "Vuze has been formerly called Azureus and many references to the old name remain."
- elog
- elog "Since version 4.1.0.0, plugins that are normally bundled by upstream"
- elog "(and auto-installed in each user's ~/.azureus if not bundled)"
- elog "are now installed into shared plugin directory by the vuze-coreplugins ebuild."
- elog
- elog "Vuze may warn that shared plugin dir is not writable, that's fine."
- elog "It may also attempt to update some these plugins and fail to write."
- elog "In that case look for or fill a bump bug in bugs.gentoo.org"
- elog
- elog "We plan to disable updater for shared components and plugins."
- elog "See progress in bug #218959, patches welcome."
- elog
- elog "After running Vuze for the first time, configuration"
- elog "options will be placed in '~/.azureus/gentoo.config'."
- elog "If you need to change some startup options, you should"
- elog "modify this file, rather than the startup script."
- elog "Using this config file you can start the console UI."
- elog
- elog "To switch from classic UI to Vuze use"
- elog "1: Tools > Options > Interface > Start > Display Vuze UI Chooser"
- elog "2: Toolbar (right-hand side)"
- elog
- elog "If you have problems starting Vuze, try starting it"
- elog "from the command line to look at debugging output."
-
- fdo-mime_desktop_database_update
-}
-
-pkg_postrm() {
- fdo-mime_desktop_database_update
-}
diff --git a/net-p2p/vuze/vuze-4.4.0.6.ebuild b/net-p2p/vuze/vuze-4.4.0.6.ebuild
deleted file mode 100644
index 5d3b1233e9cb..000000000000
--- a/net-p2p/vuze/vuze-4.4.0.6.ebuild
+++ /dev/null
@@ -1,132 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/vuze/vuze-4.4.0.6.ebuild,v 1.2 2010/09/10 15:28:54 caster Exp $
-
-EAPI=2
-
-JAVA_PKG_IUSE="source"
-
-inherit eutils fdo-mime java-pkg-2 java-ant-2 versionator
-
-MY_PV=$(replace_all_version_separators "")
-
-PATCHSET_VER="4.4.0.0"
-PATCHSET_DIR="${PN}-${PATCHSET_VER}-gentoo-patches"
-PATCHSET="${PATCHSET_DIR}.tar.bz2"
-SRC_TARBALL="Vuze_${MY_PV}_source.zip"
-
-DESCRIPTION="BitTorrent client in Java, formerly called Azureus"
-HOMEPAGE="http://www.vuze.com/"
-SRC_URI="mirror://sourceforge/azureus/${PN}/Vuze_${MY_PV}/${SRC_TARBALL}
- mirror://gentoo/${PATCHSET}"
-LICENSE="GPL-2 BSD"
-
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE=""
-
-# bundles parts of commons-lang, but modified
-# bundles parts of http://www.programmers-friend.org/
-RDEPEND="
- dev-java/json-simple:0
- dev-java/bcprov:1.3
- >=dev-java/commons-cli-1.0:1
- >=dev-java/log4j-1.2.8:0
- dev-java/swt:3.5[cairo,xulrunner]
- !net-p2p/azureus-bin
- >=virtual/jre-1.5"
-
-DEPEND="${RDEPEND}
- app-arch/unzip
- dev-util/desktop-file-utils
- >=virtual/jdk-1.5"
-
-PDEPEND="~net-p2p/vuze-coreplugins-${PV}"
-
-src_unpack() {
- unpack ${PATCHSET}
- mkdir "${S}" && cd "${S}" || die
- unpack ${SRC_TARBALL}
-}
-
-java_prepare() {
- # build.xml disappeared from 4.4.0.0 although it was there in 4.3.1.4
- # hopefully that's just a packaging mistake
- [[ -f build.xml ]] && die "upstream has build.xml again, don't overwrite"
- cp "${FILESDIR}/build.xml" . || die "failed to copy build.xml"
-
- EPATCH_FORCE="yes" EPATCH_SUFFIX="patch" epatch "${WORKDIR}/${PATCHSET_DIR}/"
-
- ### Removes OS X files and entries.
- rm -rv "org/gudy/azureus2/platform/macosx" \
- "org/gudy/azureus2/ui/swt/osx" || die
-
- ### Removes Windows files.
- rm -v ./org/gudy/azureus2/ui/swt/win32/Win32UIEnhancer.java || die
-
- ### Removes test files.
- rm -rv org/gudy/azureus2/ui/console/multiuser/TestUserManager.java || die
-
- ### Removes bouncycastle (we use our own bcprov).
- rm -rv "org/bouncycastle" || die
-
- ### Removes bundled json
- rm -rv "org/json" || die
-
- mkdir -p build/libs || die
-}
-
-JAVA_ANT_REWRITE_CLASSPATH="true"
-EANT_GENTOO_CLASSPATH="swt-3.5,bcprov-1.3,json-simple,log4j,commons-cli-1"
-
-src_compile() {
- local mem
- use amd64 && mem="320"
- use x86 && mem="192"
- use ppc && mem="192"
- use ppc64 && mem="256"
- export ANT_OPTS="-Xmx${mem}m"
- java-pkg-2_src_compile
-
- # bug #302058 - build.xml excludes .txt but upstream jar has it...
- jar uf dist/Azureus2.jar ChangeLog.txt || die
-}
-
-src_install() {
- java-pkg_dojar dist/Azureus2.jar
- dodoc ChangeLog.txt || die
-
- java-pkg_dolauncher "${PN}" \
- --main org.gudy.azureus2.ui.common.Main -pre "${FILESDIR}/${PN}-4.1.0.0-pre" \
- --java_args '-Dazureus.install.path=/usr/share/vuze/ ${JAVA_OPTIONS}' \
- --pkg_args '--ui=${UI}'
- dosym vuze /usr/bin/azureus
-
- # https://bugs.gentoo.org/show_bug.cgi?id=204132
- java-pkg_register-environment-variable MOZ_PLUGIN_PATH /usr/lib/nsbrowser/plugins
-
- newicon "${S}"/org/gudy/azureus2/ui/icons/a32.png vuze.png
- domenu "${FILESDIR}/${PN}.desktop"
-
- use source && java-pkg_dosrc "${S}"/{com,edu,org}
-}
-
-pkg_postinst() {
- ewarn "Running Vuze as root is not supported and may result in untracked"
- ewarn "updates to shared components and then collisions on updates via ebuilds"
-
- elog "Vuze has been formerly called Azureus and many references to the old name remain."
- elog
- elog "After running Vuze for the first time, configuration"
- elog "options will be placed in '~/.azureus/gentoo.config'."
- elog "If you need to change some startup options, you should"
- elog "modify this file, rather than the startup script."
- elog "Using this config file you can start the console UI."
- elog
-
- fdo-mime_desktop_database_update
-}
-
-pkg_postrm() {
- fdo-mime_desktop_database_update
-}
diff --git a/net-p2p/vuze/vuze-4.5.0.4.ebuild b/net-p2p/vuze/vuze-4.6.0.2.ebuild
index b7cf5e5ae6ca..f308d29b4a71 100644
--- a/net-p2p/vuze/vuze-4.5.0.4.ebuild
+++ b/net-p2p/vuze/vuze-4.6.0.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/vuze/vuze-4.5.0.4.ebuild,v 1.2 2010/09/10 15:28:54 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/vuze/vuze-4.6.0.2.ebuild,v 1.1 2011/02/08 23:37:59 caster Exp $
EAPI=2
@@ -32,7 +32,7 @@ RDEPEND="
dev-java/bcprov:1.3
>=dev-java/commons-cli-1.0:1
>=dev-java/log4j-1.2.8:0
- dev-java/swt:3.6[cairo,xulrunner]
+ dev-java/swt:3.6[cairo]
!net-p2p/azureus-bin
>=virtual/jre-1.5"
@@ -47,6 +47,8 @@ src_unpack() {
unpack ${PATCHSET}
mkdir "${S}" && cd "${S}" || die
unpack ${SRC_TARBALL}
+ # this is no longer needed
+ rm "${WORKDIR}/${PATCHSET_DIR}/0006-Remove-the-use-of-windows-only-Tree2-widget.patch" || die
}
java_prepare() {
@@ -128,6 +130,12 @@ pkg_postinst() {
elog "Using this config file you can start the console UI."
elog
+ if ! has_version dev-java/swt:3.6[xulrunner]; then
+ elog
+ elog "Your dev-java/swt:3.6 was built without xulrunner support. Features such as Vuze HD Network will not work."
+ elog "Rebuild swt with USE=xulrunner (needs xulrunner-1.9) to use these features."
+ fi
+
fdo-mime_desktop_database_update
}