summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-02-23 21:36:41 +0000
committerAnthony G. Basile <blueness@gentoo.org>2015-02-23 21:36:41 +0000
commit09f709144179f7891689ac59e943bb368bedad0d (patch)
tree3ca3964b6c7084438afaad91361e2cb7ad460637 /net-p2p
parentVersion bumps using bitcoincore.eclass (diff)
downloadgentoo-2-09f709144179f7891689ac59e943bb368bedad0d.tar.gz
gentoo-2-09f709144179f7891689ac59e943bb368bedad0d.tar.bz2
gentoo-2-09f709144179f7891689ac59e943bb368bedad0d.zip
Version bumps using bitcoincore.eclass
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitcoin-cli/ChangeLog10
-rw-r--r--net-p2p/bitcoin-cli/bitcoin-cli-0.10.0.ebuild29
-rw-r--r--net-p2p/bitcoin-cli/bitcoin-cli-9999.ebuild47
3 files changed, 49 insertions, 37 deletions
diff --git a/net-p2p/bitcoin-cli/ChangeLog b/net-p2p/bitcoin-cli/ChangeLog
index 32c7b90ad770..0b1bd7ab5e95 100644
--- a/net-p2p/bitcoin-cli/ChangeLog
+++ b/net-p2p/bitcoin-cli/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/bitcoin-cli
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoin-cli/ChangeLog,v 1.4 2014/11/21 23:31:20 blueness Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoin-cli/ChangeLog,v 1.5 2015/02/23 21:36:41 blueness Exp $
+
+*bitcoin-cli-0.10.0 (23 Feb 2015)
+
+ 23 Feb 2015; Anthony G. Basile <blueness@gentoo.org>
+ +bitcoin-cli-0.10.0.ebuild, bitcoin-cli-9999.ebuild:
+ Version bumps using bitcoincore.eclass
21 Nov 2014; Anthony G. Basile <blueness@gentoo.org> bitcoin-cli-9999.ebuild:
Update 9999
diff --git a/net-p2p/bitcoin-cli/bitcoin-cli-0.10.0.ebuild b/net-p2p/bitcoin-cli/bitcoin-cli-0.10.0.ebuild
new file mode 100644
index 000000000000..980f3902e676
--- /dev/null
+++ b/net-p2p/bitcoin-cli/bitcoin-cli-0.10.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2010-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoin-cli/bitcoin-cli-0.10.0.ebuild,v 1.1 2015/02/23 21:36:41 blueness Exp $
+
+EAPI=5
+
+BITCOINCORE_COMMITHASH="047a89831760ff124740fe9f58411d57ee087078"
+BITCOINCORE_LJR_DATE="20150220"
+BITCOINCORE_IUSE=""
+inherit bitcoincore
+
+DESCRIPTION="Command-line JSON-RPC client specifically designed for talking to Bitcoin Core Daemon"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="
+ virtual/bitcoin-leveldb
+"
+
+src_prepare() {
+ bitcoincore_prepare
+ bitcoincore_autoreconf
+}
+
+src_configure() {
+ bitcoincore_conf \
+ --enable-util-cli
+}
diff --git a/net-p2p/bitcoin-cli/bitcoin-cli-9999.ebuild b/net-p2p/bitcoin-cli/bitcoin-cli-9999.ebuild
index abf304dcbacc..a91faebea936 100644
--- a/net-p2p/bitcoin-cli/bitcoin-cli-9999.ebuild
+++ b/net-p2p/bitcoin-cli/bitcoin-cli-9999.ebuild
@@ -1,52 +1,29 @@
-# Copyright 2010-2014 Gentoo Foundation
+# Copyright 2010-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoin-cli/bitcoin-cli-9999.ebuild,v 1.2 2014/11/21 23:31:20 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoin-cli/bitcoin-cli-9999.ebuild,v 1.3 2015/02/23 21:36:41 blueness Exp $
-EAPI=4
+EAPI=5
-inherit autotools eutils git-2
-
-MyPV="${PV/_/}"
-MyPN="bitcoin"
-MyP="${MyPN}-${MyPV}"
+BITCOINCORE_NO_SYSLIBS=1
+BITCOINCORE_IUSE=""
+inherit bitcoincore
DESCRIPTION="Command-line JSON-RPC client specifically designed for talking to Bitcoin Core Daemon"
-HOMEPAGE="http://bitcoin.org/"
-SRC_URI="
-"
-EGIT_PROJECT='bitcoin'
-EGIT_REPO_URI="git://github.com/bitcoin/bitcoin.git https://github.com/bitcoin/bitcoin.git"
-
-LICENSE="MIT ISC"
+LICENSE="MIT"
SLOT="0"
KEYWORDS=""
-IUSE=""
RDEPEND="
- >=dev-libs/boost-1.52.0[threads(+)]
- dev-libs/openssl:0[-bindist]
+ virtual/bitcoin-leveldb
"
-DEPEND="${RDEPEND}"
src_prepare() {
+ bitcoincore_prepare
sed -i 's/bitcoin-tx//' src/Makefile.am
- eautoreconf
+ bitcoincore_autoreconf
}
src_configure() {
- econf \
- --disable-ccache \
- --without-miniupnpc \
- --disable-tests \
- --disable-wallet \
- --without-daemon \
- --without-libs \
- --without-gui
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- dodoc doc/README.md doc/release-notes.md
- dodoc doc/assets-attribution.md doc/tor.md
+ bitcoincore_conf \
+ --with-utils
}