summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Thomson <wltjr@gentoo.org>2006-12-24 02:38:41 +0000
committerWilliam Thomson <wltjr@gentoo.org>2006-12-24 02:38:41 +0000
commit1aaf5f50ed4dbaa5cd5155bf06391b4fa6553431 (patch)
treedb17f45fb138874697de3dab47f091a7b8517e72 /net-p2p
parentversion bump with bug fixes (diff)
downloadgentoo-2-1aaf5f50ed4dbaa5cd5155bf06391b4fa6553431.tar.gz
gentoo-2-1aaf5f50ed4dbaa5cd5155bf06391b4fa6553431.tar.bz2
gentoo-2-1aaf5f50ed4dbaa5cd5155bf06391b4fa6553431.zip
Bumped package to latest version. Binary package that uses bundled jars. Should use system installed/compiled jars. Ideally compile limewire from source, since it's open source :). Ebuild and package need some luv.
(Portage version: 2.1.2_rc3-r6)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/limewire/ChangeLog10
-rw-r--r--net-p2p/limewire/files/digest-limewire-4.12.63
-rw-r--r--net-p2p/limewire/limewire-4.12.6.ebuild49
-rw-r--r--net-p2p/limewire/metadata.xml14
4 files changed, 74 insertions, 2 deletions
diff --git a/net-p2p/limewire/ChangeLog b/net-p2p/limewire/ChangeLog
index 6b3d48365d38..d969abb96eb1 100644
--- a/net-p2p/limewire/ChangeLog
+++ b/net-p2p/limewire/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-p2p/limewire
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/limewire/ChangeLog,v 1.23 2006/11/01 20:06:19 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/limewire/ChangeLog,v 1.24 2006/12/24 02:38:41 wltjr Exp $
+
+*limewire-4.12.6 (24 Dec 2006)
+
+ 24 Dec 2006; William L. Thomson Jr. <wltjr@gentoo.org> metadata.xml,
+ +limewire-4.12.6.ebuild:
+ Bumped package to latest version. Binary package that uses bundled jars.
+ Should use system installed/compiled jars. Ideally compile limewire from
+ source, since it's open source :). Ebuild and package need some luv.
01 Nov 2006; Chris Gianelloni <wolf31o2@gentoo.org>
-files/limewire.desktop, -limewire-4.0.8.ebuild, -limewire-4.2.3.ebuild,
diff --git a/net-p2p/limewire/files/digest-limewire-4.12.6 b/net-p2p/limewire/files/digest-limewire-4.12.6
new file mode 100644
index 000000000000..1e2bb26aa15c
--- /dev/null
+++ b/net-p2p/limewire/files/digest-limewire-4.12.6
@@ -0,0 +1,3 @@
+MD5 4b2c2f228205f6277170bacfb152305d LimeWireOther.zip 6665140
+RMD160 d6acbd13a08b4170d3c88b7f3c864d51516427d1 LimeWireOther.zip 6665140
+SHA256 e72fb5aca3edd580d28772b3985196e2d6dcb5b4b833c90d09c9d7adf69c1237 LimeWireOther.zip 6665140
diff --git a/net-p2p/limewire/limewire-4.12.6.ebuild b/net-p2p/limewire/limewire-4.12.6.ebuild
new file mode 100644
index 000000000000..ef557ec3b720
--- /dev/null
+++ b/net-p2p/limewire/limewire-4.12.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/limewire/limewire-4.12.6.ebuild,v 1.1 2006/12/24 02:38:41 wltjr Exp $
+
+inherit eutils
+
+IUSE="gtk"
+DESCRIPTION="Limewire Java Gnutella client"
+HOMEPAGE="http://www.limewire.com"
+SRC_URI="http://maverick.limewire.com/download/LimeWireOther.zip"
+LICENSE="GPL-2 Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+DEPEND="app-arch/unzip
+ gtk? ( >=x11-libs/gtk+-2.4 )"
+
+RDEPEND="virtual/jre"
+
+S="${WORKDIR}/LimeWire"
+PREFIX="/opt/limewire"
+
+src_compile() {
+ ( echo \#!/bin/sh
+ echo cd ${PREFIX}
+ echo export J2SE_PREEMPTCLOSE=1
+ echo java -cp .:collections.jar:xerces.jar:jl011.jar:MessagesBundles.jar:themes.jar:logicrypto.jar:GURL.jar:LimeWire.jar com.limegroup.gnutella.gui.Main
+ ) >limewire.gentoo
+
+ echo PATH=${PREFIX} > limewire.envd
+}
+
+src_install() {
+ insinto ${PREFIX}
+ doins *.jar *.war *.properties *.ver *.sh hashes *.txt
+ exeinto /usr/bin
+ newexe limewire.gentoo limewire
+
+ newenvd limewire.envd 99limewire
+
+ insinto /usr/share/icons/hicolor/32x32/apps
+ newins "${FILESDIR}"/main-icon.png limewire.png
+
+ make_desktop_entry limewire LimeWire
+}
+
+pkg_postinst() {
+ use gtk || ewarn "You will probably not be able to use the gtk frontend."
+ einfo " Finished installing LimeWire into ${PREFIX}"
+}
diff --git a/net-p2p/limewire/metadata.xml b/net-p2p/limewire/metadata.xml
index aa0f3664825f..4d8b748cd751 100644
--- a/net-p2p/limewire/metadata.xml
+++ b/net-p2p/limewire/metadata.xml
@@ -1,5 +1,17 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>net-p2p</herd>
+
+ <herd>net-p2p</herd>
+
+ <longdescription>
+ LimeWire is a file sharing program running on the Gnutella Network.
+ It is open standard software running on an open protocol, free for
+ the public to use. LimeWire allows you to share any file such as
+ .mp3s, .avis, .jpgs, .tiffs, etc. Limewire is written in Java, and
+ will run on Windows, Macintosh, Linux, Sun, and other computing
+ platforms. Publish your original content to the world without
+ setting up a website!
+ </longdescription>
+
</pkgmetadata>