summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-07-16 13:06:15 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-07-16 13:06:15 +0000
commit22306b6a72e0eb14818b59ad7b3010e2b3ea5511 (patch)
tree426582ab4763031fe862bfeb4f036e856d5a2ddb /net-p2p
parentAdd gnome-base/gnome-mount dependency wrt bug #328567 (diff)
downloadgentoo-2-22306b6a72e0eb14818b59ad7b3010e2b3ea5511.tar.gz
gentoo-2-22306b6a72e0eb14818b59ad7b3010e2b3ea5511.tar.bz2
gentoo-2-22306b6a72e0eb14818b59ad7b3010e2b3ea5511.zip
Remove old ebuilds and patches
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/ChangeLog10
-rw-r--r--net-p2p/qbittorrent/files/moc_bug_workaround.patch24
-rw-r--r--net-p2p/qbittorrent/files/moc_bug_workaround2.patch51
-rw-r--r--net-p2p/qbittorrent/files/nox-webui-fix.patch94
-rw-r--r--net-p2p/qbittorrent/qbittorrent-2.2.2.ebuild60
-rw-r--r--net-p2p/qbittorrent/qbittorrent-2.2.5.ebuild57
-rw-r--r--net-p2p/qbittorrent/qbittorrent-2.2.6.ebuild57
-rw-r--r--net-p2p/qbittorrent/qbittorrent-2.2.7.ebuild57
-rw-r--r--net-p2p/qbittorrent/qbittorrent-2.2.9-r1.ebuild66
-rw-r--r--net-p2p/qbittorrent/qbittorrent-2.3.0_rc1.ebuild63
10 files changed, 9 insertions, 530 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index cbedec815da8..329e90971279 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.97 2010/07/16 09:58:15 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.98 2010/07/16 13:06:14 hwoarang Exp $
+
+ 16 Jul 2010; Markos Chandras <hwoarang@gentoo.org>
+ -qbittorrent-2.2.2.ebuild, -qbittorrent-2.2.5.ebuild,
+ -qbittorrent-2.2.6.ebuild, -qbittorrent-2.2.7.ebuild,
+ -qbittorrent-2.2.9-r1.ebuild, -qbittorrent-2.3.0_rc1.ebuild,
+ -files/moc_bug_workaround.patch, -files/moc_bug_workaround2.patch,
+ -files/nox-webui-fix.patch:
+ Remove old ebuilds and patches
16 Jul 2010; Christian Faulhammer <fauli@gentoo.org>
qbittorrent-2.2.8.ebuild:
diff --git a/net-p2p/qbittorrent/files/moc_bug_workaround.patch b/net-p2p/qbittorrent/files/moc_bug_workaround.patch
deleted file mode 100644
index f01eadb5eaac..000000000000
--- a/net-p2p/qbittorrent/files/moc_bug_workaround.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Index: src/bittorrent.h
-===================================================================
---- src/bittorrent.h (revision 4095)
-+++ src/bittorrent.h (working copy)
-@@ -118,6 +118,9 @@
- bool useTemporaryFolder() const;
- QString getDefaultSavePath() const;
- ScanFoldersModel* getScanFoldersModel() const;
-+#if LIBTORRENT_VERSION_MINOR < 15
-+ void saveDHTEntry();
-+#endif
-
- public slots:
- QTorrentHandle addTorrent(QString path, bool fromScanDir = false, QString from_url = QString(), bool resumed = false);
-@@ -136,9 +139,6 @@
- void resumeTorrent(QString hash);
- void resumeAllTorrents();
- /* End Web UI */
--#if LIBTORRENT_VERSION_MINOR < 15
-- void saveDHTEntry();
--#endif
- void preAllocateAllFiles(bool b);
- void saveFastResumeData();
- void enableIPFilter(QString filter);
diff --git a/net-p2p/qbittorrent/files/moc_bug_workaround2.patch b/net-p2p/qbittorrent/files/moc_bug_workaround2.patch
deleted file mode 100644
index 0aa866d61aec..000000000000
--- a/net-p2p/qbittorrent/files/moc_bug_workaround2.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-Index: src/trackerlist.h
-===================================================================
---- src/trackerlist.h (revision 4105)
-+++ src/trackerlist.h (working copy)
-@@ -61,10 +61,8 @@
- public slots:
- void setRowColor(int row, QColor color);
-
--#if LIBTORRENT_VERSION_MINOR < 15
- void moveSelectionUp();
- void moveSelectionDown();
--#endif
-
- void clear();
- void loadStickyItems(const QTorrentHandle &h);
-Index: src/trackerlist.cpp
-===================================================================
---- src/trackerlist.cpp (revision 4105)
-+++ src/trackerlist.cpp (working copy)
-@@ -94,8 +94,8 @@
- }
- }
-
-+void TrackerList::moveSelectionUp() {
- #if LIBTORRENT_VERSION_MINOR < 15
--void TrackerList::moveSelectionUp() {
- QTorrentHandle h = properties->getCurrentTorrent();
- if(!h.is_valid()) {
- clear();
-@@ -129,9 +129,11 @@
- h.replace_trackers(trackers);
- // Reannounce
- h.force_reannounce();
-+#endif
- }
-
- void TrackerList::moveSelectionDown() {
-+#if LIBTORRENT_VERSION_MINOR < 15
- QTorrentHandle h = properties->getCurrentTorrent();
- if(!h.is_valid()) {
- clear();
-@@ -165,8 +167,8 @@
- h.replace_trackers(trackers);
- // Reannounce
- h.force_reannounce();
-+#endif
- }
--#endif
-
- void TrackerList::clear() {
- qDeleteAll(tracker_items.values());
diff --git a/net-p2p/qbittorrent/files/nox-webui-fix.patch b/net-p2p/qbittorrent/files/nox-webui-fix.patch
deleted file mode 100644
index b4b676665bdc..000000000000
--- a/net-p2p/qbittorrent/files/nox-webui-fix.patch
+++ /dev/null
@@ -1,94 +0,0 @@
-Index: src/httpconnection.cpp
-===================================================================
---- src/httpconnection.cpp (revision 4101)
-+++ src/httpconnection.cpp (working copy)
-@@ -237,6 +237,7 @@
- QFile file(url);
- if(!file.open(QIODevice::ReadOnly))
- {
-+ qDebug("File %s was not found!", qPrintable(url));
- respondNotFound();
- return;
- }
-Index: src/src.pro
-===================================================================
---- src/src.pro (revision 4101)
-+++ src/src.pro (working copy)
-@@ -142,8 +142,9 @@
- contains(DEFINES, DISABLE_GUI) {
- QT = core
- TARGET = qbittorrent-nox
-+} else {
-+ TARGET = qbittorrent
- }
--else:TARGET = qbittorrent
-
- # QMAKE_CXXFLAGS_RELEASE += -fwrapv
- # QMAKE_CXXFLAGS_DEBUG += -fwrapv
-@@ -211,25 +212,27 @@
- }
- unix:!macx:contains(DEFINES, WITH_GEOIP_EMBEDDED):message("You chose to embed GeoIP database in qBittorrent executable.")
-
-+}
-+
- # Resource files
- RESOURCES = icons.qrc \
- lang.qrc \
- search.qrc \
- webui.qrc
-
-- # Add GeoIP resource file if the GeoIP database
-- # should be embedded in qBittorrent executable
-- contains(DEFINES, WITH_GEOIP_EMBEDDED) {
-- exists("geoip/GeoIP.dat") {
-- message("GeoIP.dat was found in src/geoip/.")
-- RESOURCES += geoip.qrc
-- }
-- else {
-- DEFINES -= WITH_GEOIP_EMBEDDED
-- error("GeoIP.dat was not found in src/geoip/ folder, please follow instructions in src/geoip/README.")
-- }
-+# Add GeoIP resource file if the GeoIP database
-+# should be embedded in qBittorrent executable
-+contains(DEFINES, WITH_GEOIP_EMBEDDED) {
-+ exists("geoip/GeoIP.dat") {
-+ message("GeoIP.dat was found in src/geoip/.")
-+ RESOURCES += geoip.qrc
- }
--else:message("GeoIP database will not be embedded in qBittorrent executable.")
-+ else {
-+ DEFINES -= WITH_GEOIP_EMBEDDED
-+ error("GeoIP.dat was not found in src/geoip/ folder, please follow instructions in src/geoip/README.")
-+ }
-+} else {
-+ message("GeoIP database will not be embedded in qBittorrent executable.")
- }
-
- # Translations
-@@ -284,7 +287,7 @@
- scannedfoldersmodel.h
-
- contains(DEFINES, DISABLE_GUI) {
-- HEADERS += headlessloader.h
-+ HEADERS += headlessloader.h
- } else {
- HEADERS += GUI.h \
- feedList.h \
-@@ -331,7 +334,8 @@
- }
- }
-
--!contains(DEFINES, DISABLE_GUI):FORMS += ui/mainwindow.ui \
-+!contains(DEFINES, DISABLE_GUI) {
-+ FORMS += ui/mainwindow.ui \
- ui/options.ui \
- ui/about.ui \
- ui/createtorrent.ui \
-@@ -350,6 +354,7 @@
- ui/propertieswidget.ui \
- ui/peer.ui \
- ui/confirmdeletiondlg.ui
-+}
-
- contains(DEFINES, DISABLE_GUI) {
- include(qtsingleapp/qtsinglecoreapplication.pri)
diff --git a/net-p2p/qbittorrent/qbittorrent-2.2.2.ebuild b/net-p2p/qbittorrent/qbittorrent-2.2.2.ebuild
deleted file mode 100644
index b02dea9c90a7..000000000000
--- a/net-p2p/qbittorrent/qbittorrent-2.2.2.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.2.2.ebuild,v 1.4 2010/04/10 23:09:02 hwoarang Exp $
-
-EAPI="2"
-inherit confutils qt4-r2 versionator
-
-DESCRIPTION="BitTorrent client in C++ and Qt"
-HOMEPAGE="http://www.qbittorrent.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="+X geoip libnotify"
-
-# boost version so that we always have thread support
-CDEPEND="net-libs/rb_libtorrent
- x11-libs/qt-core:4
- X? ( x11-libs/qt-gui:4
- libnotify? ( x11-libs/qt-gui:4[glib] ) )
- >=dev-libs/boost-1.34.1"
-DEPEND="${CDEPEND}
- dev-util/pkgconfig"
-RDEPEND="${CDEPEND}
- >=dev-lang/python-2.3
- geoip? ( dev-libs/geoip )
- libnotify? ( x11-libs/libnotify )"
-
-DOCS="AUTHORS Changelog NEWS README TODO"
-
-pkg_setup() {
- confutils_use_depend_all libnotify X
-}
-
-src_prepare() {
- # Respect LDFLAGS
- sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
- qt4-r2_src_prepare
-}
-
-src_configure() {
- local myconf
- use X || myconf+=" --disable-gui"
- use geoip || myconf+=" --disable-geoip-database"
- use libnotify || myconf+=" --disable-libnotify"
-
- # slotted boost detection, bug #309415
- BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
- BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
- BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
- myconf+=" --with-libboost-inc=/usr/include/boost-${BOOST_VER}"
-
- # econf fails, since this uses qconf
- ./configure --prefix=/usr --qtdir=/usr ${myconf} || die "configure failed"
- eqmake4
-
- # link to the correct slotted boost version, bug #309415
- sed -i "s/-mt/-mt-${BOOST_VER}/g" conf.pri
-}
diff --git a/net-p2p/qbittorrent/qbittorrent-2.2.5.ebuild b/net-p2p/qbittorrent/qbittorrent-2.2.5.ebuild
deleted file mode 100644
index ad95ee600a9a..000000000000
--- a/net-p2p/qbittorrent/qbittorrent-2.2.5.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.2.5.ebuild,v 1.1 2010/04/10 16:14:48 yngwin Exp $
-
-EAPI="2"
-inherit confutils qt4-r2 versionator
-
-DESCRIPTION="BitTorrent client in C++ and Qt"
-HOMEPAGE="http://www.qbittorrent.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+X geoip libnotify"
-
-# boost version so that we always have thread support
-CDEPEND="net-libs/rb_libtorrent
- x11-libs/qt-core:4
- X? ( x11-libs/qt-gui:4
- libnotify? ( x11-libs/qt-gui:4[glib] ) )
- >=dev-libs/boost-1.34.1"
-DEPEND="${CDEPEND}
- dev-util/pkgconfig"
-RDEPEND="${CDEPEND}
- >=dev-lang/python-2.3
- geoip? ( dev-libs/geoip )
- libnotify? ( x11-libs/libnotify )"
-
-DOCS="AUTHORS Changelog NEWS README TODO"
-
-pkg_setup() {
- confutils_use_depend_all libnotify X
-}
-
-src_prepare() {
- # Respect LDFLAGS
- sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
- qt4-r2_src_prepare
-}
-
-src_configure() {
- local myconf
- use X || myconf+=" --disable-gui"
- use geoip || myconf+=" --disable-geoip-database"
- use libnotify || myconf+=" --disable-libnotify"
-
- # slotted boost detection, bug #309415
- BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
- BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
- BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
- myconf+=" --with-libboost-inc=/usr/include/boost-${BOOST_VER}"
-
- # econf fails, since this uses qconf
- ./configure --prefix=/usr --qtdir=/usr ${myconf} || die "configure failed"
- eqmake4
-}
diff --git a/net-p2p/qbittorrent/qbittorrent-2.2.6.ebuild b/net-p2p/qbittorrent/qbittorrent-2.2.6.ebuild
deleted file mode 100644
index 31ddb036a82c..000000000000
--- a/net-p2p/qbittorrent/qbittorrent-2.2.6.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.2.6.ebuild,v 1.3 2010/05/31 11:53:18 phajdan.jr Exp $
-
-EAPI="2"
-inherit confutils qt4-r2 versionator
-
-DESCRIPTION="BitTorrent client in C++ and Qt"
-HOMEPAGE="http://www.qbittorrent.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="+X geoip libnotify"
-
-# boost version so that we always have thread support
-CDEPEND="net-libs/rb_libtorrent
- x11-libs/qt-core:4
- X? ( x11-libs/qt-gui:4
- libnotify? ( x11-libs/qt-gui:4[glib] ) )
- >=dev-libs/boost-1.34.1"
-DEPEND="${CDEPEND}
- dev-util/pkgconfig"
-RDEPEND="${CDEPEND}
- >=dev-lang/python-2.3
- geoip? ( dev-libs/geoip )
- libnotify? ( x11-libs/libnotify )"
-
-DOCS="AUTHORS Changelog NEWS README TODO"
-
-pkg_setup() {
- confutils_use_depend_all libnotify X
-}
-
-src_prepare() {
- # Respect LDFLAGS
- sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
- qt4-r2_src_prepare
-}
-
-src_configure() {
- local myconf
- use X || myconf+=" --disable-gui"
- use geoip || myconf+=" --disable-geoip-database"
- use libnotify || myconf+=" --disable-libnotify"
-
- # slotted boost detection, bug #309415
- BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
- BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
- BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
- myconf+=" --with-libboost-inc=/usr/include/boost-${BOOST_VER}"
-
- # econf fails, since this uses qconf
- ./configure --prefix=/usr --qtdir=/usr ${myconf} || die "configure failed"
- eqmake4
-}
diff --git a/net-p2p/qbittorrent/qbittorrent-2.2.7.ebuild b/net-p2p/qbittorrent/qbittorrent-2.2.7.ebuild
deleted file mode 100644
index 5f568862b8f1..000000000000
--- a/net-p2p/qbittorrent/qbittorrent-2.2.7.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.2.7.ebuild,v 1.1 2010/05/21 08:37:40 hwoarang Exp $
-
-EAPI="2"
-inherit confutils qt4-r2 versionator
-
-DESCRIPTION="BitTorrent client in C++ and Qt"
-HOMEPAGE="http://www.qbittorrent.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+X geoip libnotify"
-
-# boost version so that we always have thread support
-CDEPEND="net-libs/rb_libtorrent
- x11-libs/qt-core:4
- X? ( x11-libs/qt-gui:4
- libnotify? ( x11-libs/qt-gui:4[glib] ) )
- >=dev-libs/boost-1.34.1"
-DEPEND="${CDEPEND}
- dev-util/pkgconfig"
-RDEPEND="${CDEPEND}
- >=dev-lang/python-2.3
- geoip? ( dev-libs/geoip )
- libnotify? ( x11-libs/libnotify )"
-
-DOCS="AUTHORS Changelog NEWS README TODO"
-
-pkg_setup() {
- confutils_use_depend_all libnotify X
-}
-
-src_prepare() {
- # Respect LDFLAGS
- sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
- qt4-r2_src_prepare
-}
-
-src_configure() {
- local myconf
- use X || myconf+=" --disable-gui"
- use geoip || myconf+=" --disable-geoip-database"
- use libnotify || myconf+=" --disable-libnotify"
-
- # slotted boost detection, bug #309415
- BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
- BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
- BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
- myconf+=" --with-libboost-inc=/usr/include/boost-${BOOST_VER}"
-
- # econf fails, since this uses qconf
- ./configure --prefix=/usr --qtdir=/usr ${myconf} || die "configure failed"
- eqmake4
-}
diff --git a/net-p2p/qbittorrent/qbittorrent-2.2.9-r1.ebuild b/net-p2p/qbittorrent/qbittorrent-2.2.9-r1.ebuild
deleted file mode 100644
index 9a094d2dcdd2..000000000000
--- a/net-p2p/qbittorrent/qbittorrent-2.2.9-r1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.2.9-r1.ebuild,v 1.2 2010/06/20 19:15:24 hwoarang Exp $
-
-EAPI="2"
-PYTHON_DEPEND="2"
-inherit python confutils qt4-r2 versionator
-
-DESCRIPTION="BitTorrent client in C++ and Qt"
-HOMEPAGE="http://www.qbittorrent.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+X geoip libnotify"
-
-# boost version so that we always have thread support
-CDEPEND="net-libs/rb_libtorrent
- x11-libs/qt-core:4
- X? ( x11-libs/qt-gui:4
- libnotify? ( x11-libs/qt-gui:4[glib] ) )
- dev-libs/boost"
-DEPEND="${CDEPEND}
- dev-util/pkgconfig"
-RDEPEND="${CDEPEND}
- geoip? ( dev-libs/geoip )
- libnotify? ( x11-libs/libnotify )"
-
-DOCS="AUTHORS Changelog NEWS README TODO"
-
-pkg_setup() {
- confutils_use_depend_all libnotify X
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- # Move saveDHTEntry definition away from slots so the moc
- # doens't get confused and breaks compilation
- epatch "${FILESDIR}"/moc_bug_workaround.patch
- # same for trackerlist
- epatch "${FILESDIR}"/moc_bug_workaround2.patch
- # fix WebUI for nox binary
- epatch "${FILESDIR}"/nox-webui-fix.patch
- # Respect LDFLAGS
- sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
- qt4-r2_src_prepare
-}
-
-src_configure() {
- local myconf
- use X || myconf+=" --disable-gui"
- use geoip || myconf+=" --disable-geoip-database"
- use libnotify || myconf+=" --disable-libnotify"
-
- # slotted boost detection, bug #309415
- BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
- BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
- BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
- myconf+=" --with-libboost-inc=/usr/include/boost-${BOOST_VER}"
-
- # econf fails, since this uses qconf
- ./configure --prefix=/usr --qtdir=/usr ${myconf} || die "configure failed"
- eqmake4
-}
diff --git a/net-p2p/qbittorrent/qbittorrent-2.3.0_rc1.ebuild b/net-p2p/qbittorrent/qbittorrent-2.3.0_rc1.ebuild
deleted file mode 100644
index d1c8512d66b9..000000000000
--- a/net-p2p/qbittorrent/qbittorrent-2.3.0_rc1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.3.0_rc1.ebuild,v 1.1 2010/07/08 11:30:51 hwoarang Exp $
-
-EAPI="2"
-PYTHON_DEPEND="2"
-
-inherit python confutils qt4-r2 versionator
-
-MY_P="${P/_/}"
-DESCRIPTION="BitTorrent client in C++ and Qt"
-HOMEPAGE="http://www.qbittorrent.org/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+X geoip libnotify"
-
-# boost version so that we always have thread support
-CDEPEND="net-libs/rb_libtorrent
- x11-libs/qt-core:4
- X? ( x11-libs/qt-gui:4
- libnotify? ( x11-libs/qt-gui:4[glib] ) )
- dev-libs/boost"
-DEPEND="${CDEPEND}
- dev-util/pkgconfig"
-RDEPEND="${CDEPEND}
- geoip? ( dev-libs/geoip )
- libnotify? ( x11-libs/libnotify )"
-
-DOCS="AUTHORS Changelog NEWS README TODO"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- confutils_use_depend_all libnotify X
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- # Respect LDFLAGS
- sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
- qt4-r2_src_prepare
-}
-
-src_configure() {
- local myconf
- use X || myconf+=" --disable-gui"
- use geoip || myconf+=" --disable-geoip-database"
- use libnotify || myconf+=" --disable-libnotify"
-
- # slotted boost detection, bug #309415
- BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
- BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
- BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
- myconf+=" --with-libboost-inc=/usr/include/boost-${BOOST_VER}"
-
- # econf fails, since this uses qconf
- ./configure --prefix=/usr --qtdir=/usr ${myconf} || die "configure failed"
- eqmake4
-}