summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-03-03 12:39:07 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-03-03 12:39:07 +0000
commit2cd7500a8e347935c4213fe68b21303346a931b3 (patch)
tree08a317ac84055305db0c836df394a291e1cab3cf /net-p2p
parentDrop old versions (diff)
downloadgentoo-2-2cd7500a8e347935c4213fe68b21303346a931b3.tar.gz
gentoo-2-2cd7500a8e347935c4213fe68b21303346a931b3.tar.bz2
gentoo-2-2cd7500a8e347935c4213fe68b21303346a931b3.zip
Version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitflu/ChangeLog3
-rw-r--r--net-p2p/bitflu/bitflu-1.51.ebuild79
2 files changed, 82 insertions, 0 deletions
diff --git a/net-p2p/bitflu/ChangeLog b/net-p2p/bitflu/ChangeLog
index 39451aa3213b..3dbe6e23cbab 100644
--- a/net-p2p/bitflu/ChangeLog
+++ b/net-p2p/bitflu/ChangeLog
@@ -1,3 +1,6 @@
+# ChangeLog for net-p2p/bitflu
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitflu/ChangeLog,v 1.22 2014/03/03 12:39:07 blueness Exp $
08 Jan 2014; Mike Frysinger <vapier@gentoo.org> bitflu-1.43.ebuild:
Inherit the user eclass for enewuser/etc...
diff --git a/net-p2p/bitflu/bitflu-1.51.ebuild b/net-p2p/bitflu/bitflu-1.51.ebuild
new file mode 100644
index 000000000000..9b0599e65501
--- /dev/null
+++ b/net-p2p/bitflu/bitflu-1.51.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitflu/bitflu-1.51.ebuild,v 1.1 2014/03/03 12:39:07 blueness Exp $
+
+EAPI=4
+
+inherit user
+
+DESCRIPTION="Bitflu is a BitTorrent client, written in Perl and is designed to run as a daemon"
+HOMEPAGE="http://bitflu.workaround.ch"
+SRC_URI="http://bitflu.workaround.ch/bitflu/${P}.tgz"
+
+LICENSE="Artistic-2 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-perl/Danga-Socket
+ dev-perl/Sys-Syscall"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup bitflu
+ enewuser bitflu -1 -1 /var/lib/bitflu bitflu
+}
+
+src_compile() {
+:
+}
+
+PLUGINS="/usr/lib/bitflu"
+HOMEDIR="/var/lib/bitflu"
+CONFDIR="/etc/bitflu"
+LOGDIR="/var/log/bitflu"
+
+src_install() {
+ # executable daemon
+ exeinto /usr/sbin
+ doexe bitflu.pl
+
+ # plugins
+ dodir "${PLUGINS}"
+ insinto "${PLUGINS}"
+ doins -r plugins
+
+ # working dir
+ dodir "${HOMEDIR}"
+ fowners bitflu:bitflu "${HOMEDIR}"
+ fperms 775 "${HOMEDIR}"
+
+ # config file
+ dodir "${CONFDIR}"
+ fowners bitflu:bitflu "${CONFDIR}"
+ fperms 775 "${CONFDIR}"
+ insinto "${CONFDIR}"
+ doins "${FILESDIR}"/bitflu.config
+ fowners bitflu:bitflu "${CONFDIR}"/bitflu.config
+ fperms 664 "${CONFDIR}"/bitflu.config
+
+ # log file
+ dodir "${LOGDIR}"
+ fowners bitflu:bitflu "${LOGDIR}"
+ fperms 775 "${LOGDIR}"
+
+ # docs
+ dodoc bitflu.config.example ChangeLog.txt CONTRIBUTING README_IPv6.txt \
+ README.txt Documentation/bitflu-internals.txt
+
+ newinitd "${FILESDIR}"/bitflu.initd bitflu
+}
+
+pkg_postinst() {
+ ewarn "Note: At startup, or at the user's request, ${PN} (re)reads its"
+ ewarn "configuration file and overwrites it with its own sanitized"
+ ewarn "version. A backup is created in the configuration directory,"
+ ewarn "/etc/${PN}, but that file will subseqently be overwritten if"
+ ewarn "a further backup is made. You may want to keep your own backup."
+ ewarn "A prestine example with comments may be found in /usr/share/doc/${P}."
+}