summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-11-22 16:54:38 +0000
committerPacho Ramos <pacho@gentoo.org>2014-11-22 16:54:38 +0000
commit417b603eb16683478231715ac0f7fb629366f3fc (patch)
tree1450112840e0709073dcae7f1cef5c48565801b9 /net-p2p
parentSet proper dependencies for gtk+ and glib slots (otherwise people will get la... (diff)
downloadgentoo-2-417b603eb16683478231715ac0f7fb629366f3fc.tar.gz
gentoo-2-417b603eb16683478231715ac0f7fb629366f3fc.tar.bz2
gentoo-2-417b603eb16683478231715ac0f7fb629366f3fc.zip
Fix underlinking (#510586 by Ted Tanberry and Leonid Kopylov), prepare to configure.in deprecation, fix tests, fix desktop file
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/gtorrentviewer/ChangeLog11
-rw-r--r--net-p2p/gtorrentviewer/files/gtorrentviewer-0.2b-desktop.patch16
-rw-r--r--net-p2p/gtorrentviewer/files/gtorrentviewer-0.2b-underlinking.patch14
-rw-r--r--net-p2p/gtorrentviewer/gtorrentviewer-0.2b.ebuild33
4 files changed, 62 insertions, 12 deletions
diff --git a/net-p2p/gtorrentviewer/ChangeLog b/net-p2p/gtorrentviewer/ChangeLog
index 44d98e7f2627..7b9d1f0c0a50 100644
--- a/net-p2p/gtorrentviewer/ChangeLog
+++ b/net-p2p/gtorrentviewer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/gtorrentviewer
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gtorrentviewer/ChangeLog,v 1.14 2012/05/04 06:33:34 jdhore Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gtorrentviewer/ChangeLog,v 1.15 2014/11/22 16:54:38 pacho Exp $
+
+ 22 Nov 2014; Pacho Ramos <pacho@gentoo.org>
+ +files/gtorrentviewer-0.2b-desktop.patch,
+ +files/gtorrentviewer-0.2b-underlinking.patch, gtorrentviewer-0.2b.ebuild:
+ Fix underlinking (#510586 by Ted Tanberry and Leonid Kopylov), prepare to
+ configure.in deprecation, fix tests, fix desktop file
04 May 2012; Jeff Horelick <jdhore@gentoo.org> gtorrentviewer-0.2b.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
@@ -56,4 +62,3 @@
+gtorrentviewer-0.2a.ebuild:
Initial import. Thanks to Dionysius Wilson Almeida <dwilson@technolunatic.com>
for the ebuild, #67795.
-
diff --git a/net-p2p/gtorrentviewer/files/gtorrentviewer-0.2b-desktop.patch b/net-p2p/gtorrentviewer/files/gtorrentviewer-0.2b-desktop.patch
new file mode 100644
index 000000000000..8ddad12c3688
--- /dev/null
+++ b/net-p2p/gtorrentviewer/files/gtorrentviewer-0.2b-desktop.patch
@@ -0,0 +1,16 @@
+--- data/gtorrentviewer.desktop.in.old 2014-11-22 17:48:55.859683842 +0100
++++ data/gtorrentviewer.desktop.in 2014-11-22 17:49:25.400108137 +0100
+@@ -3,11 +3,9 @@
+ _GenericName=Torrent Viewer
+ _Comment=Viewer and Editor for .torrent files
+ Exec=gtorrentviewer %U
+-Icon=gtorrentviewer.png
++Icon=gtorrentviewer
+ StartupNotify=false
+ Terminal=false
+ Type=Application
+-Encoding=UTF-8
+-Categories=Application;Network;
++Categories=Network;
+ MimeType=application/x-bittorrent;
+-Version=0.2
diff --git a/net-p2p/gtorrentviewer/files/gtorrentviewer-0.2b-underlinking.patch b/net-p2p/gtorrentviewer/files/gtorrentviewer-0.2b-underlinking.patch
new file mode 100644
index 000000000000..22dd373e2967
--- /dev/null
+++ b/net-p2p/gtorrentviewer/files/gtorrentviewer-0.2b-underlinking.patch
@@ -0,0 +1,14 @@
+--- configure.ac
++++ configure.ac
+@@ -51,6 +51,11 @@
+ # Checks for libraries.
+ #
+
++dnl Check for libm for ceil()
++AC_SEARCH_LIBS([ceil], [m], [], [
++ AC_MSG_ERROR([unable to find the ceil() function])
++])
++
+ # check for libcurl.
+ AC_ARG_WITH([curl-config],
+ AC_HELP_STRING([--with-curl-config=PATH], [path to curl-config (e.g. /opt/bin)]),
diff --git a/net-p2p/gtorrentviewer/gtorrentviewer-0.2b.ebuild b/net-p2p/gtorrentviewer/gtorrentviewer-0.2b.ebuild
index 4f8635f78331..3cb2287c1fb3 100644
--- a/net-p2p/gtorrentviewer/gtorrentviewer-0.2b.ebuild
+++ b/net-p2p/gtorrentviewer/gtorrentviewer-0.2b.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gtorrentviewer/gtorrentviewer-0.2b.ebuild,v 1.9 2012/05/04 06:33:34 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gtorrentviewer/gtorrentviewer-0.2b.ebuild,v 1.10 2014/11/22 16:54:38 pacho Exp $
-EAPI=2
+EAPI=5
+GCONF_DEBUG="yes"
-inherit eutils gnome2
+inherit autotools eutils gnome2
MY_PN=${PN/gtorrentviewer/GTorrentViewer}
MY_P=${MY_PN}-${PV}
@@ -12,20 +13,34 @@ MY_P=${MY_PN}-${PV}
DESCRIPTION="A GTK2-based viewer and editor for BitTorrent meta files"
HOMEPAGE="http://gtorrentviewer.sourceforge.net/"
SRC_URI="mirror://sourceforge/gtorrentviewer/${MY_P}.tar.gz"
+
LICENSE="GPL-2"
KEYWORDS="amd64 ~ppc x86 ~x86-fbsd"
+
SLOT="0"
IUSE=""
+
S=${WORKDIR}/${MY_P}
-RDEPEND="net-misc/curl
+RDEPEND="
+ net-misc/curl
>=x11-libs/gtk+-2.4:2
- >=dev-libs/glib-2.4:2"
+ >=dev-libs/glib-2.4:2
+"
DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-DOCS="AUTHORS ChangeLog INSTALL NEWS README"
+ virtual/pkgconfig
+"
src_prepare() {
+ mv configure.in configure.ac || die #426262
+
epatch "${FILESDIR}"/${P}-curl-headers.patch
+ epatch "${FILESDIR}"/${P}-underlinking.patch
+ epatch "${FILESDIR}"/${P}-desktop.patch
+
+ # Fix tests
+ echo "data/gtorrentviewer.desktop.in" >> po/POTFILES.in || die
+
+ eautoreconf
+ gnome2_src_prepare
}