summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-08-04 00:45:31 +0000
committerJon Hood <squinky86@gentoo.org>2004-08-04 00:45:31 +0000
commit444ddab7d7fbf99522bd805682dc7018d4dad6e8 (patch)
tree258e36fa525bbf97363f6d4e214cff1153a1fb50 /net-p2p
parenterror check autogen.sh (Manifest recommit) (diff)
downloadgentoo-2-444ddab7d7fbf99522bd805682dc7018d4dad6e8.tar.gz
gentoo-2-444ddab7d7fbf99522bd805682dc7018d4dad6e8.tar.bz2
gentoo-2-444ddab7d7fbf99522bd805682dc7018d4dad6e8.zip
version bump, closes #56924
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/sancho-bin/ChangeLog7
-rw-r--r--net-p2p/sancho-bin/Manifest2
-rw-r--r--net-p2p/sancho-bin/files/digest-sancho-bin-0.9.4.72
-rw-r--r--net-p2p/sancho-bin/sancho-bin-0.9.4.7.ebuild54
4 files changed, 64 insertions, 1 deletions
diff --git a/net-p2p/sancho-bin/ChangeLog b/net-p2p/sancho-bin/ChangeLog
index e3754e4dc185..a8e409937a11 100644
--- a/net-p2p/sancho-bin/ChangeLog
+++ b/net-p2p/sancho-bin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/sancho-bin
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/sancho-bin/ChangeLog,v 1.7 2004/07/01 09:39:49 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/sancho-bin/ChangeLog,v 1.8 2004/08/04 00:45:31 squinky86 Exp $
+
+*sancho-bin-0.9.4.7 (03 Aug 2004)
+
+ 03 Aug 2004; Jon Hood <squinky86@gentoo.org> +sancho-bin-0.9.4.7.ebuild:
+ Version bump; closes #56924; thanks spiralvoice <spiralvoice@hotmail.com>.
01 Jul 2004; Jon Hood <squinky86@gentoo.org> sancho-bin-0.9.4.5-r1.ebuild:
change virtual/glibc to virtual/libc
diff --git a/net-p2p/sancho-bin/Manifest b/net-p2p/sancho-bin/Manifest
index 80d82ba219f8..968244a351b4 100644
--- a/net-p2p/sancho-bin/Manifest
+++ b/net-p2p/sancho-bin/Manifest
@@ -1,5 +1,7 @@
MD5 c4f959e2bb98e918822da0522823a3ef sancho-bin-0.9.4.5-r1.ebuild 1314
+MD5 c4f959e2bb98e918822da0522823a3ef sancho-bin-0.9.4.7.ebuild 1314
MD5 e31a2262821cb369985135053f2f25a8 ChangeLog 1214
MD5 8aefbc0e49db723ca1ad02d0c409cd49 metadata.xml 160
MD5 9c8935033c3fe62be83d6ad6e80d5f4e files/sancho.sh 260
MD5 94095fc16619d56b11b9ef972c422043 files/digest-sancho-bin-0.9.4.5-r1 156
+MD5 f264a1342a6e98c198fa05c3c1c39b91 files/digest-sancho-bin-0.9.4.7 156
diff --git a/net-p2p/sancho-bin/files/digest-sancho-bin-0.9.4.7 b/net-p2p/sancho-bin/files/digest-sancho-bin-0.9.4.7
new file mode 100644
index 000000000000..a983bb6f1637
--- /dev/null
+++ b/net-p2p/sancho-bin/files/digest-sancho-bin-0.9.4.7
@@ -0,0 +1,2 @@
+MD5 9b05d01f4b4858cbaf489be6fbe5c5e7 sancho-0.9.4-7-linux-gtk.tar.bz2 3913576
+MD5 e16dc996c665c0b4fff1244ae75915bd sancho-0.9.4-7-linux-fox.tar.bz2 4144629
diff --git a/net-p2p/sancho-bin/sancho-bin-0.9.4.7.ebuild b/net-p2p/sancho-bin/sancho-bin-0.9.4.7.ebuild
new file mode 100644
index 000000000000..9c3057012aaa
--- /dev/null
+++ b/net-p2p/sancho-bin/sancho-bin-0.9.4.7.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/sancho-bin/sancho-bin-0.9.4.7.ebuild,v 1.1 2004/08/04 00:45:31 squinky86 Exp $
+
+IUSE="gtk2"
+
+MY_P=${P/-bin/}
+MY_P=${MY_P%.*}-${MY_P##*.}
+
+use gtk2 && TOOLKIT="gtk" || TOOLKIT="fox"
+
+DESCRIPTION="a powerful frontend for mldonkey"
+HOMEPAGE="http://sancho-gui.sourceforge.net/"
+SRC_URI="http://sancho-gui.sourceforge.net/tmp/${MY_P}-linux-${TOOLKIT}.tar.bz2"
+SRC_URI="gtk2? ( http://sancho-gui.sourceforge.net/tmp/${MY_P}-linux-gtk.tar.bz2 )
+ !gtk2? ( http://sancho-gui.sourceforge.net/tmp/${MY_P}-linux-fox.tar.bz2 )"
+
+KEYWORDS="~x86"
+SLOT="0"
+LICENSE="CPL-1.0 LGPL-2.1"
+
+DEPEND="virtual/libc
+ virtual/x11
+ gtk2? ( >=x11-libs/gtk+-2 )"
+
+S="${WORKDIR}/${MY_P}-linux-${TOOLKIT}"
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ dodir /opt/sancho
+ dodir /opt/bin
+
+ cd ${S}
+ cp -dpR sancho distrib lib ${D}/opt/sancho
+
+ exeinto /opt/sancho
+ doexe sancho-bin
+
+ exeinto /opt/bin
+ newexe ${FILESDIR}/sancho.sh sancho
+
+ dodir /etc/env.d
+ echo -e "PATH=/opt/sancho\n" > ${D}/etc/env.d/20sancho
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Sancho requires the presence of a p2p core, like"
+ einfo "net-p2p/mldonkey, in order to operate."
+ einfo
+}