summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-08-08 03:02:01 +0000
committerJon Hood <squinky86@gentoo.org>2004-08-08 03:02:01 +0000
commit46faf399131e23ff28650f8d8805822071774033 (patch)
tree4ae9610b14f6c9471e43cb6391a4572e5fb291f6 /net-p2p
parentInitial import. Closes #59123. (Manifest recommit) (diff)
downloadgentoo-2-46faf399131e23ff28650f8d8805822071774033.tar.gz
gentoo-2-46faf399131e23ff28650f8d8805822071774033.tar.bz2
gentoo-2-46faf399131e23ff28650f8d8805822071774033.zip
ebuild cleanups courtesy of #59640 and #59672
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/amule/ChangeLog6
-rw-r--r--net-p2p/amule/amule-2.0.0_rc5.ebuild50
2 files changed, 40 insertions, 16 deletions
diff --git a/net-p2p/amule/ChangeLog b/net-p2p/amule/ChangeLog
index 634e6695d622..43126a3cfa99 100644
--- a/net-p2p/amule/ChangeLog
+++ b/net-p2p/amule/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/amule
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/ChangeLog,v 1.28 2004/07/23 23:41:38 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/ChangeLog,v 1.29 2004/08/08 03:02:01 squinky86 Exp $
+
+ 07 Aug 2004; Jon Hood <squinky86@gentoo.org> amule-2.0.0_rc5.ebuild:
+ Inherit wxwindows; thanks Giacomo Perale <ghepeu@virgilio.it>, #59672.
+ Adding optional gd abilities for those not wanting stats, #59640.
23 Jul 2004; Michael Sterrett <mr_bones_@gentoo.org> amule-2.0.0_rc5.ebuild:
don't use deprecated ? : syntax
diff --git a/net-p2p/amule/amule-2.0.0_rc5.ebuild b/net-p2p/amule/amule-2.0.0_rc5.ebuild
index e61024e7cf7f..63ed1931617e 100644
--- a/net-p2p/amule/amule-2.0.0_rc5.ebuild
+++ b/net-p2p/amule/amule-2.0.0_rc5.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.0.0_rc5.ebuild,v 1.3 2004/07/23 23:41:38 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.0.0_rc5.ebuild,v 1.4 2004/08/08 03:02:01 squinky86 Exp $
+
+inherit wxwidgets
MY_P=${P/m/M}
MY_P=${MY_P/_/}
@@ -10,39 +12,57 @@ DESCRIPTION="aMule, the all-platform eMule p2p client"
HOMEPAGE="http://www.amule.org"
SRC_URI="http://download.berlios.de/${PN}/${MY_P}.tar.bz2"
-
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~amd64"
-IUSE="debug nls remote stats"
-EXTRA_ECONF="--disable-optimise"
+IUSE="debug gtk2 nls remote stats unicode gd"
+
# USE "stats" enables external utilities (statistics and other)
# USE "remote" enables remote controlling utilities (webserver, text client)
+
DEPEND="remote? ( =x11-libs/wxGTK-2.4* )
- !remote? ( >=x11-libs/wxGTK-2.4.2-r1 )
+ !remote? ( >=x11-libs/wxGTK-2.4.2-r2 )
>=net-misc/curl-7.11.0
>=dev-libs/crypto++-5.1-r1
>=sys-libs/zlib-1.2.1
- stats? ( >=media-libs/gd-2.0.23 )"
+ stats? ( >=media-libs/gd-2.0.26 )
+ gd? ( >=media-libs/gd-2.0.26 )"
pkg_setup() {
- # GTK2 is unstable on wxGTK 2.4 and not supported by aMule developers
- if wx-config --version | grep 2.4 >& /dev/null \
- && wx-config --cppflags | grep gtk2 >& /dev/null; then
- einfo "Compiling ${PN} against wxGTK2 2.4.x is not supported."
- einfo "wxGTK must be re-emerged with USE=\"-gtk2\" or you can upgrade"
- einfo "to development snapshots 2.5.1, but this will break other"
- einfo "applications and the webserver. Please note that gtk2 support"
- einfo "is still experimental."
- die "wxGTK 2.4 must be re-emerged with USE=\"-gtk2\"."
+ if use gtk2 >& /dev/null && use remote >& /dev/null ; then
+ die "aMule remote utilities don't work with wxGTK 2.5 so use either USE='remote' or USE='gtk2'"
fi
+ need-wxwidgets gtk
+
+ if ${WX_CONFIG} --version | grep 2.4 >& /dev/null ; then
+ if use gtk2 >& /dev/null || use unicode >& /dev/null ; then
+ einfo "Compiling ${PN} against wxGTK2 2.4.x is not supported."
+ einfo "You can upgrade wxGTK to development snapshot 2.5.*"
+ einfo "but this will break other applications, or emerge amule"
+ einfo "with USE=\"-gtk2\"."
+ die "Emerge amule with USE=\"-gtk2 -unicode\"."
+ fi
+ else
+ if ! use gtk2 >& /dev/null ; then
+ need-wxwidgets gtk || die "gtk version of x11-libs/wxGTK not found"
+ elif use unicode >& /dev/null ; then
+ need-wxwidgets unicode || die "You need to emerge unicoded wxGTK with USE='gtk2 unicode'"
+ else
+ need-wxwidgets gtk2 || die "You need to emerge wxGTK with USE='gtk2'"
+ fi
+ fi
}
src_compile() {
+
+ EXTRA_ECONF="--disable-optimise \
+ --with-wx-config=${WX_CONFIG} \
+ --with-wxbase-config=${WX_CONFIG}"
+
econf `use_enable nls` \
`use_enable remote amulecmd` \
`use_enable remote amulecmdgui` \