summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2008-08-16 15:48:08 +0000
committerVlastimil Babka <caster@gentoo.org>2008-08-16 15:48:08 +0000
commit506edd40320f393c6955bc82882a7960b3242387 (patch)
tree21820cf9ee6dcf67ea32ce1db8e9d879d267c8a8 /net-p2p
parentRemove stkn from metadata.xml (#27693) (diff)
downloadgentoo-2-506edd40320f393c6955bc82882a7960b3242387.tar.gz
gentoo-2-506edd40320f393c6955bc82882a7960b3242387.tar.bz2
gentoo-2-506edd40320f393c6955bc82882a7960b3242387.zip
Version bump. Based on contributions from geki in java-overlay and Thomas Axelsson in bug 229061. Problems loading dashboard (does not affect torrents) are problem of swt tracked in bug 234934.
(Portage version: 2.2_rc8/cvs/Linux 2.6.25-gentoo-r4 x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/azureus/ChangeLog12
-rw-r--r--net-p2p/azureus/azureus-3.1.1.0.ebuild150
-rw-r--r--net-p2p/azureus/metadata.xml5
3 files changed, 161 insertions, 6 deletions
diff --git a/net-p2p/azureus/ChangeLog b/net-p2p/azureus/ChangeLog
index dca67b990cdc..7bc99051c0c3 100644
--- a/net-p2p/azureus/ChangeLog
+++ b/net-p2p/azureus/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for net-p2p/azureus
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/ChangeLog,v 1.67 2008/04/21 18:40:10 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/ChangeLog,v 1.68 2008/08/16 15:48:08 caster Exp $
+
+*azureus-3.1.1.0 (16 Aug 2008)
+
+ 16 Aug 2008; Vlastimil Babka <caster@gentoo.org>
+ +files/patches-3.1.1.0/remove-osx-platform.diff,
+ +files/patches-3.1.1.0/use-jdk-cipher-only.diff, metadata.xml,
+ +azureus-3.1.1.0.ebuild:
+ Version bump. Based on contributions from geki in java-overlay and Thomas
+ Axelsson in bug 229061. Problems loading dashboard (does not affect
+ torrents) are problem of swt tracked in bug 234934.
21 Apr 2008; Petteri Räty <betelgeuse@gentoo.org> azureus-3.0.5.2.ebuild:
Add back memory limit increasing. Should fix bug #218681.
diff --git a/net-p2p/azureus/azureus-3.1.1.0.ebuild b/net-p2p/azureus/azureus-3.1.1.0.ebuild
new file mode 100644
index 000000000000..56e1feecd2ef
--- /dev/null
+++ b/net-p2p/azureus/azureus-3.1.1.0.ebuild
@@ -0,0 +1,150 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/azureus-3.1.1.0.ebuild,v 1.1 2008/08/16 15:48:08 caster Exp $
+
+###
+### @Todo The new Azureus gui requires swt built with embedded mozilla support,
+### or azureus will hang at startup. However, you can still start
+### the old GUI which doesn't require it, by using file/restart (which
+### is kind of bug, and maybe I should put that patch, that removes
+### restart from menu, back). It probably could be invoked also by using
+### a different Main class (look for them there are plenty :) so we could
+### have some old-gui flag which would run that one and remove
+### the mozilla dep. Best would be some per-user setting and startup
+### script check for swt mozilla support and die...
+###
+
+EAPI=1
+
+JAVA_PKG_IUSE="source"
+
+inherit eutils fdo-mime java-pkg-2 java-ant-2
+
+DESCRIPTION="BitTorrent client in Java, also known as Vuze"
+HOMEPAGE="http://azureus.sourceforge.net/"
+SRC_URI="mirror://sourceforge/azureus/Vuze_${PV}_source.zip"
+LICENSE="GPL-2 BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-java/json-simple:0
+ >=dev-java/bcprov-1.35:0
+ >=dev-java/commons-cli-1.0:1
+ >=dev-java/log4j-1.2.8:0
+ >=dev-java/swt-3.4:3.4
+ !net-p2p/azureus-bin
+ >=virtual/jre-1.5"
+
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-util/desktop-file-utils
+ >=virtual/jdk-1.5"
+
+JAVA_PKG_FILTER_COMPILER="jikes"
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ # the order matters here because built_with_use doesn't like -o and --missing false combo
+ if ! built_with_use --missing false -o dev-java/swt:3.4 xulrunner mozilla firefox seamonkey; then
+ eerror "dev-java/swt:3.4 must be compiled with the firefox, mozilla, seamonkey or xulrunner USE flag"
+ eerror "(support may vary per swt version) or azureus would hang at startup!"
+ die "please recompile dev-java/swt:3.4 with embedded browser"
+ fi
+ # without cairo, some button captions seems missing
+ if ! built_with_use dev-java/swt:3.4 cairo; then
+ eerror "dev-java/swt:3.4 must be compiled with cairo USE flag"
+ die "please recompile dev-java/swt:3.4 with cairo USE flag"
+ fi
+ java-pkg-2_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+
+ epatch "${FILESDIR}/patches-3.1.1.0/use-jdk-cipher-only.diff"
+ epatch "${FILESDIR}/patches-3.1.1.0/remove-osx-platform.diff"
+
+ ### Removes OS X files and entries.
+ rm -rv "org/gudy/azureus2/platform/macosx" \
+ "org/gudy/azureus2/ui/swt/osx" || die
+
+ ### Removes Windows files.
+ rm -v ./org/gudy/azureus2/ui/swt/win32/Win32UIEnhancer.java || die
+
+ ### Removes test files.
+ rm -rv "org/gudy/azureus2/ui/swt/test" \
+ org/gudy/azureus2/ui/console/multiuser/TestUserManager.java || die
+
+ ### Removes bouncycastle (we use our own bcprov).
+ rm -rv "org/bouncycastle" || die
+
+ ### Removes bundled json
+ rm -rv "org/json" || die
+
+ mkdir -p build/libs || die
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="swt-3.4,bcprov,json-simple,log4j,commons-cli-1"
+
+src_compile() {
+ local mem
+ use amd64 && mem="256"
+ use x86 && mem="128"
+ use ppc && mem="192"
+ export ANT_OPTS="-Xmx${mem}m"
+ java-pkg-2_src_compile
+}
+
+src_install() {
+ java-pkg_dojar dist/*.jar || die "dojar failed"
+ dodoc ChangeLog.txt || die
+
+ java-pkg_dolauncher "${PN}" \
+ --main 'org.gudy.azureus2.${UI}.Main' -pre "${FILESDIR}/${PN}-3.0.5.2-pre" \
+ --java_args '-Dazureus.install.path=${HOME}/.azureus/ ${JAVA_OPTIONS}'
+
+ # https://bugs.gentoo.org/show_bug.cgi?id=204132
+ java-pkg_register-environment-variable MOZ_PLUGIN_PATH /usr/lib/nsbrowser/plugins
+
+ doicon "${FILESDIR}/azureus.png"
+ domenu "${FILESDIR}/azureus.desktop"
+
+ use source && java-pkg_dosrc "${S}"/{com,edu,org}
+}
+
+pkg_postinst() {
+ ###
+ ### @Todo We should probably deactivate auto-update it by default,
+ ### or even remove the option.
+ ###
+ elog "It is not recommended to use the Azureus auto-update feature,"
+ elog "and it might not even work. You should disable auto-update via"
+ elog "Tools > Options > Interface > Start"
+ elog
+ elog "After running azureus for the first time, configuration"
+ elog "options will be placed in '~/.azureus/gentoo.config'."
+ elog "If you need to change some startup options, you should"
+ elog "modify this file, rather than the startup script."
+ elog
+ elog "Using this config file you can start the console UI."
+ echo
+ elog "To switch from classic UI to Vuze use"
+ elog "1: Tools > Options > Interface > Start > Display Azureus UI Chooser"
+ elog "2: Toolbar (right-hand side)"
+ echo
+ elog "If you have problems starting Azureus, try starting it"
+ elog "from the command line to look at debugging output."
+ echo
+ ewarn "Running Azureus as root is not supported."
+
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/net-p2p/azureus/metadata.xml b/net-p2p/azureus/metadata.xml
index 377d9649bf26..7303cef96964 100644
--- a/net-p2p/azureus/metadata.xml
+++ b/net-p2p/azureus/metadata.xml
@@ -1,10 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer>
- <email>betelgeuse@gentoo.org</email>
- <name>Petteri Räty</name>
- <description>Maintainer</description>
- </maintainer>
<herd>java</herd>
</pkgmetadata>