summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2006-08-27 09:51:42 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2006-08-27 09:51:42 +0000
commit53344fd746a1e805e9a30a686771225585923e8d (patch)
treeedd24f27ec6a338a90959c39fca9b12b00821e91 /net-p2p
parentversion bump (diff)
downloadgentoo-2-53344fd746a1e805e9a30a686771225585923e8d.tar.gz
gentoo-2-53344fd746a1e805e9a30a686771225585923e8d.tar.bz2
gentoo-2-53344fd746a1e805e9a30a686771225585923e8d.zip
Version bump. Fixes bug #144760. Thanks to Triffid Hunter <triffid_hunter@funkmunch.net> and Caster <caster@matfyz.cz>.
(Portage version: 2.1.1_rc1)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/azureus/ChangeLog14
-rw-r--r--net-p2p/azureus/azureus-2.5.0.0.ebuild115
-rw-r--r--net-p2p/azureus/files/digest-azureus-2.5.0.03
-rw-r--r--net-p2p/azureus/files/fedora-2.5.0.0/azureus-cache-size.patch11
-rw-r--r--net-p2p/azureus/files/fedora-2.5.0.0/azureus-no-restart.patch19
-rw-r--r--net-p2p/azureus/files/fedora-2.5.0.0/azureus-remove-manifest-classpath.patch10
-rw-r--r--net-p2p/azureus/files/fedora-2.5.0.0/azureus-remove-win32-PlatformManagerUpdateChecker.patch14
-rw-r--r--net-p2p/azureus/files/fedora-2.5.0.0/azureus-remove-win32-osx-platforms.patch37
8 files changed, 222 insertions, 1 deletions
diff --git a/net-p2p/azureus/ChangeLog b/net-p2p/azureus/ChangeLog
index 8af858648b71..75cb722a5138 100644
--- a/net-p2p/azureus/ChangeLog
+++ b/net-p2p/azureus/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for net-p2p/azureus
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/ChangeLog,v 1.24 2006/08/20 08:39:09 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/ChangeLog,v 1.25 2006/08/27 09:51:41 betelgeuse Exp $
+
+*azureus-2.5.0.0 (27 Aug 2006)
+
+ 27 Aug 2006; Petteri Räty <betelgeuse@gentoo.org>
+ +files/fedora-2.5.0.0/azureus-cache-size.patch,
+ +files/fedora-2.5.0.0/azureus-no-restart.patch,
+ +files/fedora-2.5.0.0/azureus-remove-manifest-classpath.patch,
+ +files/fedora-2.5.0.0/azureus-remove-win32-PlatformManagerUpdateChecker.pa
+ tch, +files/fedora-2.5.0.0/azureus-remove-win32-osx-platforms.patch,
+ +azureus-2.5.0.0.ebuild:
+ Version bump. Fixes bug #144760. Thanks to Triffid Hunter
+ <triffid_hunter@funkmunch.net> and Caster <caster@matfyz.cz>.
20 Aug 2006; Petteri Räty <betelgeuse@gentoo.org>
azureus-2.4.0.2-r2.ebuild:
diff --git a/net-p2p/azureus/azureus-2.5.0.0.ebuild b/net-p2p/azureus/azureus-2.5.0.0.ebuild
new file mode 100644
index 000000000000..ffe766ac8172
--- /dev/null
+++ b/net-p2p/azureus/azureus-2.5.0.0.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/azureus-2.5.0.0.ebuild,v 1.1 2006/08/27 09:51:41 betelgeuse Exp $
+
+inherit eutils fdo-mime java-pkg-2 java-ant-2
+
+DESCRIPTION="Azureus - Java BitTorrent Client"
+HOMEPAGE="http://azureus.sourceforge.net/"
+SRC_URI="mirror://sourceforge/azureus/Azureus_${PV}_source.zip"
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="source"
+
+# >=swt-3.2 for bug
+# https://bugs.gentoo.org/show_bug.cgi?id=135835
+
+RDEPEND="
+ >=virtual/jre-1.4
+ >=dev-java/swt-3.2
+ >=dev-java/log4j-1.2.8
+ >=dev-java/commons-cli-1.0
+ >=dev-java/bcprov-1.31
+ !net-p2p/azureus-bin"
+DEPEND="${RDEPEND}
+ >=virtual/jdk-1.4
+ dev-util/desktop-file-utils
+ >=dev-java/ant-core-1.6.2
+ || ( =dev-java/eclipse-ecj-3.2* =dev-java/eclipse-ecj-3.1* )
+ source? ( app-arch/zip )
+ >=app-arch/unzip-5.0"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ mkdir ${S}
+ cd ${S}
+ unpack ${A}
+
+ EPATCH_SUFFIX="patch" EPATCH_FORCE="yes" \
+ epatch ${FILESDIR}/fedora-${PV}/
+
+ #removing osx files and entries
+ rm -fr org/gudy/azureus2/ui/swt/osx org/gudy/azureus2/platform/macosx
+ #removing windows files
+ rm -fr org/gudy/azureus2/platform/win32
+ #removing test files
+ rm -fr org/gudy/azureus2/ui/swt/test
+ rm -f org/gudy/azureus2/ui/console/multiuser/TestUserManager.java
+ #removing bouncycastle
+ rm -fr org/bouncycastle
+
+ mkdir -p build/libs
+ cd build/libs
+ java-pkg_jar-from log4j
+ java-pkg_jar-from commons-cli-1
+ java-pkg_jar-from swt-3
+ java-pkg_jar-from bcprov
+}
+
+src_compile() {
+ # javac likes to run out of memory during build... use ecj instead
+ java-pkg_force-compiler ecj-3.2 ecj-3.1
+
+ eant ${ant_extra_opts} jar
+}
+
+src_install() {
+ java-pkg_dojar dist/Azureus2.jar || die "dojar failed"
+
+
+ java-pkg_dolauncher ${PN} \
+ --main org.gudy.azureus2.ui.swt.Main \
+ -pre ${FILESDIR}/${PN}-2.4.0.2-pre
+
+ doicon "${FILESDIR}/azureus.png"
+ domenu "${FILESDIR}/azureus.desktop"
+ use source && java-pkg_dosrc ${S}/{com,org}
+}
+
+pkg_postinst() {
+ echo
+ einfo "Due to the nature of the portage system, we recommend"
+ einfo "that users check portage for new versions of Azureus"
+ einfo "instead of attempting to use the auto-update feature."
+ einfo "You can disable auto-update in"
+ einfo "Tools->Options...->Interface->Start"
+ echo
+ einfo "After running azureus for the first time, configuration"
+ einfo "options will be placed in ~/.azureus/gentoo.config"
+ einfo "It is recommended that you modify this file rather than"
+ einfo "the azureus startup script directly."
+ echo
+ einfo "As of this version, the new ui type 'console' is supported,"
+ einfo "and this may be set in ~/.azureus/gentoo.config."
+ echo
+ ewarn "If you are upgrading, and the menu in azureus has entries like"
+ ewarn "\"!MainWindow.menu.transfers!\" then you have a stray"
+ ewarn "MessageBundle.properties file,"
+ ewarn "and you may safely delete ~/.azureus/MessagesBundle.properties"
+ echo
+ einfo "It's recommended to use Sun's Java version 1.5 or later."
+ einfo "If you're experiencing problems running azureus and you've"
+ einfo "using an older version of Java, try to upgrading to a new version. "
+ echo
+ ewarn "Please, do not run azureus as root!"
+ ewarn "Azureus has not been developed for multi-user environments!"
+
+ fdo-mime_desktop_database_update
+}
+
+pkg_prerm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/net-p2p/azureus/files/digest-azureus-2.5.0.0 b/net-p2p/azureus/files/digest-azureus-2.5.0.0
new file mode 100644
index 000000000000..9e923fb8c6d3
--- /dev/null
+++ b/net-p2p/azureus/files/digest-azureus-2.5.0.0
@@ -0,0 +1,3 @@
+MD5 f487f75f37674820bd3b2cc6af97ce57 Azureus_2.5.0.0_source.zip 5856328
+RMD160 7ec7e6ccb570651a655f6077d4b323a4d3b8fcb0 Azureus_2.5.0.0_source.zip 5856328
+SHA256 64aa4150bb8036f11e5207a602253431d46578ce9cd3b62732b0ae0f555a08c4 Azureus_2.5.0.0_source.zip 5856328
diff --git a/net-p2p/azureus/files/fedora-2.5.0.0/azureus-cache-size.patch b/net-p2p/azureus/files/fedora-2.5.0.0/azureus-cache-size.patch
new file mode 100644
index 000000000000..954f6eeae4f9
--- /dev/null
+++ b/net-p2p/azureus/files/fedora-2.5.0.0/azureus-cache-size.patch
@@ -0,0 +1,11 @@
+--- org/gudy/azureus2/core3/config/COConfigurationManager.java.~1.34.~ 2006-01-19 21:27:18.000000000 -0500
++++ org/gudy/azureus2/core3/config/COConfigurationManager.java 2006-02-09 00:01:46.000000000 -0500
+@@ -39,7 +39,7 @@
+ public static final int CONFIG_CACHE_SIZE_MAX_MB;
+
+ static{
+- long max_mem_bytes = Runtime.getRuntime().maxMemory();
++ long max_mem_bytes = Math.min (Runtime.getRuntime().maxMemory(), 64*1024*1024);
+ long mb_1 = 1*1024*1024;
+ long mb_32 = 32*mb_1;
+ CONFIG_CACHE_SIZE_MAX_MB = (int)(( max_mem_bytes - mb_32 )/mb_1);
diff --git a/net-p2p/azureus/files/fedora-2.5.0.0/azureus-no-restart.patch b/net-p2p/azureus/files/fedora-2.5.0.0/azureus-no-restart.patch
new file mode 100644
index 000000000000..11473ccdcdb3
--- /dev/null
+++ b/net-p2p/azureus/files/fedora-2.5.0.0/azureus-no-restart.patch
@@ -0,0 +1,19 @@
+--- org/gudy/azureus2/ui/swt/mainwindow/MainMenu.java 2006-08-22 10:18:03.000000000 +0200
++++ org/gudy/azureus2/ui/swt/mainwindow/MainMenu.java 2006-08-22 10:20:10.000000000 +0200
+@@ -200,16 +200,6 @@
+ if(!Constants.isOSX) {
+ new MenuItem(fileMenu, SWT.SEPARATOR);
+
+- MenuItem file_restart = new MenuItem(fileMenu, SWT.NULL);
+- Messages.setLanguageText(file_restart, "MainWindow.menu.file.restart"); //$NON-NLS-1$
+-
+- file_restart.addListener(SWT.Selection, new Listener() {
+-
+- public void handleEvent(Event event) {
+- UIFunctionsManagerSWT.getUIFunctionsSWT().dispose(true, false);
+- }
+- });
+-
+ final MenuItem file_exit = new MenuItem(fileMenu, SWT.NULL);
+ if(!COConfigurationManager.getBooleanParameter("Enable System Tray") || !COConfigurationManager.getBooleanParameter("Close To Tray")) {
+ KeyBindings.setAccelerator(file_exit, "MainWindow.menu.file.exit");
diff --git a/net-p2p/azureus/files/fedora-2.5.0.0/azureus-remove-manifest-classpath.patch b/net-p2p/azureus/files/fedora-2.5.0.0/azureus-remove-manifest-classpath.patch
new file mode 100644
index 000000000000..842e47b39f4a
--- /dev/null
+++ b/net-p2p/azureus/files/fedora-2.5.0.0/azureus-remove-manifest-classpath.patch
@@ -0,0 +1,10 @@
+--- build.xml.orig 2005-10-25 05:22:46.000000000 -0700
++++ build.xml 2006-01-25 12:16:32.000000000 -0800
+@@ -39,7 +39,6 @@
+ <jar destfile="${root.dir}/${dist.dir}/Azureus2.jar" basedir="${root.dir}" excludes="${dist.jar.excludes}" >
+ <manifest>
+ <attribute name="Main-Class" value="org.gudy.azureus2.ui.common.Main" />
+- <attribute name="Class-Path" value="Azureus2.jar apple-extensions.jar commons-cli.jar log4j.jar swt.jar swt-win32.jar swt-osx.jar" />
+ </manifest>
+ </jar>
+
diff --git a/net-p2p/azureus/files/fedora-2.5.0.0/azureus-remove-win32-PlatformManagerUpdateChecker.patch b/net-p2p/azureus/files/fedora-2.5.0.0/azureus-remove-win32-PlatformManagerUpdateChecker.patch
new file mode 100644
index 000000000000..6cbc8c194a02
--- /dev/null
+++ b/net-p2p/azureus/files/fedora-2.5.0.0/azureus-remove-win32-PlatformManagerUpdateChecker.patch
@@ -0,0 +1,14 @@
+--- org/gudy/azureus2/pluginsimpl/local/PluginInitializer.java 2006-07-27 11:35:22.000000000 +0200
++++ org/gudy/azureus2/pluginsimpl/local/PluginInitializer.java 2006-08-22 10:22:49.000000000 +0200
+@@ -131,11 +131,6 @@
+ "azbpcorepatcher",
+ "CorePatcher",
+ "true" },
+- { PluginManagerDefaults.PID_PLATFORM_CHECKER,
+- "org.gudy.azureus2.platform.win32.PlatformManagerUpdateChecker",
+- "azplatform2",
+- "azplatform2",
+- "true" },
+ //{ PluginManagerDefaults.PID_JPC,
+ // "com.aelitis.azureus.plugins.jpc.JPCPlugin",
+ // "azjpc",
diff --git a/net-p2p/azureus/files/fedora-2.5.0.0/azureus-remove-win32-osx-platforms.patch b/net-p2p/azureus/files/fedora-2.5.0.0/azureus-remove-win32-osx-platforms.patch
new file mode 100644
index 000000000000..961ee333ceef
--- /dev/null
+++ b/net-p2p/azureus/files/fedora-2.5.0.0/azureus-remove-win32-osx-platforms.patch
@@ -0,0 +1,37 @@
+--- org/gudy/azureus2/platform/PlatformManagerFactory.java.orig 2005-09-12 12:00:07.000000000 -0700
++++ org/gudy/azureus2/platform/PlatformManagerFactory.java 2006-01-25 11:25:11.000000000 -0800
+@@ -42,33 +42,7 @@
+ {
+ try{
+ class_mon.enter();
+-
+- if ( platform_manager == null ){
+-
+- try{
+- if ( getPlatformType() == PlatformManager.PT_WINDOWS ){
+-
+- platform_manager = org.gudy.azureus2.platform.win32.PlatformManagerImpl.getSingleton();
+-
+- }else if( getPlatformType() == PlatformManager.PT_MACOSX ){
+-
+- platform_manager = org.gudy.azureus2.platform.macosx.PlatformManagerImpl.getSingleton();
+-
+- }
+- }catch( PlatformManagerException e ){
+-
+- // exception will already have been logged
+-
+- }catch( Throwable e ){
+-
+- Debug.printStackTrace(e);
+- }
+- }
+-
+- if ( platform_manager == null ){
+-
+- platform_manager = org.gudy.azureus2.platform.dummy.PlatformManagerImpl.getSingleton();
+- }
++ platform_manager = org.gudy.azureus2.platform.dummy.PlatformManagerImpl.getSingleton();
+
+ return( platform_manager );
+