summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-11-28 22:49:28 +0000
committerPacho Ramos <pacho@gentoo.org>2010-11-28 22:49:28 +0000
commit610c72a83439c0783272984c982529c9dc583cb0 (patch)
tree98ea382ca4904a55e0b8f9a1132c3f7e1a3caa28 /net-p2p
parentRestrict Jython ABIs. (diff)
downloadgentoo-2-610c72a83439c0783272984c982529c9dc583cb0.tar.gz
gentoo-2-610c72a83439c0783272984c982529c9dc583cb0.tar.bz2
gentoo-2-610c72a83439c0783272984c982529c9dc583cb0.zip
Let this compile and work when python3 is the main interpreter (bug #315863).
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/deluge/ChangeLog5
-rw-r--r--net-p2p/deluge/deluge-1.3.1.ebuild14
2 files changed, 14 insertions, 5 deletions
diff --git a/net-p2p/deluge/ChangeLog b/net-p2p/deluge/ChangeLog
index e1c54b809e4d..bd4bcd2929ab 100644
--- a/net-p2p/deluge/ChangeLog
+++ b/net-p2p/deluge/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-p2p/deluge
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/ChangeLog,v 1.154 2010/11/17 17:22:14 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/ChangeLog,v 1.155 2010/11/28 22:49:28 pacho Exp $
+
+ 28 Nov 2010; Pacho Ramos <pacho@gentoo.org> deluge-1.3.1.ebuild:
+ Let this compile and work when python3 is the main interpreter (bug #315863).
*deluge-1.3.1 (17 Nov 2010)
diff --git a/net-p2p/deluge/deluge-1.3.1.ebuild b/net-p2p/deluge/deluge-1.3.1.ebuild
index 2983067d60b4..d0afc81aa850 100644
--- a/net-p2p/deluge/deluge-1.3.1.ebuild
+++ b/net-p2p/deluge/deluge-1.3.1.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-1.3.1.ebuild,v 1.1 2010/11/17 17:22:14 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-1.3.1.ebuild,v 1.2 2010/11/28 22:49:28 pacho Exp $
EAPI="2"
+PYTHON_DEPEND="2:2.5"
inherit eutils distutils flag-o-matic python
@@ -15,15 +16,14 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~x86"
IUSE="gtk libnotify webinterface"
-DEPEND=">=virtual/python-2.5
- || ( app-arch/xz-utils app-arch/lzma-utils )
+DEPEND="|| ( app-arch/xz-utils app-arch/lzma-utils )
>=net-libs/rb_libtorrent-0.14.9[python]
dev-python/setuptools"
RDEPEND="${DEPEND}
dev-python/chardet
dev-python/pyopenssl
dev-python/pyxdg
- || ( >=virtual/python-2.6 dev-python/simplejson )
+ || ( dev-lang/python:2.7 dev-lang/python:2.6 dev-python/simplejson )
>=dev-python/twisted-8.1
>=dev-python/twisted-web-8.1
gtk? (
@@ -37,6 +37,12 @@ RDEPEND="${DEPEND}
pkg_setup() {
append-ldflags $(no-as-needed)
+ python_set_active_version 2
+}
+
+src_prepare() {
+ distutils_src_prepare
+ python_convert_shebangs -r 2 .
}
src_install() {