summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2009-02-06 11:46:18 +0000
committerVlastimil Babka <caster@gentoo.org>2009-02-06 11:46:18 +0000
commit75b7304c5e747249eced92bfcad11fb3718b5f89 (patch)
treea7d2628524aba980b1dd7edbe09605ec1b92541b /net-p2p
parentAdd modified release ebuild for bug #250208, thanks to Corey Beres for the in... (diff)
downloadgentoo-2-75b7304c5e747249eced92bfcad11fb3718b5f89.tar.gz
gentoo-2-75b7304c5e747249eced92bfcad11fb3718b5f89.tar.bz2
gentoo-2-75b7304c5e747249eced92bfcad11fb3718b5f89.zip
Initial ebuild for package which splits core plugins out of vuze package. Later we should build this from source too.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/vuze-coreplugins/ChangeLog11
-rw-r--r--net-p2p/vuze-coreplugins/metadata.xml5
-rw-r--r--net-p2p/vuze-coreplugins/vuze-coreplugins-4.1.0.0.ebuild66
3 files changed, 82 insertions, 0 deletions
diff --git a/net-p2p/vuze-coreplugins/ChangeLog b/net-p2p/vuze-coreplugins/ChangeLog
new file mode 100644
index 000000000000..68767868ca86
--- /dev/null
+++ b/net-p2p/vuze-coreplugins/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-p2p/vuze-coreplugins
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/vuze-coreplugins/ChangeLog,v 1.1 2009/02/06 11:46:18 caster Exp $
+
+*vuze-coreplugins-4.1.0.0 (06 Feb 2009)
+
+ 06 Feb 2009; Vlastimil Babka <caster@gentoo.org> +metadata.xml,
+ +vuze-coreplugins-4.1.0.0.ebuild:
+ Initial ebuild for package which splits core plugins out of vuze package.
+ Later we should build this from source too.
+
diff --git a/net-p2p/vuze-coreplugins/metadata.xml b/net-p2p/vuze-coreplugins/metadata.xml
new file mode 100644
index 000000000000..7303cef96964
--- /dev/null
+++ b/net-p2p/vuze-coreplugins/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>
diff --git a/net-p2p/vuze-coreplugins/vuze-coreplugins-4.1.0.0.ebuild b/net-p2p/vuze-coreplugins/vuze-coreplugins-4.1.0.0.ebuild
new file mode 100644
index 000000000000..0b1ed04e3bde
--- /dev/null
+++ b/net-p2p/vuze-coreplugins/vuze-coreplugins-4.1.0.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/vuze-coreplugins/vuze-coreplugins-4.1.0.0.ebuild,v 1.1 2009/02/06 11:46:18 caster Exp $
+
+# eventually this should be built from source...
+
+EAPI=2
+
+inherit eutils
+
+PLUGINS_N=azplugins
+RATING_N=azrating
+UPDATER_N=azupdater
+UPNPAV_N=azupnpav
+PLUGINS_V=2.1.6
+RATING_V=1.3.1
+UPDATER_V=1.8.8
+UPNPAV_V=0.2.5
+PLUGINS_DIST=${PLUGINS_N}_${PLUGINS_V}.jar
+RATING_DIST=${RATING_N}_${RATING_V}.jar
+UPDATER_DIST=${UPDATER_N}_${UPDATER_V}.zip
+UPNPAV_DIST=${UPNPAV_N}_${UPNPAV_V}.zip
+
+ALLPLUGINS_URL="http://azureus.sourceforge.net/plugins"
+
+DESCRIPTION="Core plugins for Vuze that are included in upstream distribution"
+HOMEPAGE="http://www.vuze.com/"
+SRC_URI="
+ ${ALLPLUGINS_URL}/${PLUGINS_DIST}
+ ${ALLPLUGINS_URL}/${RATING_DIST}
+ ${ALLPLUGINS_URL}/${UPDATER_DIST}
+ ${ALLPLUGINS_URL}/${UPNPAV_DIST}"
+LICENSE="GPL-2 BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="~net-p2p/vuze-${PV}"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ mkdir -p plugins/{${PLUGINS_N},${RATING_N},${UPDATER_N},${UPNPAV_N}} || die
+ cp "${DISTDIR}/${PLUGINS_DIST}" plugins/${PLUGINS_N} || die
+ cp "${DISTDIR}/${RATING_DIST}" plugins/${RATING_N} || die
+ cd "${WORKDIR}/plugins/${UPDATER_N}" && unpack ${UPDATER_DIST} || die
+ cd "${WORKDIR}/plugins/${UPNPAV_N}" && unpack ${UPNPAV_DIST} || die
+}
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/share/vuze/
+ doins -r "${WORKDIR}/plugins"
+}
+
+pkg_postinst() {
+ elog "Since version 4.0.0.2, plugins that are normally bundled by upstream"
+ elog "(and auto-installed in each user's ~/.azureus if not bundled)"
+ elog "are now installed into shared plugin directory by the ebuild."
+ elog "Users are recommended to delete the following plugin copies:"
+ elog "~/.azureus/plugins/{${PLUGINS_N},${RATING_N},${UPDATER_N},${UPNPAV_N}}"
+}