summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2010-12-21 04:27:36 +0000
committerRyan Hill <dirtyepic@gentoo.org>2010-12-21 04:27:36 +0000
commit7635f69a103c5a09a68627082e410a35776fcb88 (patch)
tree0400527d51ae112f6e4448000f6e11c07c683f61 /net-p2p
parentStable on amd64 wrt bug #349163 (diff)
downloadgentoo-2-7635f69a103c5a09a68627082e410a35776fcb88.tar.gz
gentoo-2-7635f69a103c5a09a68627082e410a35776fcb88.tar.bz2
gentoo-2-7635f69a103c5a09a68627082e410a35776fcb88.zip
Version bump. Remove optional packages from USE and RDEPEND as suggested by
mgorny in bug #289904. Remove old. (Portage version: 2.2.0_alpha9/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/nicotine+/ChangeLog9
-rw-r--r--net-p2p/nicotine+/nicotine+-1.2.14.ebuild32
-rw-r--r--net-p2p/nicotine+/nicotine+-1.2.16.ebuild45
3 files changed, 53 insertions, 33 deletions
diff --git a/net-p2p/nicotine+/ChangeLog b/net-p2p/nicotine+/ChangeLog
index 0d3295fd6622..a407dec1fd29 100644
--- a/net-p2p/nicotine+/ChangeLog
+++ b/net-p2p/nicotine+/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-p2p/nicotine+
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/ChangeLog,v 1.49 2010/10/15 19:16:55 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/ChangeLog,v 1.50 2010/12/21 04:27:36 dirtyepic Exp $
+
+*nicotine+-1.2.16 (21 Dec 2010)
+
+ 21 Dec 2010; Ryan Hill <dirtyepic@gentoo.org> -nicotine+-1.2.14.ebuild,
+ +nicotine+-1.2.16.ebuild:
+ Version bump. Remove optional packages from USE and RDEPEND as suggested by
+ mgorny in bug #289904. Remove old.
15 Oct 2010; Brent Baude <ranger@gentoo.org> nicotine+-1.2.15.ebuild:
stable ppc, bug 326495
diff --git a/net-p2p/nicotine+/nicotine+-1.2.14.ebuild b/net-p2p/nicotine+/nicotine+-1.2.14.ebuild
deleted file mode 100644
index 4590a7318a64..000000000000
--- a/net-p2p/nicotine+/nicotine+-1.2.14.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/nicotine+-1.2.14.ebuild,v 1.4 2010/06/01 10:52:00 arfrever Exp $
-
-inherit distutils
-
-DESCRIPTION="A fork of nicotine, a Soulseek client in Python"
-HOMEPAGE="http://nicotine-plus.sourceforge.net"
-#SRC_URI="http://www.nicotine-plus.org/files/${P}.tar.bz2"
-SRC_URI="http://129.125.101.92/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-3 LGPL-3"
-SLOT="0"
-KEYWORDS="amd64 ppc x86 ~x86-fbsd"
-IUSE="geoip spell"
-
-RDEPEND="virtual/python
- >=dev-python/pygtk-2.10
- media-libs/mutagen
- geoip? ( >=dev-python/geoip-python-0.2.0
- >=dev-libs/geoip-1.2.1 )
- spell? ( dev-python/sexy-python )
- !net-p2p/nicotine"
-
-DEPEND="${RDEPEND}"
-
-PYTHON_MODNAME="pynicotine"
-
-src_install() {
- distutils_src_install
- dosym nicotine.py /usr/bin/nicotine
-}
diff --git a/net-p2p/nicotine+/nicotine+-1.2.16.ebuild b/net-p2p/nicotine+/nicotine+-1.2.16.ebuild
new file mode 100644
index 000000000000..e4031d5072fe
--- /dev/null
+++ b/net-p2p/nicotine+/nicotine+-1.2.16.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/nicotine+-1.2.16.ebuild,v 1.1 2010/12/21 04:27:36 dirtyepic Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+
+inherit distutils
+
+DESCRIPTION="A fork of nicotine, a Soulseek client in Python"
+HOMEPAGE="http://nicotine-plus.sourceforge.net"
+SRC_URI="mirror://sourceforge/nicotine-plus/${P}.tar.bz2"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-python/pygtk-2.12"
+
+DEPEND="${RDEPEND}"
+
+PYTHON_MODNAME="pynicotine"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_install() {
+ distutils_src_install
+ python_convert_shebangs -r 2 "${D}"
+ dosym nicotine.py /usr/bin/nicotine
+}
+
+pkg_postinst() {
+ echo
+ elog "You may want to install these packages to add additional features"
+ elog "to Nicotine+:"
+ elog
+ elog "dev-python/geoip-python Country lookup and flag display"
+ elog "dev-python/sexy-python Spellchecking for chat rooms"
+ elog "media-libs/mutagen Media metadata extraction"
+ elog "net-libs/miniupnpc UPnP portmapping"
+ echo
+}