summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIoannis Aslanidis <deathwing00@gentoo.org>2007-02-10 23:04:35 +0000
committerIoannis Aslanidis <deathwing00@gentoo.org>2007-02-10 23:04:35 +0000
commita2a96fbed0c6d92c6a4da6f1a72ec0dd46aed127 (patch)
tree3ca7f6c0afc93ffe8e90e3641dce15a06af7f179 /net-p2p
parentas-needed patch thanks to Alex <nesl247@gmail.com> in bug 162130 (diff)
downloadgentoo-2-a2a96fbed0c6d92c6a4da6f1a72ec0dd46aed127.tar.gz
gentoo-2-a2a96fbed0c6d92c6a4da6f1a72ec0dd46aed127.tar.bz2
gentoo-2-a2a96fbed0c6d92c6a4da6f1a72ec0dd46aed127.zip
Version bump.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/ktorrent/ChangeLog8
-rw-r--r--net-p2p/ktorrent/files/digest-ktorrent-2.13
-rw-r--r--net-p2p/ktorrent/ktorrent-2.1.ebuild48
3 files changed, 58 insertions, 1 deletions
diff --git a/net-p2p/ktorrent/ChangeLog b/net-p2p/ktorrent/ChangeLog
index e8115a7226be..513b5aac06d6 100644
--- a/net-p2p/ktorrent/ChangeLog
+++ b/net-p2p/ktorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/ktorrent
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.31 2007/01/11 17:33:01 masterdriverz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.32 2007/02/10 23:04:35 deathwing00 Exp $
+
+*ktorrent-2.1 (10 Feb 2007)
+
+ 10 Feb 2007; Ioannis Aslanidis <deathwing00@gentoo.org>
+ +ktorrent-2.1.ebuild:
+ Version bump. See details on bug #165674 and the bugs it blocks.
*ktorrent-2.1_rc1 (11 Jan 2007)
diff --git a/net-p2p/ktorrent/files/digest-ktorrent-2.1 b/net-p2p/ktorrent/files/digest-ktorrent-2.1
new file mode 100644
index 000000000000..ee39c8c753c2
--- /dev/null
+++ b/net-p2p/ktorrent/files/digest-ktorrent-2.1
@@ -0,0 +1,3 @@
+MD5 2e3c350fe02b68936a6f8f6460fae8f6 ktorrent-2.1.tar.gz 3459985
+RMD160 d6bff7ec5504dcb2d279f75410c918b2d623963e ktorrent-2.1.tar.gz 3459985
+SHA256 f8c3f4dd7a247d1158570ea71cb7f17e10306cfc34b03c757b6b546a831086d3 ktorrent-2.1.tar.gz 3459985
diff --git a/net-p2p/ktorrent/ktorrent-2.1.ebuild b/net-p2p/ktorrent/ktorrent-2.1.ebuild
new file mode 100644
index 000000000000..7ed981509484
--- /dev/null
+++ b/net-p2p/ktorrent/ktorrent-2.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ktorrent-2.1.ebuild,v 1.1 2007/02/10 23:04:35 deathwing00 Exp $
+
+inherit kde
+
+MY_P="${P/_/}"
+MY_PV="${PV/_/}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A BitTorrent program for KDE."
+HOMEPAGE="http://ktorrent.org/"
+SRC_URI="http://ktorrent.org/downloads/${MY_PV}/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="kdeenablefinal"
+
+DEPEND="dev-libs/gmp"
+
+need-kde 3.4
+
+LANGS="bg br ca cs cy da de el en_GB es et eu fr ga gl hu it ja km lt
+mk ms nb nl pa pl pt pt_BR ru rw sk sr sr@Latn sv tr uk zh_CN zh_TW"
+
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+src_unpack() {
+ kde_src_unpack
+
+ local MAKE_LANGS
+ cd "${WORKDIR}/${MY_P}/translations"
+ for X in ${LANGS} ; do
+ use linguas_${X} && MAKE_LANGS="${MAKE_LANGS} ${X}"
+ done
+ rm -f ${S}/configure
+ sed -i -e "s:SUBDIRS=.*:SUBDIRS=${MAKE_LANGS}:" Makefile.am
+}
+
+
+src_compile(){
+ local myconf="--enable-knetwork"
+ kde_src_compile
+}
+