summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-12-20 22:23:05 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-12-20 22:23:05 +0000
commitbb81f82e4ee1105ccee989e17787d22b870a152d (patch)
tree2d1d073c8ab453de7adc6aee7f7d254577d4edc8 /net-p2p
parentVersion bump. (diff)
downloadgentoo-2-bb81f82e4ee1105ccee989e17787d22b870a152d.tar.gz
gentoo-2-bb81f82e4ee1105ccee989e17787d22b870a152d.tar.bz2
gentoo-2-bb81f82e4ee1105ccee989e17787d22b870a152d.zip
Revbump to revert my previous commit. Thanks to Arfrever
(Portage version: 2.1.11.37/cvs/Linux x86_64, signed Manifest commit with key B4AFF2C2)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/deluge/ChangeLog8
-rw-r--r--net-p2p/deluge/deluge-1.3.5-r2.ebuild (renamed from net-p2p/deluge/deluge-1.3.5-r1.ebuild)14
-rw-r--r--net-p2p/deluge/deluge-9999.ebuild14
3 files changed, 11 insertions, 25 deletions
diff --git a/net-p2p/deluge/ChangeLog b/net-p2p/deluge/ChangeLog
index 6dcf3697e073..fb63d02afdfb 100644
--- a/net-p2p/deluge/ChangeLog
+++ b/net-p2p/deluge/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/deluge
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/ChangeLog,v 1.179 2012/12/20 20:07:24 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/ChangeLog,v 1.180 2012/12/20 22:23:05 hwoarang Exp $
+
+*deluge-1.3.5-r2 (20 Dec 2012)
+
+ 20 Dec 2012; Markos Chandras <hwoarang@gentoo.org> +deluge-1.3.5-r2.ebuild,
+ -deluge-1.3.5-r1.ebuild, deluge-9999.ebuild:
+ Revbump to revert my previous commit. Thanks to Arfrever
20 Dec 2012; Markos Chandras <hwoarang@gentoo.org> deluge-1.3.5-r1.ebuild,
deluge-9999.ebuild:
diff --git a/net-p2p/deluge/deluge-1.3.5-r1.ebuild b/net-p2p/deluge/deluge-1.3.5-r2.ebuild
index e3be2a40e997..d12c4f487204 100644
--- a/net-p2p/deluge/deluge-1.3.5-r1.ebuild
+++ b/net-p2p/deluge/deluge-1.3.5-r2.ebuild
@@ -1,11 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-1.3.5-r1.ebuild,v 1.2 2012/12/20 20:07:24 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-1.3.5-r2.ebuild,v 1.1 2012/12/20 22:23:05 hwoarang Exp $
EAPI="3"
PYTHON_DEPEND="2:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
inherit distutils eutils flag-o-matic python
@@ -39,22 +37,14 @@ RDEPEND="${DEPEND}
setproctitle? ( dev-python/setproctitle )
webinterface? ( dev-python/mako )"
-DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
-
pkg_setup() {
append-ldflags $(no-as-needed)
+ python_set_active_version 2
python_pkg_setup
}
src_prepare() {
distutils_src_prepare
- fix_boost_python() {
- # fix libboost_python. It needs the python ABI on the side. #444522
- sed -i -e "s/'boost_python'/'boost_python-${PYTHON_ABI}'/" setup.py \
- || die "sed setup.py failed"
- }
- python_execute_function -s fix_boost_python
-
python_convert_shebangs -r 2 .
epatch "${FILESDIR}/${P}-rb_libtorrent-disable-python-bindings"
}
diff --git a/net-p2p/deluge/deluge-9999.ebuild b/net-p2p/deluge/deluge-9999.ebuild
index 9226f3acd9e8..61b6c6555655 100644
--- a/net-p2p/deluge/deluge-9999.ebuild
+++ b/net-p2p/deluge/deluge-9999.ebuild
@@ -1,11 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-9999.ebuild,v 1.30 2012/12/20 20:07:24 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-9999.ebuild,v 1.31 2012/12/20 22:23:05 hwoarang Exp $
EAPI="3"
PYTHON_DEPEND="2:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
inherit distutils flag-o-matic git-2
@@ -41,22 +39,14 @@ RDEPEND="${DEPEND}
setproctitle? ( dev-python/setproctitle )
webinterface? ( dev-python/mako )"
-DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
-
pkg_setup() {
append-ldflags $(no-as-needed)
+ python_set_active_version 2
python_pkg_setup
}
src_prepare() {
distutils_src_prepare
- fix_boost_python() {
- # fix libboost_python. It needs the python ABI on the side. #444522
- sed -i -e "s/'boost_python'/'boost_python-${PYTHON_ABI}'/" setup.py \
- || die "sed setup.py failed"
- }
- python_execute_function -s fix_boost_python
-
python_convert_shebangs -r 2 .
}