summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-03-17 18:19:52 +0000
committerHans de Graaff <graaff@gentoo.org>2010-03-17 18:19:52 +0000
commitc10cd45c166853ad88982c769cb2bc7095821291 (patch)
treeeadf3ea864750afb9409beac888c163af22859d3 /net-p2p
parentMask tigervnc snapshot which depends on removed xorg-server. (diff)
downloadgentoo-2-c10cd45c166853ad88982c769cb2bc7095821291.tar.gz
gentoo-2-c10cd45c166853ad88982c769cb2bc7095821291.tar.bz2
gentoo-2-c10cd45c166853ad88982c769cb2bc7095821291.zip
Version bump.
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/gtk-gnutella/ChangeLog10
-rw-r--r--net-p2p/gtk-gnutella/files/gtk-gnutella-0.96.7-ldflags.patch11
-rw-r--r--net-p2p/gtk-gnutella/gtk-gnutella-0.96.7.ebuild62
3 files changed, 81 insertions, 2 deletions
diff --git a/net-p2p/gtk-gnutella/ChangeLog b/net-p2p/gtk-gnutella/ChangeLog
index 2265a5e70291..c3b3d8c6763d 100644
--- a/net-p2p/gtk-gnutella/ChangeLog
+++ b/net-p2p/gtk-gnutella/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/gtk-gnutella
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gtk-gnutella/ChangeLog,v 1.96 2009/07/13 08:06:25 graaff Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gtk-gnutella/ChangeLog,v 1.97 2010/03/17 18:19:51 graaff Exp $
+
+*gtk-gnutella-0.96.7 (17 Mar 2010)
+
+ 17 Mar 2010; Hans de Graaff <graaff@gentoo.org>
+ +gtk-gnutella-0.96.7.ebuild, +files/gtk-gnutella-0.96.7-ldflags.patch:
+ Version bump.
*gtk-gnutella-0.96.6-r1 (13 Jul 2009)
diff --git a/net-p2p/gtk-gnutella/files/gtk-gnutella-0.96.7-ldflags.patch b/net-p2p/gtk-gnutella/files/gtk-gnutella-0.96.7-ldflags.patch
new file mode 100644
index 000000000000..57964a073f2c
--- /dev/null
+++ b/net-p2p/gtk-gnutella/files/gtk-gnutella-0.96.7-ldflags.patch
@@ -0,0 +1,11 @@
+Reset LDFLAGS variable. Fixed upstream in r17379.
+--- src/sdbm/Makefile.SH.orig 2010-03-17 19:08:04.559093208 +0100
++++ src/sdbm/Makefile.SH 2010-03-17 19:08:19.623092585 +0100
+@@ -49,6 +49,7 @@
+ RANLIB = $ranlib
+ RM = $rm -f
+ SED = $sed
++LDFLAGS =
+
+ ########################################################################
+ # Automatically generated parameters -- do not edit
diff --git a/net-p2p/gtk-gnutella/gtk-gnutella-0.96.7.ebuild b/net-p2p/gtk-gnutella/gtk-gnutella-0.96.7.ebuild
new file mode 100644
index 000000000000..be989a5a0443
--- /dev/null
+++ b/net-p2p/gtk-gnutella/gtk-gnutella-0.96.7.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gtk-gnutella/gtk-gnutella-0.96.7.ebuild,v 1.1 2010/03/17 18:19:51 graaff Exp $
+
+EAPI="2"
+
+inherit eutils
+
+IUSE="nls dbus gnutls +gtk"
+
+DESCRIPTION="A GTK+ Gnutella client"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://gtk-gnutella.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+
+RDEPEND=">=dev-libs/libxml2-2.6.0
+ >=x11-libs/gtk+-2.2.1
+ dbus? ( >=sys-apps/dbus-0.35.2 )
+ gnutls? ( >=net-libs/gnutls-1.0.16 )
+ nls? ( >=sys-devel/gettext-0.11.5 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-ldflags.patch"
+}
+
+src_configure() {
+ # The build script does not support the equivalent --enable
+ # options so we must construct the configuration by hand.
+
+ local myconf
+
+ if ! use nls; then
+ myconf="${myconf} --disable-nls"
+ fi
+
+ if ! use dbus; then
+ myconf="${myconf} --disable-dbus"
+ fi
+
+ if ! use gnutls; then
+ myconf="${myconf} --disable-gnutls"
+ fi
+
+ if use gtk; then
+ myconf="${myconf} --gtk2"
+ else
+ myconf="${myconf} --topless"
+ fi
+
+ ./build.sh --configure-only --prefix="/usr" ${myconf}
+}
+
+src_install() {
+ dodir /usr/bin
+ emake INSTALL_PREFIX="${D}" install || die "Install failed"
+ dodoc AUTHORS ChangeLog README TODO
+}