summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-03-16 12:33:19 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-03-16 12:33:19 +0000
commitc6e1e959e50ea2162a8815673de80c811002bacc (patch)
treec3f498117ac5e31eb12e3bd93da31eefa498eece /net-p2p
parenttypo (diff)
downloadgentoo-2-c6e1e959e50ea2162a8815673de80c811002bacc.tar.gz
gentoo-2-c6e1e959e50ea2162a8815673de80c811002bacc.tar.bz2
gentoo-2-c6e1e959e50ea2162a8815673de80c811002bacc.zip
Remove debug flag from build, bug #408483
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitcoind/ChangeLog6
-rw-r--r--net-p2p/bitcoind/bitcoind-0.5.3.ebuild3
-rw-r--r--net-p2p/bitcoind/files/bitcoind-remove-debug.patch12
3 files changed, 19 insertions, 2 deletions
diff --git a/net-p2p/bitcoind/ChangeLog b/net-p2p/bitcoind/ChangeLog
index 73e2bec76437..aa654e51a202 100644
--- a/net-p2p/bitcoind/ChangeLog
+++ b/net-p2p/bitcoind/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/bitcoind
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v 1.14 2012/03/16 12:26:48 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v 1.15 2012/03/16 12:33:19 blueness Exp $
+
+ 16 Mar 2012; Anthony G. Basile <blueness@gentoo.org> bitcoind-0.5.3.ebuild,
+ +files/bitcoind-remove-debug.patch:
+ Remove debug flag from build, bug #408483
16 Mar 2012; Anthony G. Basile <blueness@gentoo.org> bitcoind-0.5.3.ebuild:
Don't call g++ directly, fixes bug #408481
diff --git a/net-p2p/bitcoind/bitcoind-0.5.3.ebuild b/net-p2p/bitcoind/bitcoind-0.5.3.ebuild
index 6448e5a98560..9772f4bf579f 100644
--- a/net-p2p/bitcoind/bitcoind-0.5.3.ebuild
+++ b/net-p2p/bitcoind/bitcoind-0.5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.5.3.ebuild,v 1.3 2012/03/16 12:26:48 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.5.3.ebuild,v 1.4 2012/03/16 12:33:19 blueness Exp $
EAPI="4"
@@ -41,6 +41,7 @@ pkg_setup() {
src_prepare() {
cd src || die
+ epatch "${FILESDIR}"/${PN}-remove-debug.patch
use eligius && epatch "${WORKDIR}/0.5.2-eligius_sendfee.patch"
}
diff --git a/net-p2p/bitcoind/files/bitcoind-remove-debug.patch b/net-p2p/bitcoind/files/bitcoind-remove-debug.patch
new file mode 100644
index 000000000000..27da569a4329
--- /dev/null
+++ b/net-p2p/bitcoind/files/bitcoind-remove-debug.patch
@@ -0,0 +1,12 @@
+diff -Naur bitcoin-bitcoind-stable.orig//src/makefile.unix bitcoin-bitcoind-stable/src/makefile.unix
+--- bitcoin-bitcoind-stable.orig//src/makefile.unix 2012-03-11 22:21:06.000000000 -0400
++++ bitcoin-bitcoind-stable/src/makefile.unix 2012-03-16 08:28:27.000000000 -0400
+@@ -85,7 +85,7 @@
+
+ DEBUGFLAGS=-g
+ CXXFLAGS=-O2
+-xCXXFLAGS=-pthread -Wno-invalid-offsetof -Wformat $(DEBUGFLAGS) $(DEFS) $(HARDENING) $(CXXFLAGS)
++xCXXFLAGS=-pthread -Wno-invalid-offsetof -Wformat $(DEFS) $(HARDENING) $(CXXFLAGS)
+ HEADERS = \
+ base58.h \
+ bignum.h \