summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-06-17 15:01:56 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-06-17 15:01:56 +0000
commitcf308681ddcafcda3b1fec7e0dfeab0296bcde72 (patch)
treead1369b61cc33cd450d79b13d598e5363114717b /net-p2p
parentCleanup mpi deps. Remove sys-cluster/lam-mpi (#324415). Remove special sys-... (diff)
downloadgentoo-2-cf308681ddcafcda3b1fec7e0dfeab0296bcde72.tar.gz
gentoo-2-cf308681ddcafcda3b1fec7e0dfeab0296bcde72.tar.bz2
gentoo-2-cf308681ddcafcda3b1fec7e0dfeab0296bcde72.zip
Bumping beta release
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/ChangeLog8
-rw-r--r--net-p2p/qbittorrent/qbittorrent-2.3.0_beta2.ebuild63
2 files changed, 70 insertions, 1 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index 7f0b5de901ec..858ea78a32ec 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.89 2010/06/17 12:09:12 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.90 2010/06/17 15:01:56 hwoarang Exp $
+
+*qbittorrent-2.3.0_beta2 (17 Jun 2010)
+
+ 17 Jun 2010; Markos Chandras <hwoarang@gentoo.org>
+ +qbittorrent-2.3.0_beta2.ebuild:
+ Bumping beta release
*qbittorrent-2.2.9-r1 (17 Jun 2010)
diff --git a/net-p2p/qbittorrent/qbittorrent-2.3.0_beta2.ebuild b/net-p2p/qbittorrent/qbittorrent-2.3.0_beta2.ebuild
new file mode 100644
index 000000000000..2b7379052647
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-2.3.0_beta2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.3.0_beta2.ebuild,v 1.1 2010/06/17 15:01:56 hwoarang Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+
+inherit python confutils qt4-r2 versionator
+
+MY_P="${P/_/}"
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="http://www.qbittorrent.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+X geoip libnotify"
+
+# boost version so that we always have thread support
+CDEPEND="net-libs/rb_libtorrent
+ x11-libs/qt-core:4
+ X? ( x11-libs/qt-gui:4
+ libnotify? ( x11-libs/qt-gui:4[glib] ) )
+ dev-libs/boost"
+DEPEND="${CDEPEND}
+ dev-util/pkgconfig"
+RDEPEND="${CDEPEND}
+ geoip? ( dev-libs/geoip )
+ libnotify? ( x11-libs/libnotify )"
+
+DOCS="AUTHORS Changelog NEWS README TODO"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ confutils_use_depend_all libnotify X
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # Respect LDFLAGS
+ sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ local myconf
+ use X || myconf+=" --disable-gui"
+ use geoip || myconf+=" --disable-geoip-database"
+ use libnotify || myconf+=" --disable-libnotify"
+
+ # slotted boost detection, bug #309415
+ BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ myconf+=" --with-libboost-inc=/usr/include/boost-${BOOST_VER}"
+
+ # econf fails, since this uses qconf
+ ./configure --prefix=/usr --qtdir=/usr ${myconf} || die "configure failed"
+ eqmake4
+}