summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2010-04-10 16:14:48 +0000
committerBen de Groot <yngwin@gentoo.org>2010-04-10 16:14:48 +0000
commitd26a7d517db1b1b73667b57253349b7e0de9d41c (patch)
tree0008dab638e339e632c5192932f143bfb9acc5c5 /net-p2p
parentFix include path for cdb, #313405 (diff)
downloadgentoo-2-d26a7d517db1b1b73667b57253349b7e0de9d41c.tar.gz
gentoo-2-d26a7d517db1b1b73667b57253349b7e0de9d41c.tar.bz2
gentoo-2-d26a7d517db1b1b73667b57253349b7e0de9d41c.zip
Version bump. Drop conf.pri hack, as the correct values are now detected from the arguments we pass to configure. Fixes bug #313811.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/ChangeLog8
-rw-r--r--net-p2p/qbittorrent/qbittorrent-2.2.5.ebuild57
2 files changed, 64 insertions, 1 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index 9d6d1b62aee4..9ae6eadcdf3a 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.78 2010/04/08 12:35:58 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.79 2010/04/10 16:14:48 yngwin Exp $
+
+*qbittorrent-2.2.5 (10 Apr 2010)
+
+ 10 Apr 2010; Ben de Groot <yngwin@gentoo.org> +qbittorrent-2.2.5.ebuild:
+ Version bump. Drop conf.pri hack, as the correct values are now detected
+ from the arguments we pass to configure. Fixes bug #313811.
08 Apr 2010; Christian Faulhammer <fauli@gentoo.org>
qbittorrent-2.2.2.ebuild:
diff --git a/net-p2p/qbittorrent/qbittorrent-2.2.5.ebuild b/net-p2p/qbittorrent/qbittorrent-2.2.5.ebuild
new file mode 100644
index 000000000000..ad95ee600a9a
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-2.2.5.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.2.5.ebuild,v 1.1 2010/04/10 16:14:48 yngwin Exp $
+
+EAPI="2"
+inherit confutils qt4-r2 versionator
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="http://www.qbittorrent.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+X geoip libnotify"
+
+# boost version so that we always have thread support
+CDEPEND="net-libs/rb_libtorrent
+ x11-libs/qt-core:4
+ X? ( x11-libs/qt-gui:4
+ libnotify? ( x11-libs/qt-gui:4[glib] ) )
+ >=dev-libs/boost-1.34.1"
+DEPEND="${CDEPEND}
+ dev-util/pkgconfig"
+RDEPEND="${CDEPEND}
+ >=dev-lang/python-2.3
+ geoip? ( dev-libs/geoip )
+ libnotify? ( x11-libs/libnotify )"
+
+DOCS="AUTHORS Changelog NEWS README TODO"
+
+pkg_setup() {
+ confutils_use_depend_all libnotify X
+}
+
+src_prepare() {
+ # Respect LDFLAGS
+ sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ local myconf
+ use X || myconf+=" --disable-gui"
+ use geoip || myconf+=" --disable-geoip-database"
+ use libnotify || myconf+=" --disable-libnotify"
+
+ # slotted boost detection, bug #309415
+ BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ myconf+=" --with-libboost-inc=/usr/include/boost-${BOOST_VER}"
+
+ # econf fails, since this uses qconf
+ ./configure --prefix=/usr --qtdir=/usr ${myconf} || die "configure failed"
+ eqmake4
+}