summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2009-09-29 05:32:28 +0000
committerVlastimil Babka <caster@gentoo.org>2009-09-29 05:32:28 +0000
commitd994d87ddab926ba7c3026000ed59e979ee82279 (patch)
tree145f213f489e019027e8d861f7c810a99c525a17 /net-p2p
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-d994d87ddab926ba7c3026000ed59e979ee82279.tar.gz
gentoo-2-d994d87ddab926ba7c3026000ed59e979ee82279.tar.bz2
gentoo-2-d994d87ddab926ba7c3026000ed59e979ee82279.zip
Version bump.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/vuze-coreplugins/ChangeLog8
-rw-r--r--net-p2p/vuze-coreplugins/vuze-coreplugins-4.2.0.8.ebuild66
2 files changed, 73 insertions, 1 deletions
diff --git a/net-p2p/vuze-coreplugins/ChangeLog b/net-p2p/vuze-coreplugins/ChangeLog
index 409347d95c4b..a88fa6c388a0 100644
--- a/net-p2p/vuze-coreplugins/ChangeLog
+++ b/net-p2p/vuze-coreplugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/vuze-coreplugins
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/vuze-coreplugins/ChangeLog,v 1.12 2009/07/13 22:44:40 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/vuze-coreplugins/ChangeLog,v 1.13 2009/09/29 05:32:28 caster Exp $
+
+*vuze-coreplugins-4.2.0.8 (28 Sep 2009)
+
+ 28 Sep 2009; Vlastimil Babka <caster@gentoo.org>
+ +vuze-coreplugins-4.2.0.8.ebuild:
+ Version bump.
*vuze-coreplugins-4.2.0.4 (13 Jul 2009)
diff --git a/net-p2p/vuze-coreplugins/vuze-coreplugins-4.2.0.8.ebuild b/net-p2p/vuze-coreplugins/vuze-coreplugins-4.2.0.8.ebuild
new file mode 100644
index 000000000000..6a3b4bd392de
--- /dev/null
+++ b/net-p2p/vuze-coreplugins/vuze-coreplugins-4.2.0.8.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/vuze-coreplugins/vuze-coreplugins-4.2.0.8.ebuild,v 1.1 2009/09/29 05:32:28 caster Exp $
+
+# eventually this should be built from source...
+
+EAPI=2
+
+inherit eutils
+
+PLUGINS_N=azplugins
+RATING_N=azrating
+UPDATER_N=azupdater
+UPNPAV_N=azupnpav
+PLUGINS_V=2.1.6
+RATING_V=1.3.1
+UPDATER_V=1.8.8
+UPNPAV_V=0.2.23
+PLUGINS_DIST=${PLUGINS_N}_${PLUGINS_V}.jar
+RATING_DIST=${RATING_N}_${RATING_V}.jar
+UPDATER_DIST=${UPDATER_N}_${UPDATER_V}.zip
+UPNPAV_DIST=${UPNPAV_N}_${UPNPAV_V}.zip
+
+ALLPLUGINS_URL="http://azureus.sourceforge.net/plugins"
+
+DESCRIPTION="Core plugins for Vuze that are included in upstream distribution"
+HOMEPAGE="http://www.vuze.com/"
+SRC_URI="
+ ${ALLPLUGINS_URL}/${PLUGINS_DIST}
+ ${ALLPLUGINS_URL}/${RATING_DIST}
+ ${ALLPLUGINS_URL}/${UPDATER_DIST}
+ ${ALLPLUGINS_URL}/${UPNPAV_DIST}"
+LICENSE="GPL-2 BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="~net-p2p/vuze-${PV}"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ mkdir -p plugins/{${PLUGINS_N},${RATING_N},${UPDATER_N},${UPNPAV_N}} || die
+ cp "${DISTDIR}/${PLUGINS_DIST}" plugins/${PLUGINS_N} || die
+ cp "${DISTDIR}/${RATING_DIST}" plugins/${RATING_N} || die
+ cd "${WORKDIR}/plugins/${UPDATER_N}" && unpack ${UPDATER_DIST} || die
+ cd "${WORKDIR}/plugins/${UPNPAV_N}" && unpack ${UPNPAV_DIST} || die
+}
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/share/vuze/
+ doins -r "${WORKDIR}/plugins"
+}
+
+pkg_postinst() {
+ elog "Since version 4.0.0.2, plugins that are normally bundled by upstream"
+ elog "(and auto-installed in each user's ~/.azureus if not bundled)"
+ elog "are now installed into shared plugin directory by the ebuild."
+ elog "Users are recommended to delete the following plugin copies:"
+ elog "~/.azureus/plugins/{${PLUGINS_N},${RATING_N},${UPDATER_N},${UPNPAV_N}}"
+}