summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-01-23 16:06:14 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-01-23 16:06:14 +0000
commitded323948bca848b7801ccef285bb0ace47f211a (patch)
tree89afe9694ba3da8a8807e13082aeef38eb0c28d3 /net-p2p
parentAlways depend on libpcre, upstream forces it from now on. (diff)
downloadgentoo-2-ded323948bca848b7801ccef285bb0ace47f211a.tar.gz
gentoo-2-ded323948bca848b7801ccef285bb0ace47f211a.tar.bz2
gentoo-2-ded323948bca848b7801ccef285bb0ace47f211a.zip
version bump
(Portage version: 2.1.9.33/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/ChangeLog7
-rw-r--r--net-p2p/qbittorrent/qbittorrent-2.6.4.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index c0b426b33adf..9cdfe986d23b 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.136 2011/01/15 15:37:17 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.137 2011/01/23 16:06:14 hwoarang Exp $
+
+*qbittorrent-2.6.4 (23 Jan 2011)
+
+ 23 Jan 2011; Markos Chandras <hwoarang@gentoo.org> +qbittorrent-2.6.4.ebuild:
+ version bump
*qbittorrent-2.6.3 (15 Jan 2011)
diff --git a/net-p2p/qbittorrent/qbittorrent-2.6.4.ebuild b/net-p2p/qbittorrent/qbittorrent-2.6.4.ebuild
new file mode 100644
index 000000000000..ccdd8e39299b
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-2.6.4.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.6.4.ebuild,v 1.1 2011/01/23 16:06:14 hwoarang Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+
+inherit python confutils qt4-r2 versionator
+
+MY_P="${P/_/}"
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="http://www.qbittorrent.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+X geoip libnotify"
+
+# boost version so that we always have thread support
+CDEPEND="net-libs/rb_libtorrent
+ x11-libs/qt-core:4
+ x11-libs/qt-dbus:4
+ X? ( x11-libs/qt-gui:4
+ libnotify? ( x11-libs/qt-gui:4[glib] ) )
+ dev-libs/boost"
+DEPEND="${CDEPEND}
+ dev-util/pkgconfig"
+RDEPEND="${CDEPEND}
+ geoip? ( dev-libs/geoip )
+ libnotify? ( x11-libs/libnotify )"
+
+DOCS="AUTHORS Changelog NEWS README TODO"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ confutils_use_depend_all libnotify X
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # Respect LDFLAGS
+ sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ local myconf
+ use X || myconf+=" --disable-gui"
+ use geoip || myconf+=" --disable-geoip-database"
+ use libnotify || myconf+=" --disable-libnotify"
+
+ # slotted boost detection, bug #309415
+ BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ myconf+=" --with-libboost-inc=/usr/include/boost-${BOOST_VER}"
+
+ # econf fails, since this uses qconf
+ ./configure --prefix=/usr --qtdir=/usr ${myconf} || die "configure failed"
+ eqmake4
+}