summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDror Levin <spatz@gentoo.org>2010-05-27 23:04:38 +0000
committerDror Levin <spatz@gentoo.org>2010-05-27 23:04:38 +0000
commitf4220c3fbb8c83e93d383ba46be740639a2e2885 (patch)
treea503dc60b09fb052ab2464de0342fc6c53267bf5 /net-p2p
parentFix stupid typo (diff)
downloadgentoo-2-f4220c3fbb8c83e93d383ba46be740639a2e2885.tar.gz
gentoo-2-f4220c3fbb8c83e93d383ba46be740639a2e2885.tar.bz2
gentoo-2-f4220c3fbb8c83e93d383ba46be740639a2e2885.zip
Version bump, import ebuild from kde overlay, bug 321395.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/ktorrent/ChangeLog7
-rw-r--r--net-p2p/ktorrent/ktorrent-4.0.0.ebuild83
-rw-r--r--net-p2p/ktorrent/metadata.xml24
3 files changed, 102 insertions, 12 deletions
diff --git a/net-p2p/ktorrent/ChangeLog b/net-p2p/ktorrent/ChangeLog
index f7d10936aea2..2e99e0230910 100644
--- a/net-p2p/ktorrent/ChangeLog
+++ b/net-p2p/ktorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/ktorrent
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.147 2010/05/26 08:35:28 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.148 2010/05/27 23:04:38 spatz Exp $
+
+*ktorrent-4.0.0 (27 May 2010)
+
+ 27 May 2010; Dror Levin <spatz@gentoo.org> +ktorrent-4.0.0.ebuild:
+ Version bump, import ebuild from kde overlay, bug 321395.
26 May 2010; Pacho Ramos <pacho@gentoo.org> ktorrent-3.3.4.ebuild:
Drop KEYWORDS for *9999* due ekeyword bug #321475
diff --git a/net-p2p/ktorrent/ktorrent-4.0.0.ebuild b/net-p2p/ktorrent/ktorrent-4.0.0.ebuild
new file mode 100644
index 000000000000..12799d859238
--- /dev/null
+++ b/net-p2p/ktorrent/ktorrent-4.0.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ktorrent-4.0.0.ebuild,v 1.1 2010/05/27 23:04:38 spatz Exp $
+
+EAPI="2"
+
+KDE_LINGUAS="ar be bg ca cs da de el en_GB es et eu fr ga gl hi hne hr hu is it
+ja km lt lv mai ms nb nds nl nn oc pl pt pt_BR ro ru se sk sl sr sv tr uk zh_CN
+zh_TW"
+
+inherit kde4-base
+
+DESCRIPTION="A BitTorrent program for KDE."
+HOMEPAGE="http://ktorrent.org/"
+SRC_URI="http://ktorrent.org/downloads/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+SLOT="4"
+IUSE="+bwscheduler debug +downloadorder +infowidget +ipfilter +kross +logviewer
++magnetgenerator +mediaplayer plasma rss +scanfolder +search +shutdown +stats
++upnp webinterface +zeroconf"
+
+COMMONDEPEND="
+ >=net-libs/libktorrent-1.0_rc1
+ mediaplayer? ( >=media-libs/taglib-1.5 )
+ plasma? ( >=kde-base/libtaskmanager-${KDE_MINIMAL} )
+ rss? (
+ >=kde-base/kdepimlibs-${KDE_MINIMAL}
+ )
+ shutdown? (
+ >=kde-base/solid-${KDE_MINIMAL}
+ >=kde-base/libkworkspace-${KDE_MINIMAL}
+ )
+"
+DEPEND="${COMMONDEPEND}
+ dev-libs/boost
+ sys-devel/gettext
+"
+RDEPEND="${COMMONDEPEND}
+ infowidget? ( >=dev-libs/geoip-1.4.4 )
+ ipfilter? (
+ app-arch/bzip2
+ app-arch/unzip
+ >=kde-base/kdebase-kioslaves-${KDE_MINIMAL}
+ )
+ kross? ( >=kde-base/krosspython-${KDE_MINIMAL} )
+"
+
+src_prepare() {
+ if ! use plasma; then
+ sed -i \
+ -e "s:add_subdirectory(plasma):#nada:g" \
+ CMakeLists.txt || die "Failed to make plasmoid optional"
+ fi
+
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DENABLE_DHT_SUPPORT=ON
+ -DWITH_SYSTEM_GEOIP=ON
+ $(cmake-utils_use_enable bwscheduler BWSCHEDULER_PLUGIN)
+ $(cmake-utils_use_enable downloadorder DOWNLOADORDER_PLUGIN)
+ $(cmake-utils_use_enable infowidget INFOWIDGET_PLUGIN)
+ $(cmake-utils_use_with infowidget SYSTEM_GEOIP)
+ $(cmake-utils_use_enable ipfilter IPFILTER_PLUGIN)
+ $(cmake-utils_use_enable kross SCRIPTING_PLUGIN)
+ $(cmake-utils_use_enable logviewer LOGVIEWER_PLUGIN)
+ $(cmake-utils_use_enable magnetgenerator MAGNETGENERATOR_PLUGIN)
+ $(cmake-utils_use_enable mediaplayer MEDIAPLAYER_PLUGIN)
+ $(cmake-utils_use_enable rss SYNDICATION_PLUGIN)
+ $(cmake-utils_use_enable scanfolder SCANFOLDER_PLUGIN)
+ $(cmake-utils_use_enable search SEARCH_PLUGIN)
+ $(cmake-utils_use_enable shutdown SHUTDOWN_PLUGIN)
+ $(cmake-utils_use_enable stats STATS_PLUGIN)
+ $(cmake-utils_use_enable upnp UPNP_PLUGIN)
+ $(cmake-utils_use_enable webinterface WEBINTERFACE_PLUGIN)
+ $(cmake-utils_use_enable zeroconf ZEROCONF_PLUGIN)
+ )
+ kde4-base_src_configure
+}
diff --git a/net-p2p/ktorrent/metadata.xml b/net-p2p/ktorrent/metadata.xml
index 8393ba1b2b34..4500d4db5451 100644
--- a/net-p2p/ktorrent/metadata.xml
+++ b/net-p2p/ktorrent/metadata.xml
@@ -8,19 +8,21 @@
<name>deathwing00</name>
</maintainer>
<use>
- <flag name="bwscheduler">Enable the bwscheduler plugin</flag>
- <flag name="downloadorder">Enable plugin for user selected download order</flag>
- <flag name="infowidget">Enable the infowidget plugin</flag>
- <flag name="ipfilter">Enable the ipfilter plugin</flag>
+ <flag name="bwscheduler">Schedule upload and download limits over a period of a week</flag>
+ <flag name="downloadorder">Specify the download order of a multi-file torrent</flag>
<flag name="kross">Enable kross scripting support</flag>
- <flag name="logviewer">Enable the logviewer plugin</flag>
- <flag name="mediaplayer">Enable the mediaplayer plugin</flag>
- <flag name="scanfolder">Enable the scanfolder plugin</flag>
- <flag name="search">Enable the search plugin</flag>
+ <flag name="infowidget">Displays general information about a torrent in several tabs</flag>
+ <flag name="ipfilter">Filter IP addresses through a blocklist</flag>
+ <flag name="logviewer">Displays the logging output</flag>
+ <flag name="magnetgenerator">Generates magnet URI's</flag>
+ <flag name="mediaplayer">Phonon-based media player</flag>
+ <flag name="rss">Syndication plugin for KTorrent, supporting RSS and Atom feeds</flag>
+ <flag name="scanfolder">Scan folders for torrent files and load them</flag>
+ <flag name="search">Search for torrents</flag>
<flag name="shutdown">Shutdown when done</flag>
- <flag name="stats">Enable the statistics plugin</flag>
- <flag name="upnp">Enable the uphp plugin</flag>
- <flag name="webinterface">Enable the webinterface plugin</flag>
+ <flag name="stats">Shows statistics about torrents in several graphs</flag>
+ <flag name="upnp">Forward ports using UPnP</flag>
+ <flag name="webinterface">Allows control of KTorrent via a web interface</flag>
<flag name="zeroconf">Discover peers on the local network using the Zeroconf protocol</flag>
</use>
</pkgmetadata>